AC707 Database

Database AC707 Database
.\SQL2005 > AC707
  • Project Information
  • Object Types
  • Properties
  • Files
Project Information
AbleCommerce 7.0.7 Database Schema
Author | Able Solutions Corporation
Created | 15 July 2011 14:43
Object Types
  • Tables Tables
  • Stored Procedures Stored Procedures
Properties
Property | Value
SQL Server Version | SQL Server 2005
Compatibility Level | SQL Server 2005
Files
Name | Type | Size | File Name
AC707 | Data | 2.00 MB | c:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\AC707.mdf
AC707_log | Log | 1.00 MB | c:\Program Files (x86)\Microsoft SQL Server\MSSQL.1\MSSQL\DATA\AC707_log.ldf
Created 15 July 2011 14:43
Copyright 2011 Able Solutions Corporation, All Rights Reserved


Tables

Tables Tables
.\SQL2005 > AC707 > Tables

Name
dbo.ac_Addresses
dbo.ac_Affiliates
dbo.ac_AuditEvents
dbo.ac_BannedIPs
dbo.ac_BasketCoupons
dbo.ac_BasketItemInputs
dbo.ac_BasketItems
dbo.ac_Baskets
dbo.ac_BasketShipments
dbo.ac_CatalogNodes
dbo.ac_Categories
dbo.ac_CategoryParents
dbo.ac_CategoryVolumeDiscounts
dbo.ac_Countries
dbo.ac_CouponCombos
dbo.ac_CouponGroups
dbo.ac_CouponProducts
dbo.ac_Coupons
dbo.ac_CouponShipMethods
dbo.ac_Currencies
dbo.ac_CustomFields
dbo.ac_CustomUrls
dbo.ac_DigitalGoods
dbo.ac_Downloads
dbo.ac_EmailLists
dbo.ac_EmailListSignups
dbo.ac_EmailListUsers
dbo.ac_EmailTemplates
dbo.ac_EmailTemplateTriggers
dbo.ac_ErrorMessages
dbo.ac_GiftCertificates
dbo.ac_GiftCertificateTransactions
dbo.ac_GroupRoles
dbo.ac_Groups
dbo.ac_InputChoices
dbo.ac_InputFields
dbo.ac_IPLocations
dbo.ac_KitComponents
dbo.ac_KitProducts
dbo.ac_Kits
dbo.ac_LicenseAgreements
dbo.ac_Links
dbo.ac_Manufacturers
dbo.ac_OptionChoices
dbo.ac_Options
dbo.ac_OrderCoupons
dbo.ac_OrderItemDigitalGoods
dbo.ac_OrderItemInputs
dbo.ac_OrderItems
dbo.ac_OrderNotes
dbo.ac_Orders
dbo.ac_OrderShipments
dbo.ac_OrderStatusActions
dbo.ac_OrderStatusEmails
dbo.ac_OrderStatuses
dbo.ac_OrderStatusTriggers
dbo.ac_PageViews
dbo.ac_PaymentGateways
dbo.ac_PaymentMethodGroups
dbo.ac_PaymentMethods
dbo.ac_Payments
dbo.ac_PersonalizationPaths
dbo.ac_ProductAssets
dbo.ac_ProductCustomFields
dbo.ac_ProductDigitalGoods
dbo.ac_ProductImages
dbo.ac_ProductKitComponents
dbo.ac_ProductOptions
dbo.ac_ProductProductTemplates
dbo.ac_ProductReviews
dbo.ac_Products
dbo.ac_ProductTemplateFields
dbo.ac_ProductTemplates
dbo.ac_ProductVariants
dbo.ac_ProductVolumeDiscounts
dbo.ac_Profiles
dbo.ac_Provinces
dbo.ac_Readmes
dbo.ac_Redirects
dbo.ac_RelatedProducts
dbo.ac_ReviewerProfiles
dbo.ac_Roles
dbo.ac_SerialKeys
dbo.ac_SharedPersonalization
dbo.ac_ShipGateways
dbo.ac_ShipMethodGroups
dbo.ac_ShipMethods
dbo.ac_ShipMethodShipZones
dbo.ac_ShipMethodWarehouses
dbo.ac_ShipRateMatrix
dbo.ac_ShipZoneCountries
dbo.ac_ShipZoneProvinces
dbo.ac_ShipZones
dbo.ac_SpecialGroups
dbo.ac_Specials
dbo.ac_Stores
dbo.ac_StoreSettings
dbo.ac_SubscriptionPlans
dbo.ac_Subscriptions
dbo.ac_TaxCodes
dbo.ac_TaxGateways
dbo.ac_TaxRuleGroups
dbo.ac_TaxRules
dbo.ac_TaxRuleShipZones
dbo.ac_TaxRuleTaxCodes
dbo.ac_TrackingNumbers
dbo.ac_Transactions
dbo.ac_UpsellProducts
dbo.ac_UpsOrigin
dbo.ac_UserGroups
dbo.ac_UserPasswords
dbo.ac_UserPersonalization
dbo.ac_Users
dbo.ac_UserSettings
dbo.ac_VendorGroups
dbo.ac_Vendors
dbo.ac_VolumeDiscountGroups
dbo.ac_VolumeDiscountLevels
dbo.ac_VolumeDiscounts
dbo.ac_Warehouses
dbo.ac_Webpages
dbo.ac_WishlistItemInputs
dbo.ac_WishlistItems
dbo.ac_Wishlists
dbo.ac_WrapGroups
dbo.ac_WrapStyles


[dbo].[ac_Addresses]

Tables [dbo].[ac_Addresses]
.\SQL2005 > AC707 > Tables > dbo.ac_Addresses
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:49 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Addresses_PK: AddressId | AddressId | int | 4 | No | 1 - 1
Foreign Keys ac_Users_ac_Addresses_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No |
 | Nickname | nvarchar(100) | 200 | Yes |
 | FirstName | nvarchar(30) | 60 | Yes |
 | LastName | nvarchar(50) | 100 | Yes |
 | Company | nvarchar(50) | 100 | Yes |
 | Address1 | nvarchar(255) | 510 | Yes |
 | Address2 | nvarchar(255) | 510 | Yes |
 | City | nvarchar(50) | 100 | Yes |
 | Province | nvarchar(50) | 100 | Yes |
 | PostalCode | nvarchar(15) | 30 | Yes |
Foreign Keys ac_Countries_ac_Addresses_FK1: [dbo].[ac_Countries].CountryCode | CountryCode | char(2) | 2 | Yes |
 | Phone | nvarchar(50) | 100 | Yes |
 | Fax | nvarchar(50) | 100 | Yes |
 | Email | nvarchar(255) | 510 | Yes |
 | Residence | bit | 1 | No |
 | Validated | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Addresses_PK: AddressId | ac_Addresses_PK | AddressId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Countries_ac_Addresses_FK1 | SetNull | CountryCode->[dbo].[ac_Countries].[CountryCode]
ac_Users_ac_Addresses_FK1 | Cascade | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_Addresses]
(
[AddressId] [int] NOT NULL IDENTITY(1, 1),
[UserId] [int] NOT NULL,
[Nickname] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[FirstName] [nvarchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[LastName] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Company] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Address1] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Address2] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[City] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Province] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PostalCode] [nvarchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Phone] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Fax] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Residence] [bit] NOT NULL,
[Validated] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Addresses] ADD CONSTRAINT [ac_Addresses_PK] PRIMARY KEY CLUSTERED ([AddressId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Addresses] ADD CONSTRAINT [ac_Countries_ac_Addresses_FK1] FOREIGN KEY ([CountryCode]) REFERENCES [dbo].[ac_Countries] ([CountryCode]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Addresses] ADD CONSTRAINT [ac_Users_ac_Addresses_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Countries]
  • [dbo].[ac_Users]
  • dbo
Used By
  • [dbo].[ac_BasketShipments]


[dbo].[ac_Affiliates]

Tables [dbo].[ac_Affiliates]
.\SQL2005 > AC707 > Tables > dbo.ac_Affiliates
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:49 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Affiliates_PK: AffiliateId | AffiliateId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Affiliates_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | PayeeName | nvarchar(100) | 200 | Yes |
 | FirstName | nvarchar(30) | 60 | Yes |
 | LastName | nvarchar(50) | 100 | Yes |
 | Company | nvarchar(50) | 100 | Yes |
 | Address1 | nvarchar(100) | 200 | Yes |
 | Address2 | nvarchar(100) | 200 | Yes |
 | City | nvarchar(50) | 100 | Yes |
 | Province | nvarchar(50) | 100 | Yes |
 | PostalCode | nvarchar(15) | 30 | Yes |
 | CountryCode | char(2) | 2 | Yes |
 | PhoneNumber | nvarchar(50) | 100 | Yes |
 | FaxNumber | nvarchar(50) | 100 | Yes |
 | MobileNumber | nvarchar(50) | 100 | Yes |
 | WebsiteUrl | nvarchar(255) | 510 | Yes |
 | Email | nvarchar(255) | 510 | Yes |
 | CommissionRate | decimal(9,4) | 5 | No |
 | CommissionIsPercent | bit | 1 | No |
 | CommissionOnTotal | bit | 1 | No |
 | ReferralPeriodId | tinyint | 1 | No |
 | ReferralDays | smallint | 2 | No |
Foreign Keys ac_Groups_ac_Affiliates_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Affiliates_PK: AffiliateId | ac_Affiliates_PK | AffiliateId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_Affiliates_FK1 | SetNull | GroupId->[dbo].[ac_Groups].[GroupId]
ac_Stores_ac_Affiliates_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Affiliates]
(
[AffiliateId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[PayeeName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[FirstName] [nvarchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[LastName] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Company] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Address1] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Address2] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[City] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Province] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PostalCode] [nvarchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PhoneNumber] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[FaxNumber] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[MobileNumber] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[WebsiteUrl] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CommissionRate] [decimal] (9, 4) NOT NULL,
[CommissionIsPercent] [bit] NOT NULL,
[CommissionOnTotal] [bit] NOT NULL,
[ReferralPeriodId] [tinyint] NOT NULL,
[ReferralDays] [smallint] NOT NULL,
[GroupId] [int] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Affiliates] ADD CONSTRAINT [ac_Affiliates_PK] PRIMARY KEY CLUSTERED ([AffiliateId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Affiliates] ADD CONSTRAINT [ac_Groups_ac_Affiliates_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Affiliates] ADD CONSTRAINT [ac_Stores_ac_Affiliates_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Orders]
  • [dbo].[ac_Users]


[dbo].[ac_AuditEvents]

Tables [dbo].[ac_AuditEvents]
.\SQL2005 > AC707 > Tables > dbo.ac_AuditEvents
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_AuditLog_PK: AuditEventId | AuditEventId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_AuditEvents_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | EventDate | datetime | 8 | No |
 | EventTypeId | int | 4 | No |
 | Successful | bit | 1 | No |
Foreign Keys ac_Users_ac_Auditlog_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | Yes |
 | RelatedId | int | 4 | Yes |
 | RemoteIP | varchar(39) | 39 | Yes |
 | Comment | nvarchar(max) | max | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_AuditLog_PK: AuditEventId | ac_AuditLog_PK | AuditEventId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Stores_ac_AuditEvents_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
ac_Users_ac_Auditlog_FK1 | SetNull | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_AuditEvents]
(
[AuditEventId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[EventDate] [datetime] NOT NULL,
[EventTypeId] [int] NOT NULL,
[Successful] [bit] NOT NULL,
[UserId] [int] NULL,
[RelatedId] [int] NULL,
[RemoteIP] [varchar] (39) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Comment] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_AuditEvents] ADD CONSTRAINT [ac_AuditLog_PK] PRIMARY KEY CLUSTERED ([AuditEventId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_AuditEvents] ADD CONSTRAINT [ac_Stores_ac_AuditEvents_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
ALTER TABLE [dbo].[ac_AuditEvents] ADD CONSTRAINT [ac_Users_ac_Auditlog_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Stores]
  • [dbo].[ac_Users]
  • dbo


[dbo].[ac_BannedIPs]

Tables [dbo].[ac_BannedIPs]
.\SQL2005 > AC707 > Tables > dbo.ac_BannedIPs
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_BannedIPs_PK: BannedIPId | BannedIPId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_BannedIPs_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | IPRangeStart | bigint | 8 | No |
 | IPRangeEnd | bigint | 8 | No |
 | Comment | nvarchar(100) | 200 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_BannedIPs_PK: BannedIPId | ac_BannedIPs_PK | BannedIPId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_BannedIPs_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_BannedIPs]
(
[BannedIPId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[IPRangeStart] [bigint] NOT NULL,
[IPRangeEnd] [bigint] NOT NULL,
[Comment] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BannedIPs] ADD CONSTRAINT [ac_BannedIPs_PK] PRIMARY KEY CLUSTERED ([BannedIPId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BannedIPs] ADD CONSTRAINT [ac_Stores_ac_BannedIPs_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_BasketCoupons]

Tables [dbo].[ac_BasketCoupons]
.\SQL2005 > AC707 > Tables > dbo.ac_BasketCoupons
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Baskets_ac_BasketCoupons_FK1: [dbo].[ac_Baskets].BasketId | BasketId | int | 4 | No
Foreign Keys ac_Coupons_ac_OrderCouponAssn_FK1: [dbo].[ac_Coupons].CouponId | CouponId | int | 4 | No
 | AppliedDate | datetime | 8 | No
Indexes Indexes
Name | Columns | Unique
ac_BasketCoupons_PK | CouponId, BasketId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Baskets_ac_BasketCoupons_FK1 | Cascade | BasketId->[dbo].[ac_Baskets].[BasketId]
ac_Coupons_ac_OrderCouponAssn_FK1 | Cascade | CouponId->[dbo].[ac_Coupons].[CouponId]
SQL Script
CREATE TABLE [dbo].[ac_BasketCoupons]
(
[BasketId] [int] NOT NULL,
[CouponId] [int] NOT NULL,
[AppliedDate] [datetime] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketCoupons] ADD CONSTRAINT [ac_BasketCoupons_PK] PRIMARY KEY CLUSTERED ([CouponId], [BasketId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketCoupons] ADD CONSTRAINT [ac_Baskets_ac_BasketCoupons_FK1] FOREIGN KEY ([BasketId]) REFERENCES [dbo].[ac_Baskets] ([BasketId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_BasketCoupons] ADD CONSTRAINT [ac_Coupons_ac_OrderCouponAssn_FK1] FOREIGN KEY ([CouponId]) REFERENCES [dbo].[ac_Coupons] ([CouponId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Baskets]
  • [dbo].[ac_Coupons]
  • dbo


[dbo].[ac_BasketItemInputs]

Tables [dbo].[ac_BasketItemInputs]
.\SQL2005 > AC707 > Tables > dbo.ac_BasketItemInputs
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_BasketItemInputs_PK: BasketItemInputId | BasketItemInputId | int | 4 | No | 1 - 1
Foreign Keys ac_BasketItems_ac_BasketItemInputs_FK1: [dbo].[ac_BasketItems].BasketItemId | BasketItemId | int | 4 | No |
Foreign Keys ac_InputFields_ac_BasketItemInputs_FK1: [dbo].[ac_InputFields].InputFieldId | InputFieldId | int | 4 | No |
 | InputValue | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_BasketItemInputs_PK: BasketItemInputId | ac_BasketItemInputs_PK | BasketItemInputId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_BasketItems_ac_BasketItemInputs_FK1 | Cascade | BasketItemId->[dbo].[ac_BasketItems].[BasketItemId]
ac_InputFields_ac_BasketItemInputs_FK1 | Cascade | InputFieldId->[dbo].[ac_InputFields].[InputFieldId]
SQL Script
CREATE TABLE [dbo].[ac_BasketItemInputs]
(
[BasketItemInputId] [int] NOT NULL IDENTITY(1, 1),
[BasketItemId] [int] NOT NULL,
[InputFieldId] [int] NOT NULL,
[InputValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketItemInputs] ADD CONSTRAINT [ac_BasketItemInputs_PK] PRIMARY KEY CLUSTERED ([BasketItemInputId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketItemInputs] ADD CONSTRAINT [ac_BasketItems_ac_BasketItemInputs_FK1] FOREIGN KEY ([BasketItemId]) REFERENCES [dbo].[ac_BasketItems] ([BasketItemId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_BasketItemInputs] ADD CONSTRAINT [ac_InputFields_ac_BasketItemInputs_FK1] FOREIGN KEY ([InputFieldId]) REFERENCES [dbo].[ac_InputFields] ([InputFieldId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_BasketItems]
  • [dbo].[ac_InputFields]
  • dbo


[dbo].[ac_BasketItems]

Tables [dbo].[ac_BasketItems]
.\SQL2005 > AC707 > Tables > dbo.ac_BasketItems
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_BasketItems_PK: BasketItemId | BasketItemId | int | 4 | No | 1 - 1 |
 | ParentItemId | int | 4 | No |  |
Foreign Keys ac_Baskets_ac_BasketItems_FK1: [dbo].[ac_Baskets].BasketId | BasketId | int | 4 | No |  |
 | BasketShipmentId | int | 4 | Yes |  |
Foreign Keys ac_Products_ac_BasketItems_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |  |
 | OptionList | varchar(255) | 255 | Yes |  |
Foreign Keys ac_TaxCodes_ac_BasketItems_FK1: [dbo].[ac_TaxCodes].TaxCodeId | TaxCodeId | int | 4 | Yes |  |
 | Name | nvarchar(255) | 510 | No |  |
 | Sku | nvarchar(100) | 200 | Yes |  |
 | Price | decimal(12,4) | 9 | No |  |
 | Weight | decimal(12,4) | 9 | No |  |
 | Quantity | smallint | 2 | No |  |
 | LineMessage | nvarchar(255) | 510 | Yes |  |
 | OrderItemTypeId | smallint | 2 | No |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Foreign Keys ac_WrapStyles_ac_BasketItems_FK1: [dbo].[ac_WrapStyles].WrapStyleId | WrapStyleId | int | 4 | Yes |  |
 | GiftMessage | nvarchar(255) | 510 | Yes |  |
Foreign Keys ac_WishlistItems_ac_BasketItems_FK1: [dbo].[ac_WishlistItems].WishlistItemId | WishlistItemId | int | 4 | Yes |  |
 | ShippableId | tinyint | 1 | No |  |
 | LastModifiedDate | datetime | 8 | No |  |
 | TaxRate | decimal(12,4) | 9 | No |  |
 | TaxAmount | decimal(12,4) | 9 | No |  |
 | KitList | varchar(255) | 255 | Yes |  |
 | CustomFields | nvarchar(max) | max | Yes |  |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_BasketItems_PK: BasketItemId | ac_BasketItems_PK | BasketItemId | Yes
Foreign Keys Foreign Keys
Name | No Check | Delete | Columns
ac_Baskets_ac_BasketItems_FK1 |  | Cascade | BasketId->[dbo].[ac_Baskets].[BasketId]
ac_Products_ac_BasketItems_FK1 | Yes |  | ProductId->[dbo].[ac_Products].[ProductId]
ac_TaxCodes_ac_BasketItems_FK1 |  | SetNull | TaxCodeId->[dbo].[ac_TaxCodes].[TaxCodeId]
ac_WishlistItems_ac_BasketItems_FK1 |  | SetNull | WishlistItemId->[dbo].[ac_WishlistItems].[WishlistItemId]
ac_WrapStyles_ac_BasketItems_FK1 |  | SetNull | WrapStyleId->[dbo].[ac_WrapStyles].[WrapStyleId]
SQL Script
CREATE TABLE [dbo].[ac_BasketItems]
(
[BasketItemId] [int] NOT NULL IDENTITY(1, 1),
[ParentItemId] [int] NOT NULL,
[BasketId] [int] NOT NULL,
[BasketShipmentId] [int] NULL,
[ProductId] [int] NOT NULL,
[OptionList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[TaxCodeId] [int] NULL,
[Name] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Sku] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Price] [decimal] (12, 4) NOT NULL,
[Weight] [decimal] (12, 4) NOT NULL,
[Quantity] [smallint] NOT NULL,
[LineMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[OrderItemTypeId] [smallint] NOT NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Basket__Order__690797E6] DEFAULT ((0)),
[WrapStyleId] [int] NULL,
[GiftMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[WishlistItemId] [int] NULL,
[ShippableId] [tinyint] NOT NULL,
[LastModifiedDate] [datetime] NOT NULL,
[TaxRate] [decimal] (12, 4) NOT NULL,
[TaxAmount] [decimal] (12, 4) NOT NULL,
[KitList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CustomFields] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketItems] ADD CONSTRAINT [ac_BasketItems_PK] PRIMARY KEY CLUSTERED ([BasketItemId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketItems] ADD CONSTRAINT [ac_Baskets_ac_BasketItems_FK1] FOREIGN KEY ([BasketId]) REFERENCES [dbo].[ac_Baskets] ([BasketId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_BasketItems] WITH NOCHECK ADD CONSTRAINT [ac_Products_ac_BasketItems_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId])
GO
ALTER TABLE [dbo].[ac_BasketItems] ADD CONSTRAINT [ac_TaxCodes_ac_BasketItems_FK1] FOREIGN KEY ([TaxCodeId]) REFERENCES [dbo].[ac_TaxCodes] ([TaxCodeId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_BasketItems] ADD CONSTRAINT [ac_WishlistItems_ac_BasketItems_FK1] FOREIGN KEY ([WishlistItemId]) REFERENCES [dbo].[ac_WishlistItems] ([WishlistItemId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_BasketItems] ADD CONSTRAINT [ac_WrapStyles_ac_BasketItems_FK1] FOREIGN KEY ([WrapStyleId]) REFERENCES [dbo].[ac_WrapStyles] ([WrapStyleId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_BasketItems] NOCHECK CONSTRAINT [ac_Products_ac_BasketItems_FK1]
GO
Uses
  • [dbo].[ac_Baskets]
  • [dbo].[ac_Products]
  • [dbo].[ac_TaxCodes]
  • [dbo].[ac_WishlistItems]
  • [dbo].[ac_WrapStyles]
  • dbo
Used By
  • [dbo].[ac_BasketItemInputs]


[dbo].[ac_Baskets]

Tables [dbo].[ac_Baskets]
.\SQL2005 > AC707 > Tables > dbo.ac_Baskets
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Baskets_PK: BasketId | BasketId | int | 4 | No | 1 - 1
Foreign Keys ac_Users_ac_Baskets_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No |
 | ContentHash | nvarchar(32) | 64 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Baskets_PK: BasketId | ac_Baskets_PK | BasketId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Users_ac_Baskets_FK1 | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_Baskets]
(
[BasketId] [int] NOT NULL IDENTITY(1, 1),
[UserId] [int] NOT NULL,
[ContentHash] [nvarchar] (32) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Baskets] ADD CONSTRAINT [ac_Baskets_PK] PRIMARY KEY CLUSTERED ([BasketId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Baskets] ADD CONSTRAINT [ac_Users_ac_Baskets_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId])
GO
Uses
  • [dbo].[ac_Users]
  • dbo
Used By
  • [dbo].[ac_BasketCoupons]
  • [dbo].[ac_BasketItems]
  • [dbo].[ac_BasketShipments]


[dbo].[ac_BasketShipments]

Tables [dbo].[ac_BasketShipments]
.\SQL2005 > AC707 > Tables > dbo.ac_BasketShipments
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_BasketShipments_PK: BasketShipmentId | BasketShipmentId | int | 4 | No | 1 - 1
Foreign Keys ac_Baskets_ac_BasketShipments_FK1: [dbo].[ac_Baskets].BasketId | BasketId | int | 4 | No |
Foreign Keys ac_Warehouses_ac_BasketShipments_FK1: [dbo].[ac_Warehouses].WarehouseId | WarehouseId | int | 4 | Yes |
Foreign Keys ac_ShipMethods_ac_BasketShipments_FK1: [dbo].[ac_ShipMethods].ShipMethodId | ShipMethodId | int | 4 | Yes |
Foreign Keys ac_Addresses_ac_BasketShipments_FK1: [dbo].[ac_Addresses].AddressId | AddressId | int | 4 | Yes |
 | ShipMessage | nvarchar(255) | 510 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_BasketShipments_PK: BasketShipmentId | ac_BasketShipments_PK | BasketShipmentId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Addresses_ac_BasketShipments_FK1 |  | AddressId->[dbo].[ac_Addresses].[AddressId]
ac_Baskets_ac_BasketShipments_FK1 | Cascade | BasketId->[dbo].[ac_Baskets].[BasketId]
ac_ShipMethods_ac_BasketShipments_FK1 | SetNull | ShipMethodId->[dbo].[ac_ShipMethods].[ShipMethodId]
ac_Warehouses_ac_BasketShipments_FK1 | Cascade | WarehouseId->[dbo].[ac_Warehouses].[WarehouseId]
SQL Script
CREATE TABLE [dbo].[ac_BasketShipments]
(
[BasketShipmentId] [int] NOT NULL IDENTITY(1, 1),
[BasketId] [int] NOT NULL,
[WarehouseId] [int] NULL,
[ShipMethodId] [int] NULL,
[AddressId] [int] NULL,
[ShipMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketShipments] ADD CONSTRAINT [ac_BasketShipments_PK] PRIMARY KEY CLUSTERED ([BasketShipmentId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_BasketShipments] ADD CONSTRAINT [ac_Addresses_ac_BasketShipments_FK1] FOREIGN KEY ([AddressId]) REFERENCES [dbo].[ac_Addresses] ([AddressId])
GO
ALTER TABLE [dbo].[ac_BasketShipments] ADD CONSTRAINT [ac_Baskets_ac_BasketShipments_FK1] FOREIGN KEY ([BasketId]) REFERENCES [dbo].[ac_Baskets] ([BasketId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_BasketShipments] ADD CONSTRAINT [ac_ShipMethods_ac_BasketShipments_FK1] FOREIGN KEY ([ShipMethodId]) REFERENCES [dbo].[ac_ShipMethods] ([ShipMethodId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_BasketShipments] ADD CONSTRAINT [ac_Warehouses_ac_BasketShipments_FK1] FOREIGN KEY ([WarehouseId]) REFERENCES [dbo].[ac_Warehouses] ([WarehouseId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Addresses]
  • [dbo].[ac_Baskets]
  • [dbo].[ac_ShipMethods]
  • [dbo].[ac_Warehouses]
  • dbo


[dbo].[ac_CatalogNodes]

Tables [dbo].[ac_CatalogNodes]
.\SQL2005 > AC707 > Tables > dbo.ac_CatalogNodes
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Default
Foreign Keys ac_Categories_ac_CatalogNodes_FK1: [dbo].[ac_Categories].CategoryId | CategoryId | int | 4 | No |
 | CatalogNodeId | int | 4 | No |
 | CatalogNodeTypeId | tinyint | 1 | No |
 | OrderBy | smallint | 2 | No | ((0))
Indexes Indexes
Name | Columns | Unique
ac_CatalogNodes_PK | CatalogNodeId, CategoryId, CatalogNodeTypeId | Yes
Foreign Keys Foreign Keys
Name | No Check | Columns
ac_Categories_ac_CatalogNodes_FK1 | Yes | CategoryId->[dbo].[ac_Categories].[CategoryId]
SQL Script
CREATE TABLE [dbo].[ac_CatalogNodes]
(
[CategoryId] [int] NOT NULL,
[CatalogNodeId] [int] NOT NULL,
[CatalogNodeTypeId] [tinyint] NOT NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Catalo__Order__625A9A57] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CatalogNodes] ADD CONSTRAINT [ac_CatalogNodes_PK] PRIMARY KEY CLUSTERED ([CatalogNodeId], [CategoryId], [CatalogNodeTypeId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CatalogNodes] WITH NOCHECK ADD CONSTRAINT [ac_Categories_ac_CatalogNodes_FK1] FOREIGN KEY ([CategoryId]) REFERENCES [dbo].[ac_Categories] ([CategoryId])
GO
ALTER TABLE [dbo].[ac_CatalogNodes] NOCHECK CONSTRAINT [ac_Categories_ac_CatalogNodes_FK1]
GO
Uses
  • [dbo].[ac_Categories]
  • dbo


[dbo].[ac_Categories]

Tables [dbo].[ac_Categories]
.\SQL2005 > AC707 > Tables > dbo.ac_Categories
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Categories_PK: CategoryId | CategoryId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Categories_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | ParentId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | Summary | nvarchar(max) | max | Yes |
 | Description | nvarchar(max) | max | Yes |
 | ThumbnailUrl | varchar(255) | 255 | Yes |
 | ThumbnailAltText | nvarchar(255) | 510 | Yes |
 | DisplayPage | varchar(100) | 100 | Yes |
 | Theme | varchar(100) | 100 | Yes |
 | HtmlHead | nvarchar(max) | max | Yes |
 | VisibilityId | tinyint | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Categories_PK: CategoryId | ac_Categories_PK | CategoryId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Categories_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Categories]
(
[CategoryId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[ParentId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Summary] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Description] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ThumbnailUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ThumbnailAltText] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DisplayPage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Theme] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[HtmlHead] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[VisibilityId] [tinyint] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Categories] ADD CONSTRAINT [ac_Categories_PK] PRIMARY KEY CLUSTERED ([CategoryId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Categories] ADD CONSTRAINT [ac_Stores_ac_Categories_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_CatalogNodes]
  • [dbo].[ac_CategoryParents]
  • [dbo].[ac_CategoryVolumeDiscounts]


[dbo].[ac_CategoryParents]

Tables [dbo].[ac_CategoryParents]
.\SQL2005 > AC707 > Tables > dbo.ac_CategoryParents
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Categories_ac_CategoryAssn_FK1: [dbo].[ac_Categories].CategoryId | CategoryId | int | 4 | No
 | ParentId | int | 4 | No
 | ParentLevel | tinyint | 1 | Yes
 | ParentNumber | tinyint | 1 | Yes
Indexes Indexes
Name | Columns | Unique
ac_CategoryParents_PK | CategoryId, ParentId | Yes
Foreign Keys Foreign Keys
Name | No Check | Columns
ac_Categories_ac_CategoryAssn_FK1 | Yes | CategoryId->[dbo].[ac_Categories].[CategoryId]
SQL Script
CREATE TABLE [dbo].[ac_CategoryParents]
(
[CategoryId] [int] NOT NULL,
[ParentId] [int] NOT NULL,
[ParentLevel] [tinyint] NULL,
[ParentNumber] [tinyint] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CategoryParents] ADD CONSTRAINT [ac_CategoryParents_PK] PRIMARY KEY CLUSTERED ([CategoryId], [ParentId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CategoryParents] WITH NOCHECK ADD CONSTRAINT [ac_Categories_ac_CategoryAssn_FK1] FOREIGN KEY ([CategoryId]) REFERENCES [dbo].[ac_Categories] ([CategoryId])
GO
ALTER TABLE [dbo].[ac_CategoryParents] NOCHECK CONSTRAINT [ac_Categories_ac_CategoryAssn_FK1]
GO
Uses
  • [dbo].[ac_Categories]
  • dbo


[dbo].[ac_CategoryVolumeDiscounts]

Tables [dbo].[ac_CategoryVolumeDiscounts]
.\SQL2005 > AC707 > Tables > dbo.ac_CategoryVolumeDiscounts
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Categories_ac_CategoryDiscountAssn_FK1: [dbo].[ac_Categories].CategoryId | CategoryId | int | 4 | No
Foreign Keys ac_Discounts_ac_CategoryDiscountAssn_FK1: [dbo].[ac_VolumeDiscounts].VolumeDiscountId | VolumeDiscountId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_CategoryVolumeDiscounts_PK | CategoryId, VolumeDiscountId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Categories_ac_CategoryDiscountAssn_FK1 | Cascade | CategoryId->[dbo].[ac_Categories].[CategoryId]
ac_Discounts_ac_CategoryDiscountAssn_FK1 | Cascade | VolumeDiscountId->[dbo].[ac_VolumeDiscounts].[VolumeDiscountId]
SQL Script
CREATE TABLE [dbo].[ac_CategoryVolumeDiscounts]
(
[CategoryId] [int] NOT NULL,
[VolumeDiscountId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CategoryVolumeDiscounts] ADD CONSTRAINT [ac_CategoryVolumeDiscounts_PK] PRIMARY KEY CLUSTERED ([CategoryId], [VolumeDiscountId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CategoryVolumeDiscounts] ADD CONSTRAINT [ac_Categories_ac_CategoryDiscountAssn_FK1] FOREIGN KEY ([CategoryId]) REFERENCES [dbo].[ac_Categories] ([CategoryId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_CategoryVolumeDiscounts] ADD CONSTRAINT [ac_Discounts_ac_CategoryDiscountAssn_FK1] FOREIGN KEY ([VolumeDiscountId]) REFERENCES [dbo].[ac_VolumeDiscounts] ([VolumeDiscountId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Categories]
  • [dbo].[ac_VolumeDiscounts]
  • dbo


[dbo].[ac_Countries]

Tables [dbo].[ac_Countries]
.\SQL2005 > AC707 > Tables > dbo.ac_Countries
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Cluster Primary Key ac_Countries_PK: CountryCode | CountryCode | char(2) | 2 | No
Foreign Keys ac_Stores_ac_Countries_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No
 | Name | nvarchar(100) | 200 | No
 | AddressFormat | nvarchar(255) | 510 | Yes
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Countries_PK: CountryCode | ac_Countries_PK | CountryCode | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Countries_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Countries]
(
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[AddressFormat] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Countries] ADD CONSTRAINT [ac_Countries_PK] PRIMARY KEY CLUSTERED ([CountryCode]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Countries] ADD CONSTRAINT [ac_Stores_ac_Countries_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Addresses]
  • [dbo].[ac_Provinces]
  • [dbo].[ac_ShipZoneCountries]
  • [dbo].[ac_Warehouses]


[dbo].[ac_CouponCombos]

Tables [dbo].[ac_CouponCombos]
.\SQL2005 > AC707 > Tables > dbo.ac_CouponCombos
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Coupons_ac_CouponCombos_FK1: [dbo].[ac_Coupons].CouponId | CouponId | int | 4 | No
Foreign Keys ac_Coupons_ac_CouponCombos_FK2: [dbo].[ac_Coupons].ComboCouponId | ComboCouponId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_CouponCombos_PK | CouponId, ComboCouponId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Coupons_ac_CouponCombos_FK1 | Cascade | CouponId->[dbo].[ac_Coupons].[CouponId]
ac_Coupons_ac_CouponCombos_FK2 |  | ComboCouponId->[dbo].[ac_Coupons].[CouponId]
SQL Script
CREATE TABLE [dbo].[ac_CouponCombos]
(
[CouponId] [int] NOT NULL,
[ComboCouponId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponCombos] ADD CONSTRAINT [ac_CouponCombos_PK] PRIMARY KEY CLUSTERED ([CouponId], [ComboCouponId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponCombos] ADD CONSTRAINT [ac_Coupons_ac_CouponCombos_FK1] FOREIGN KEY ([CouponId]) REFERENCES [dbo].[ac_Coupons] ([CouponId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_CouponCombos] ADD CONSTRAINT [ac_Coupons_ac_CouponCombos_FK2] FOREIGN KEY ([ComboCouponId]) REFERENCES [dbo].[ac_Coupons] ([CouponId])
GO
Uses
  • [dbo].[ac_Coupons]
  • [dbo].[ac_Coupons]
  • dbo


[dbo].[ac_CouponGroups]

Tables [dbo].[ac_CouponGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_CouponGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Coupons_ac_CouponGroups_FK1: [dbo].[ac_Coupons].CouponId | CouponId | int | 4 | No
Foreign Keys ac_Groups_ac_CouponGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_CouponGroups_PK | CouponId, GroupId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Coupons_ac_CouponGroups_FK1 | Cascade | CouponId->[dbo].[ac_Coupons].[CouponId]
ac_Groups_ac_CouponGroups_FK1 | Cascade | GroupId->[dbo].[ac_Groups].[GroupId]
SQL Script
CREATE TABLE [dbo].[ac_CouponGroups]
(
[CouponId] [int] NOT NULL,
[GroupId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponGroups] ADD CONSTRAINT [ac_CouponGroups_PK] PRIMARY KEY CLUSTERED ([CouponId], [GroupId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponGroups] ADD CONSTRAINT [ac_Coupons_ac_CouponGroups_FK1] FOREIGN KEY ([CouponId]) REFERENCES [dbo].[ac_Coupons] ([CouponId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_CouponGroups] ADD CONSTRAINT [ac_Groups_ac_CouponGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Coupons]
  • [dbo].[ac_Groups]
  • dbo


[dbo].[ac_CouponProducts]

Tables [dbo].[ac_CouponProducts]
.\SQL2005 > AC707 > Tables > dbo.ac_CouponProducts
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Coupons_ac_CouponProductAssn_FK1: [dbo].[ac_Coupons].CouponId | CouponId | int | 4 | No
Foreign Keys ac_Products_ac_CouponProductAssn_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_CouponProducts_PK | CouponId, ProductId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Coupons_ac_CouponProductAssn_FK1 | Cascade | CouponId->[dbo].[ac_Coupons].[CouponId]
ac_Products_ac_CouponProductAssn_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_CouponProducts]
(
[CouponId] [int] NOT NULL,
[ProductId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponProducts] ADD CONSTRAINT [ac_CouponProducts_PK] PRIMARY KEY CLUSTERED ([CouponId], [ProductId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponProducts] ADD CONSTRAINT [ac_Coupons_ac_CouponProductAssn_FK1] FOREIGN KEY ([CouponId]) REFERENCES [dbo].[ac_Coupons] ([CouponId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_CouponProducts] ADD CONSTRAINT [ac_Products_ac_CouponProductAssn_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Coupons]
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_Coupons]

Tables [dbo].[ac_Coupons]
.\SQL2005 > AC707 > Tables > dbo.ac_Coupons
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Coupons_PK: CouponId | CouponId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Coupons_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | CouponTypeId | tinyint | 1 | Yes |
 | Name | nvarchar(100) | 200 | No |
 | CouponCode | nvarchar(50) | 100 | No |
 | DiscountAmount | decimal(12,4) | 9 | No |
 | IsPercent | bit | 1 | No |
 | MaxValue | decimal(12,4) | 9 | No |
 | MinPurchase | decimal(12,4) | 9 | No |
 | MinQuantity | smallint | 2 | No |
 | MaxQuantity | smallint | 2 | No |
 | QuantityInterval | smallint | 2 | No |
 | MaxUses | smallint | 2 | No |
 | MaxUsesPerCustomer | smallint | 2 | No |
 | StartDate | datetime | 8 | Yes |
 | EndDate | datetime | 8 | Yes |
 | ProductRuleId | tinyint | 1 | No |
 | AllowCombine | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Coupons_PK: CouponId | ac_Coupons_PK | CouponId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Coupons_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Coupons]
(
[CouponId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[CouponTypeId] [tinyint] NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[CouponCode] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[DiscountAmount] [decimal] (12, 4) NOT NULL,
[IsPercent] [bit] NOT NULL,
[MaxValue] [decimal] (12, 4) NOT NULL,
[MinPurchase] [decimal] (12, 4) NOT NULL,
[MinQuantity] [smallint] NOT NULL,
[MaxQuantity] [smallint] NOT NULL,
[QuantityInterval] [smallint] NOT NULL,
[MaxUses] [smallint] NOT NULL,
[MaxUsesPerCustomer] [smallint] NOT NULL,
[StartDate] [datetime] NULL,
[EndDate] [datetime] NULL,
[ProductRuleId] [tinyint] NOT NULL,
[AllowCombine] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Coupons] ADD CONSTRAINT [ac_Coupons_PK] PRIMARY KEY CLUSTERED ([CouponId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Coupons] ADD CONSTRAINT [ac_Stores_ac_Coupons_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_BasketCoupons]
  • [dbo].[ac_CouponCombos]
  • [dbo].[ac_CouponCombos]
  • [dbo].[ac_CouponGroups]
  • [dbo].[ac_CouponProducts]
  • [dbo].[ac_CouponShipMethods]


[dbo].[ac_CouponShipMethods]

Tables [dbo].[ac_CouponShipMethods]
.\SQL2005 > AC707 > Tables > dbo.ac_CouponShipMethods
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Coupons_ac_CouponShipMethods_FK1: [dbo].[ac_Coupons].CouponId | CouponId | int | 4 | No
Foreign Keys ac_ShipMethods_ac_CouponShipMethods_FK1: [dbo].[ac_ShipMethods].ShipMethodId | ShipMethodId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_CouponShipMethods_PK | ShipMethodId, CouponId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Coupons_ac_CouponShipMethods_FK1 | Cascade | CouponId->[dbo].[ac_Coupons].[CouponId]
ac_ShipMethods_ac_CouponShipMethods_FK1 | Cascade | ShipMethodId->[dbo].[ac_ShipMethods].[ShipMethodId]
SQL Script
CREATE TABLE [dbo].[ac_CouponShipMethods]
(
[CouponId] [int] NOT NULL,
[ShipMethodId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponShipMethods] ADD CONSTRAINT [ac_CouponShipMethods_PK] PRIMARY KEY CLUSTERED ([ShipMethodId], [CouponId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CouponShipMethods] ADD CONSTRAINT [ac_Coupons_ac_CouponShipMethods_FK1] FOREIGN KEY ([CouponId]) REFERENCES [dbo].[ac_Coupons] ([CouponId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_CouponShipMethods] ADD CONSTRAINT [ac_ShipMethods_ac_CouponShipMethods_FK1] FOREIGN KEY ([ShipMethodId]) REFERENCES [dbo].[ac_ShipMethods] ([ShipMethodId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Coupons]
  • [dbo].[ac_ShipMethods]
  • dbo


[dbo].[ac_Currencies]

Tables [dbo].[ac_Currencies]
.\SQL2005 > AC707 > Tables > dbo.ac_Currencies
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_Currencies_PK: CurrencyId | CurrencyId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Stores_ac_Currencies_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |  |
 | Name | nvarchar(50) | 100 | No |  |
 | CurrencySymbol | nvarchar(40) | 80 | Yes |  |
 | DecimalDigits | int | 4 | No |  |
 | DecimalSeparator | nvarchar(4) | 8 | Yes |  |
 | GroupSeparator | nvarchar(4) | 8 | Yes |  |
 | GroupSizes | varchar(8) | 8 | Yes |  |
 | NegativePattern | tinyint | 1 | No |  |
 | NegativeSign | varchar(4) | 4 | Yes |  |
 | PositivePattern | tinyint | 1 | No |  |
 | ISOCode | varchar(3) | 3 | No |  |
 | ISOCodePattern | tinyint | 1 | Yes |  |
 | ExchangeRate | decimal(12,4) | 9 | No |  | ((1))
 | AutoUpdate | bit | 1 | No |  |
 | LastUpdate | datetime | 8 | Yes |  |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Currencies_PK: CurrencyId | ac_Currencies_PK | CurrencyId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Currencies_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Currencies]
(
[CurrencyId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[CurrencySymbol] [nvarchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DecimalDigits] [int] NOT NULL,
[DecimalSeparator] [nvarchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[GroupSeparator] [nvarchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[GroupSizes] [varchar] (8) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[NegativePattern] [tinyint] NOT NULL,
[NegativeSign] [varchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PositivePattern] [tinyint] NOT NULL,
[ISOCode] [varchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ISOCodePattern] [tinyint] NULL,
[ExchangeRate] [decimal] (12, 4) NOT NULL CONSTRAINT [DF__ac_Curren__Excha__4E53A1AA] DEFAULT ((1)),
[AutoUpdate] [bit] NOT NULL,
[LastUpdate] [datetime] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Currencies] ADD CONSTRAINT [ac_Currencies_PK] PRIMARY KEY CLUSTERED ([CurrencyId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Currencies] ADD CONSTRAINT [ac_Stores_ac_Currencies_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_CustomFields]

Tables [dbo].[ac_CustomFields]
.\SQL2005 > AC707 > Tables > dbo.ac_CustomFields
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_CustomFields_PK: CustomFieldId | CustomFieldId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_CustomFields_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | TableName | nvarchar(50) | 100 | No |
 | ForeignKeyId | int | 4 | No |
 | FieldName | nvarchar(255) | 510 | No |
 | FieldValue | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_CustomFields_PK: CustomFieldId | ac_CustomFields_PK | CustomFieldId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_CustomFields_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_CustomFields]
(
[CustomFieldId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[TableName] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ForeignKeyId] [int] NOT NULL,
[FieldName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[FieldValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CustomFields] ADD CONSTRAINT [ac_CustomFields_PK] PRIMARY KEY CLUSTERED ([CustomFieldId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CustomFields] ADD CONSTRAINT [ac_Stores_ac_CustomFields_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_CustomUrls]

Tables [dbo].[ac_CustomUrls]
.\SQL2005 > AC707 > Tables > dbo.ac_CustomUrls
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Heap | Yes
Row Count (~) | 0
Created | 2:33:49 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Primary Key ac_CustomUrls_PK: CustomUrlId | CustomUrlId | int | 4 | No | 1 - 1
Foreign Keys ac_CustomUrls_ac_Stores_FK: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | CatalogNodeId | int | 4 | No |
 | CatalogNodeTypeId | tinyint | 1 | No |
 | Url | nvarchar(300) | 600 | No |
Indexes ac_CustomUrls_IX2: LoweredUrl | LoweredUrl | nvarchar(300) | 600 | No |
Indexes Indexes
 | Name | Columns | Unique
Primary Key ac_CustomUrls_PK: CustomUrlId | ac_CustomUrls_PK | CustomUrlId | Yes
 | ac_CustomUrls_IX1 | CatalogNodeId, CatalogNodeTypeId | Yes
 | ac_CustomUrls_IX2 | LoweredUrl | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_CustomUrls_ac_Stores_FK | Cascade | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_CustomUrls]
(
[CustomUrlId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[CatalogNodeId] [int] NOT NULL,
[CatalogNodeTypeId] [tinyint] NOT NULL,
[Url] [nvarchar] (300) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LoweredUrl] [nvarchar] (300) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CustomUrls] ADD CONSTRAINT [ac_CustomUrls_PK] PRIMARY KEY NONCLUSTERED ([CustomUrlId]) ON [PRIMARY]
GO
CREATE UNIQUE NONCLUSTERED INDEX [ac_CustomUrls_IX1] ON [dbo].[ac_CustomUrls] ([CatalogNodeId], [CatalogNodeTypeId]) ON [PRIMARY]
GO
CREATE UNIQUE NONCLUSTERED INDEX [ac_CustomUrls_IX2] ON [dbo].[ac_CustomUrls] ([LoweredUrl]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_CustomUrls] ADD CONSTRAINT [ac_CustomUrls_ac_Stores_FK] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_DigitalGoods]

Tables [dbo].[ac_DigitalGoods]
.\SQL2005 > AC707 > Tables > dbo.ac_DigitalGoods
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_DigitalGoods_PK: DigitalGoodId | DigitalGoodId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_DigitalGoods_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | FileName | nvarchar(100) | 200 | Yes |
 | FileSize | bigint | 8 | No |
 | MaxDownloads | tinyint | 1 | Yes |
 | DownloadTimeout | nvarchar(15) | 30 | Yes |
 | ActivationTimeout | nvarchar(15) | 30 | Yes |
 | MediaKey | nvarchar(100) | 200 | Yes |
 | ServerFileName | varchar(255) | 255 | Yes |
 | EnableSerialKeys | bit | 1 | No |
 | SerialKeyProviderId | varchar(255) | 255 | Yes |
 | SerialKeyConfigData | nvarchar(max) | max | Yes |
 | ActivationModeId | tinyint | 1 | No |
 | ActivationEmailId | int | 4 | Yes |
 | FulfillmentModeId | tinyint | 1 | No |
 | FulfillmentEmailId | int | 4 | Yes |
Foreign Keys ac_Readmes_ac_DigitalGoods_FK1: [dbo].[ac_Readmes].ReadmeId | ReadmeId | int | 4 | Yes |
Foreign Keys ac_LicenseAgreements_ac_DigitalGoods_FK1: [dbo].[ac_LicenseAgreements].LicenseAgreementId | LicenseAgreementId | int | 4 | Yes |
 | LicenseAgreementModeId | tinyint | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_DigitalGoods_PK: DigitalGoodId | ac_DigitalGoods_PK | DigitalGoodId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_LicenseAgreements_ac_DigitalGoods_FK1 | SetNull | LicenseAgreementId->[dbo].[ac_LicenseAgreements].[LicenseAgreementId]
ac_Readmes_ac_DigitalGoods_FK1 | SetNull | ReadmeId->[dbo].[ac_Readmes].[ReadmeId]
ac_Stores_ac_DigitalGoods_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_DigitalGoods]
(
[DigitalGoodId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[FileName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[FileSize] [bigint] NOT NULL,
[MaxDownloads] [tinyint] NULL,
[DownloadTimeout] [nvarchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ActivationTimeout] [nvarchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[MediaKey] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ServerFileName] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[EnableSerialKeys] [bit] NOT NULL,
[SerialKeyProviderId] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[SerialKeyConfigData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ActivationModeId] [tinyint] NOT NULL,
[ActivationEmailId] [int] NULL,
[FulfillmentModeId] [tinyint] NOT NULL,
[FulfillmentEmailId] [int] NULL,
[ReadmeId] [int] NULL,
[LicenseAgreementId] [int] NULL,
[LicenseAgreementModeId] [tinyint] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_DigitalGoods] ADD CONSTRAINT [ac_DigitalGoods_PK] PRIMARY KEY CLUSTERED ([DigitalGoodId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_DigitalGoods] ADD CONSTRAINT [ac_LicenseAgreements_ac_DigitalGoods_FK1] FOREIGN KEY ([LicenseAgreementId]) REFERENCES [dbo].[ac_LicenseAgreements] ([LicenseAgreementId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_DigitalGoods] ADD CONSTRAINT [ac_Readmes_ac_DigitalGoods_FK1] FOREIGN KEY ([ReadmeId]) REFERENCES [dbo].[ac_Readmes] ([ReadmeId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_DigitalGoods] ADD CONSTRAINT [ac_Stores_ac_DigitalGoods_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_LicenseAgreements]
  • [dbo].[ac_Readmes]
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_OrderItemDigitalGoods]
  • [dbo].[ac_ProductDigitalGoods]
  • [dbo].[ac_SerialKeys]


[dbo].[ac_Downloads]

Tables [dbo].[ac_Downloads]
.\SQL2005 > AC707 > Tables > dbo.ac_Downloads
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Downloads_PK: DownloadId | DownloadId | int | 4 | No | 1 - 1
Foreign Keys ac_OrderFiles_ac_Downloads_FK1: [dbo].[ac_OrderItemDigitalGoods].OrderItemDigitalGoodId | OrderItemDigitalGoodId | int | 4 | No |
 | DownloadDate | datetime | 8 | No |
 | RemoteAddr | nvarchar(39) | 78 | No |
 | UserAgent | nvarchar(255) | 510 | No |
 | Referrer | nvarchar(255) | 510 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Downloads_PK: DownloadId | ac_Downloads_PK | DownloadId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_OrderFiles_ac_Downloads_FK1 | Cascade | OrderItemDigitalGoodId->[dbo].[ac_OrderItemDigitalGoods].[OrderItemDigitalGoodId]
SQL Script
CREATE TABLE [dbo].[ac_Downloads]
(
[DownloadId] [int] NOT NULL IDENTITY(1, 1),
[OrderItemDigitalGoodId] [int] NOT NULL,
[DownloadDate] [datetime] NOT NULL,
[RemoteAddr] [nvarchar] (39) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[UserAgent] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Referrer] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Downloads] ADD CONSTRAINT [ac_Downloads_PK] PRIMARY KEY CLUSTERED ([DownloadId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Downloads] ADD CONSTRAINT [ac_OrderFiles_ac_Downloads_FK1] FOREIGN KEY ([OrderItemDigitalGoodId]) REFERENCES [dbo].[ac_OrderItemDigitalGoods] ([OrderItemDigitalGoodId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_OrderItemDigitalGoods]
  • dbo


[dbo].[ac_EmailLists]

Tables [dbo].[ac_EmailLists]
.\SQL2005 > AC707 > Tables > dbo.ac_EmailLists
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_EmailLists_PK: EmailListId | EmailListId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_EmailLists_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | Description | nvarchar(255) | 510 | Yes |
 | IsPublic | bit | 1 | No |
 | SignupRuleId | smallint | 2 | No |
 | SignupEmailTemplateId | int | 4 | Yes |
 | LastSendDate | datetime | 8 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_EmailLists_PK: EmailListId | ac_EmailLists_PK | EmailListId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_EmailLists_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_EmailLists]
(
[EmailListId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Description] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IsPublic] [bit] NOT NULL,
[SignupRuleId] [smallint] NOT NULL,
[SignupEmailTemplateId] [int] NULL,
[LastSendDate] [datetime] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailLists] ADD CONSTRAINT [ac_EmailLists_PK] PRIMARY KEY CLUSTERED ([EmailListId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailLists] ADD CONSTRAINT [ac_Stores_ac_EmailLists_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_EmailListSignups]
  • [dbo].[ac_EmailListUsers]


[dbo].[ac_EmailListSignups]

Tables [dbo].[ac_EmailListSignups]
.\SQL2005 > AC707 > Tables > dbo.ac_EmailListSignups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_EmailListSignups_PK: EmailListSignupId | EmailListSignupId | int | 4 | No | 1 - 1
Foreign Keys ac_EmailLists_ac_EmailListSignups_FK1: [dbo].[ac_EmailLists].EmailListId | EmailListId | int | 4 | No |
 | Email | nvarchar(255) | 510 | No |
 | SignupDate | datetime | 8 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_EmailListSignups_PK: EmailListSignupId | ac_EmailListSignups_PK | EmailListSignupId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_EmailLists_ac_EmailListSignups_FK1 | Cascade | EmailListId->[dbo].[ac_EmailLists].[EmailListId]
SQL Script
CREATE TABLE [dbo].[ac_EmailListSignups]
(
[EmailListSignupId] [int] NOT NULL IDENTITY(1, 1),
[EmailListId] [int] NOT NULL,
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[SignupDate] [datetime] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailListSignups] ADD CONSTRAINT [ac_EmailListSignups_PK] PRIMARY KEY CLUSTERED ([EmailListSignupId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailListSignups] ADD CONSTRAINT [ac_EmailLists_ac_EmailListSignups_FK1] FOREIGN KEY ([EmailListId]) REFERENCES [dbo].[ac_EmailLists] ([EmailListId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_EmailLists]
  • dbo


[dbo].[ac_EmailListUsers]

Tables [dbo].[ac_EmailListUsers]
.\SQL2005 > AC707 > Tables > dbo.ac_EmailListUsers
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_EmailLists_ac_EmailListUsers_FK1: [dbo].[ac_EmailLists].EmailListId | EmailListId | int | 4 | No
 | Email | nvarchar(255) | 510 | No
 | SignupDate | datetime | 8 | No
 | SignupIP | varchar(39) | 39 | Yes
 | LastSendDate | datetime | 8 | Yes
 | FailureCount | smallint | 2 | No
Indexes Indexes
Name | Columns | Unique
ac_EmailListUsers_PK | EmailListId, Email | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_EmailLists_ac_EmailListUsers_FK1 | Cascade | EmailListId->[dbo].[ac_EmailLists].[EmailListId]
SQL Script
CREATE TABLE [dbo].[ac_EmailListUsers]
(
[EmailListId] [int] NOT NULL,
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[SignupDate] [datetime] NOT NULL,
[SignupIP] [varchar] (39) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[LastSendDate] [datetime] NULL,
[FailureCount] [smallint] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailListUsers] ADD CONSTRAINT [ac_EmailListUsers_PK] PRIMARY KEY CLUSTERED ([EmailListId], [Email]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailListUsers] ADD CONSTRAINT [ac_EmailLists_ac_EmailListUsers_FK1] FOREIGN KEY ([EmailListId]) REFERENCES [dbo].[ac_EmailLists] ([EmailListId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_EmailLists]
  • dbo


[dbo].[ac_EmailTemplates]

Tables [dbo].[ac_EmailTemplates]
.\SQL2005 > AC707 > Tables > dbo.ac_EmailTemplates
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_EmailTemplates_PK: EmailTemplateId | EmailTemplateId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Emails_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | ToAddress | nvarchar(255) | 510 | No |
 | FromAddress | nvarchar(255) | 510 | No |
 | ReplyToAddress | nvarchar(255) | 510 | Yes |
 | CCList | nvarchar(255) | 510 | Yes |
 | BCCList | nvarchar(255) | 510 | Yes |
 | Subject | nvarchar(255) | 510 | Yes |
 | ContentFileName | nvarchar(100) | 200 | Yes |
 | IsHTML | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_EmailTemplates_PK: EmailTemplateId | ac_EmailTemplates_PK | EmailTemplateId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Emails_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_EmailTemplates]
(
[EmailTemplateId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ToAddress] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[FromAddress] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ReplyToAddress] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CCList] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BCCList] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Subject] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ContentFileName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IsHTML] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailTemplates] ADD CONSTRAINT [ac_EmailTemplates_PK] PRIMARY KEY CLUSTERED ([EmailTemplateId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailTemplates] ADD CONSTRAINT [ac_Stores_ac_Emails_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_EmailTemplateTriggers]
  • [dbo].[ac_OrderStatusEmails]


[dbo].[ac_EmailTemplateTriggers]

Tables [dbo].[ac_EmailTemplateTriggers]
.\SQL2005 > AC707 > Tables > dbo.ac_EmailTemplateTriggers
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Emails_ac_EmailEventAssn_FK1: [dbo].[ac_EmailTemplates].EmailTemplateId | EmailTemplateId | int | 4 | No
 | StoreEventId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_EmailTemplateTriggers_PK | EmailTemplateId, StoreEventId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Emails_ac_EmailEventAssn_FK1 | Cascade | EmailTemplateId->[dbo].[ac_EmailTemplates].[EmailTemplateId]
SQL Script
CREATE TABLE [dbo].[ac_EmailTemplateTriggers]
(
[EmailTemplateId] [int] NOT NULL,
[StoreEventId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailTemplateTriggers] ADD CONSTRAINT [ac_EmailTemplateTriggers_PK] PRIMARY KEY CLUSTERED ([EmailTemplateId], [StoreEventId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_EmailTemplateTriggers] ADD CONSTRAINT [ac_Emails_ac_EmailEventAssn_FK1] FOREIGN KEY ([EmailTemplateId]) REFERENCES [dbo].[ac_EmailTemplates] ([EmailTemplateId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_EmailTemplates]
  • dbo


[dbo].[ac_ErrorMessages]

Tables [dbo].[ac_ErrorMessages]
.\SQL2005 > AC707 > Tables > dbo.ac_ErrorMessages
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ErrorMessages_PK: ErrorMessageId | ErrorMessageId | int | 4 | No | 1 - 1
 | EntryDate | datetime | 8 | No |
Foreign Keys ac_Stores_ac_ErrorMessages_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | MessageSeverityId | tinyint | 1 | No |
 | Text | nvarchar(255) | 510 | No |
 | DebugData | nvarchar(max) | max | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ErrorMessages_PK: ErrorMessageId | ac_ErrorMessages_PK | ErrorMessageId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_ErrorMessages_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_ErrorMessages]
(
[ErrorMessageId] [int] NOT NULL IDENTITY(1, 1),
[EntryDate] [datetime] NOT NULL,
[StoreId] [int] NOT NULL,
[MessageSeverityId] [tinyint] NOT NULL,
[Text] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[DebugData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ErrorMessages] ADD CONSTRAINT [ac_ErrorMessages_PK] PRIMARY KEY CLUSTERED ([ErrorMessageId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ErrorMessages] ADD CONSTRAINT [ac_Stores_ac_ErrorMessages_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_GiftCertificates]

Tables [dbo].[ac_GiftCertificates]
.\SQL2005 > AC707 > Tables > dbo.ac_GiftCertificates
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_GiftCertificates_PK: GiftCertificateId | GiftCertificateId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_GiftCertificates_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | Yes |
 | SerialNumber | nvarchar(40) | 80 | No |
 | CreatedBy | int | 4 | No |
 | CreateDate | datetime | 8 | No |
Foreign Keys ac_OrderItems_ac_GiftCertificates_FK1: [dbo].[ac_OrderItems].OrderItemId | OrderItemId | int | 4 | Yes |
 | ExpirationDate | datetime | 8 | Yes |
 | Balance | decimal(12,4) | 9 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_GiftCertificates_PK: GiftCertificateId | ac_GiftCertificates_PK | GiftCertificateId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_OrderItems_ac_GiftCertificates_FK1 | SetNull | OrderItemId->[dbo].[ac_OrderItems].[OrderItemId]
ac_Stores_ac_GiftCertificates_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_GiftCertificates]
(
[GiftCertificateId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[SerialNumber] [nvarchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[CreatedBy] [int] NOT NULL,
[CreateDate] [datetime] NOT NULL,
[OrderItemId] [int] NULL,
[ExpirationDate] [datetime] NULL,
[Balance] [decimal] (12, 4) NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_GiftCertificates] ADD CONSTRAINT [ac_GiftCertificates_PK] PRIMARY KEY CLUSTERED ([GiftCertificateId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_GiftCertificates] ADD CONSTRAINT [ac_OrderItems_ac_GiftCertificates_FK1] FOREIGN KEY ([OrderItemId]) REFERENCES [dbo].[ac_OrderItems] ([OrderItemId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_GiftCertificates] ADD CONSTRAINT [ac_Stores_ac_GiftCertificates_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_OrderItems]
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_GiftCertificateTransactions]


[dbo].[ac_GiftCertificateTransactions]

Tables [dbo].[ac_GiftCertificateTransactions]
.\SQL2005 > AC707 > Tables > dbo.ac_GiftCertificateTransactions
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_GiftCertificateTransactions_PK: GiftCertificateTransactionId | GiftCertificateTransactionId | int | 4 | No | 1 - 1
Foreign Keys ac_GiftCertificates_ac_GiftCertificateTransactions_FK1: [dbo].[ac_GiftCertificates].GiftCertificateId | GiftCertificateId | int | 4 | No |
Foreign Keys ac_Orders_ac_GiftCertificateTransactions_FK1: [dbo].[ac_Orders].OrderId | OrderId | int | 4 | Yes |
 | TransactionDate | datetime | 8 | No |
 | Amount | decimal(12,4) | 9 | No |
 | Description | nvarchar(255) | 510 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_GiftCertificateTransactions_PK: GiftCertificateTransactionId | ac_GiftCertificateTransactions_PK | GiftCertificateTransactionId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_GiftCertificates_ac_GiftCertificateTransactions_FK1 | Cascade | GiftCertificateId->[dbo].[ac_GiftCertificates].[GiftCertificateId]
ac_Orders_ac_GiftCertificateTransactions_FK1 | SetNull | OrderId->[dbo].[ac_Orders].[OrderId]
SQL Script
CREATE TABLE [dbo].[ac_GiftCertificateTransactions]
(
[GiftCertificateTransactionId] [int] NOT NULL IDENTITY(1, 1),
[GiftCertificateId] [int] NOT NULL,
[OrderId] [int] NULL,
[TransactionDate] [datetime] NOT NULL,
[Amount] [decimal] (12, 4) NOT NULL,
[Description] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_GiftCertificateTransactions] ADD CONSTRAINT [ac_GiftCertificateTransactions_PK] PRIMARY KEY CLUSTERED ([GiftCertificateTransactionId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_GiftCertificateTransactions] ADD CONSTRAINT [ac_GiftCertificates_ac_GiftCertificateTransactions_FK1] FOREIGN KEY ([GiftCertificateId]) REFERENCES [dbo].[ac_GiftCertificates] ([GiftCertificateId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_GiftCertificateTransactions] ADD CONSTRAINT [ac_Orders_ac_GiftCertificateTransactions_FK1] FOREIGN KEY ([OrderId]) REFERENCES [dbo].[ac_Orders] ([OrderId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_GiftCertificates]
  • [dbo].[ac_Orders]
  • dbo


[dbo].[ac_GroupRoles]

Tables [dbo].[ac_GroupRoles]
.\SQL2005 > AC707 > Tables > dbo.ac_GroupRoles
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Groups_ac_GroupRoles_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Foreign Keys ac_Roles_ac_GroupRoles_FK1: [dbo].[ac_Roles].RoleId | RoleId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_GroupRoles_PK | GroupId, RoleId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_GroupRoles_FK1 | Cascade | GroupId->[dbo].[ac_Groups].[GroupId]
ac_Roles_ac_GroupRoles_FK1 | Cascade | RoleId->[dbo].[ac_Roles].[RoleId]
SQL Script
CREATE TABLE [dbo].[ac_GroupRoles]
(
[GroupId] [int] NOT NULL,
[RoleId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_GroupRoles] ADD CONSTRAINT [ac_GroupRoles_PK] PRIMARY KEY CLUSTERED ([GroupId], [RoleId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_GroupRoles] ADD CONSTRAINT [ac_Groups_ac_GroupRoles_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_GroupRoles] ADD CONSTRAINT [ac_Roles_ac_GroupRoles_FK1] FOREIGN KEY ([RoleId]) REFERENCES [dbo].[ac_Roles] ([RoleId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_Roles]
  • dbo


[dbo].[ac_Groups]

Tables [dbo].[ac_Groups]
.\SQL2005 > AC707 > Tables > dbo.ac_Groups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Groups_PK: GroupId | GroupId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Groups_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | Description | nvarchar(255) | 510 | Yes |
 | IsTaxExempt | bit | 1 | No |
 | IsReadOnly | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Groups_PK: GroupId | ac_Groups_PK | GroupId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Groups_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Groups]
(
[GroupId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Description] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IsTaxExempt] [bit] NOT NULL,
[IsReadOnly] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Groups] ADD CONSTRAINT [ac_Groups_PK] PRIMARY KEY CLUSTERED ([GroupId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Groups] ADD CONSTRAINT [ac_Stores_ac_Groups_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Affiliates]
  • [dbo].[ac_CouponGroups]
  • [dbo].[ac_GroupRoles]
  • [dbo].[ac_PaymentMethodGroups]
  • [dbo].[ac_ShipMethodGroups]
  • [dbo].[ac_SpecialGroups]
  • [dbo].[ac_SubscriptionPlans]
  • [dbo].[ac_TaxRuleGroups]
  • [dbo].[ac_UserGroups]
  • [dbo].[ac_VendorGroups]
  • [dbo].[ac_VolumeDiscountGroups]


[dbo].[ac_InputChoices]

Tables [dbo].[ac_InputChoices]
.\SQL2005 > AC707 > Tables > dbo.ac_InputChoices
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_InputChoices_PK: InputChoiceId | InputChoiceId | int | 4 | No | 1 - 1 |
Foreign Keys ac_InputFields_ac_InputChoices_FK1: [dbo].[ac_InputFields].InputFieldId | InputFieldId | int | 4 | No |  |
 | ChoiceText | nvarchar(100) | 200 | No |  |
 | ChoiceValue | nvarchar(100) | 200 | Yes |  |
 | IsSelected | bit | 1 | No |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_InputChoices_PK: InputChoiceId | ac_InputChoices_PK | InputChoiceId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_InputFields_ac_InputChoices_FK1 | Cascade | InputFieldId->[dbo].[ac_InputFields].[InputFieldId]
SQL Script
CREATE TABLE [dbo].[ac_InputChoices]
(
[InputChoiceId] [int] NOT NULL IDENTITY(1, 1),
[InputFieldId] [int] NOT NULL,
[ChoiceText] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ChoiceValue] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IsSelected] [bit] NOT NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_InputC__Order__3864608B] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_InputChoices] ADD CONSTRAINT [ac_InputChoices_PK] PRIMARY KEY CLUSTERED ([InputChoiceId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_InputChoices] ADD CONSTRAINT [ac_InputFields_ac_InputChoices_FK1] FOREIGN KEY ([InputFieldId]) REFERENCES [dbo].[ac_InputFields] ([InputFieldId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_InputFields]
  • dbo


[dbo].[ac_InputFields]

Tables [dbo].[ac_InputFields]
.\SQL2005 > AC707 > Tables > dbo.ac_InputFields
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_InputFields_PK: InputFieldId | InputFieldId | int | 4 | No | 1 - 1 |
Foreign Keys ac_ProductTemplates_ac_InputFields_FK1: [dbo].[ac_ProductTemplates].ProductTemplateId | ProductTemplateId | int | 4 | No |  |
 | Name | nvarchar(100) | 200 | No |  |
 | UserPrompt | nvarchar(255) | 510 | No |  |
 | InputTypeId | smallint | 2 | No |  |
 | Rows | tinyint | 1 | No |  |
 | Columns | tinyint | 1 | No |  |
 | MaxLength | smallint | 2 | No |  |
 | IsRequired | bit | 1 | No |  |
 | RequiredMessage | nvarchar(max) | max | Yes |  |
 | IsMerchantField | bit | 1 | No |  |
 | PersistWithOrder | bit | 1 | No |  |
 | PromptCssClass | nvarchar(100) | 200 | Yes |  |
 | ControlCssClass | nvarchar(100) | 200 | Yes |  |
 | AdditionalData | nvarchar(255) | 510 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_InputFields_PK: InputFieldId | ac_InputFields_PK | InputFieldId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ProductTemplates_ac_InputFields_FK1 | Cascade | ProductTemplateId->[dbo].[ac_ProductTemplates].[ProductTemplateId]
SQL Script
CREATE TABLE [dbo].[ac_InputFields]
(
[InputFieldId] [int] NOT NULL IDENTITY(1, 1),
[ProductTemplateId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[UserPrompt] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[InputTypeId] [smallint] NOT NULL,
[Rows] [tinyint] NOT NULL,
[Columns] [tinyint] NOT NULL,
[MaxLength] [smallint] NOT NULL,
[IsRequired] [bit] NOT NULL,
[RequiredMessage] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IsMerchantField] [bit] NOT NULL,
[PersistWithOrder] [bit] NOT NULL,
[PromptCssClass] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ControlCssClass] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[AdditionalData] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_InputF__Order__3587F3E0] DEFAULT ((0))
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_InputFields] ADD CONSTRAINT [ac_InputFields_PK] PRIMARY KEY CLUSTERED ([InputFieldId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_InputFields] ADD CONSTRAINT [ac_ProductTemplates_ac_InputFields_FK1] FOREIGN KEY ([ProductTemplateId]) REFERENCES [dbo].[ac_ProductTemplates] ([ProductTemplateId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_ProductTemplates]
  • dbo
Used By
  • [dbo].[ac_BasketItemInputs]
  • [dbo].[ac_InputChoices]
  • [dbo].[ac_ProductTemplateFields]
  • [dbo].[ac_WishlistItemInputs]


[dbo].[ac_IPLocations]

Tables [dbo].[ac_IPLocations]
.\SQL2005 > AC707 > Tables > dbo.ac_IPLocations
  • Properties
  • Columns
  • Indexes
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:48 PM Friday, July 15, 2011
Columns
Name | Data Type | Max Length (Bytes) | Allow Nulls
IPRangeStart | bigint | 8 | No
IPRangeEnd | bigint | 8 | No
CountryCode | char(2) | 2 | No
Region | varchar(128) | 128 | Yes
City | varchar(128) | 128 | Yes
Indexes Indexes
Name | Columns | Unique
ac_IPLocations_PK | IPRangeStart, IPRangeEnd | Yes
SQL Script
CREATE TABLE [dbo].[ac_IPLocations]
(
[IPRangeStart] [bigint] NOT NULL,
[IPRangeEnd] [bigint] NOT NULL,
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Region] [varchar] (128) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[City] [varchar] (128) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_IPLocations] ADD CONSTRAINT [ac_IPLocations_PK] PRIMARY KEY CLUSTERED ([IPRangeStart], [IPRangeEnd]) ON [PRIMARY]
GO
Uses
  • dbo


[dbo].[ac_KitComponents]

Tables [dbo].[ac_KitComponents]
.\SQL2005 > AC707 > Tables > dbo.ac_KitComponents
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_KitComponents_PK: KitComponentId | KitComponentId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_KitComponents_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | UserPrompt | nvarchar(255) | 510 | Yes |
 | InputTypeId | smallint | 2 | No |
 | Columns | tinyint | 1 | No |
 | HeaderOption | nvarchar(100) | 200 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_KitComponents_PK: KitComponentId | ac_KitComponents_PK | KitComponentId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_KitComponents_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_KitComponents]
(
[KitComponentId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[UserPrompt] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[InputTypeId] [smallint] NOT NULL,
[Columns] [tinyint] NOT NULL,
[HeaderOption] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_KitComponents] ADD CONSTRAINT [ac_KitComponents_PK] PRIMARY KEY CLUSTERED ([KitComponentId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_KitComponents] ADD CONSTRAINT [ac_Stores_ac_KitComponents_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_KitProducts]
  • [dbo].[ac_ProductKitComponents]


[dbo].[ac_KitProducts]

Tables [dbo].[ac_KitProducts]
.\SQL2005 > AC707 > Tables > dbo.ac_KitProducts
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_KitProducts_PK: KitProductId | KitProductId | int | 4 | No | 1 - 1 |
Foreign Keys ac_KitComponents_ac_KitProduct_FK1: [dbo].[ac_KitComponents].KitComponentId | KitComponentId | int | 4 | No |  |
 | ProductId | int | 4 | No |  |
 | OptionList | varchar(255) | 255 | Yes |  |
 | Name | nvarchar(255) | 510 | No |  |
 | Quantity | smallint | 2 | No |  |
 | Price | decimal(12,4) | 9 | No |  |
 | PriceModeId | tinyint | 1 | No |  |
 | Weight | decimal(12,4) | 9 | No |  |
 | WeightModeId | tinyint | 1 | No |  |
 | IsSelected | bit | 1 | No |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_KitProducts_PK: KitProductId | ac_KitProducts_PK | KitProductId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_KitComponents_ac_KitProduct_FK1 | Cascade | KitComponentId->[dbo].[ac_KitComponents].[KitComponentId]
SQL Script
CREATE TABLE [dbo].[ac_KitProducts]
(
[KitProductId] [int] NOT NULL IDENTITY(1, 1),
[KitComponentId] [int] NOT NULL,
[ProductId] [int] NOT NULL,
[OptionList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Name] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Quantity] [smallint] NOT NULL,
[Price] [decimal] (12, 4) NOT NULL,
[PriceModeId] [tinyint] NOT NULL,
[Weight] [decimal] (12, 4) NOT NULL,
[WeightModeId] [tinyint] NOT NULL,
[IsSelected] [bit] NOT NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_KitPro__Order__30C33EC3] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_KitProducts] ADD CONSTRAINT [ac_KitProducts_PK] PRIMARY KEY CLUSTERED ([KitProductId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_KitProducts] ADD CONSTRAINT [ac_KitComponents_ac_KitProduct_FK1] FOREIGN KEY ([KitComponentId]) REFERENCES [dbo].[ac_KitComponents] ([KitComponentId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_KitComponents]
  • dbo


[dbo].[ac_Kits]

Tables [dbo].[ac_Kits]
.\SQL2005 > AC707 > Tables > dbo.ac_Kits
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Cluster Primary Key ac_Kits_PK: ProductId Foreign Keys ac_Products_ac_Kits_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
 | ItemizeDisplay | bit | 1 | No
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Kits_PK: ProductId | ac_Kits_PK | ProductId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_Kits_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_Kits]
(
[ProductId] [int] NOT NULL,
[ItemizeDisplay] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Kits] ADD CONSTRAINT [ac_Kits_PK] PRIMARY KEY CLUSTERED ([ProductId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Kits] ADD CONSTRAINT [ac_Products_ac_Kits_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_LicenseAgreements]

Tables [dbo].[ac_LicenseAgreements]
.\SQL2005 > AC707 > Tables > dbo.ac_LicenseAgreements
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_LicenseAgreements_PK: LicenseAgreementId | LicenseAgreementId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_LicenseAgreements_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | DisplayName | nvarchar(100) | 200 | No |
 | AgreementText | nvarchar(max) | max | No |
 | IsHTML | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_LicenseAgreements_PK: LicenseAgreementId | ac_LicenseAgreements_PK | LicenseAgreementId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_LicenseAgreements_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_LicenseAgreements]
(
[LicenseAgreementId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[DisplayName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[AgreementText] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[IsHTML] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_LicenseAgreements] ADD CONSTRAINT [ac_LicenseAgreements_PK] PRIMARY KEY CLUSTERED ([LicenseAgreementId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_LicenseAgreements] ADD CONSTRAINT [ac_Stores_ac_LicenseAgreements_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_DigitalGoods]


[dbo].[ac_Links]

Tables [dbo].[ac_Links]
.\SQL2005 > AC707 > Tables > dbo.ac_Links
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Links_PK: LinkId | LinkId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Links_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | TargetUrl | varchar(255) | 255 | No |
 | TargetWindow | varchar(40) | 40 | Yes |
 | Summary | nvarchar(max) | max | Yes |
 | Description | nvarchar(max) | max | Yes |
 | ThumbnailUrl | varchar(255) | 255 | Yes |
 | ThumbnailAltText | nvarchar(255) | 510 | Yes |
 | DisplayPage | varchar(100) | 100 | Yes |
 | Theme | varchar(100) | 100 | Yes |
 | HtmlHead | nvarchar(max) | max | Yes |
 | VisibilityId | tinyint | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Links_PK: LinkId | ac_Links_PK | LinkId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Links_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Links]
(
[LinkId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[TargetUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[TargetWindow] [varchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Summary] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Description] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ThumbnailUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ThumbnailAltText] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DisplayPage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Theme] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[HtmlHead] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[VisibilityId] [tinyint] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Links] ADD CONSTRAINT [ac_Links_PK] PRIMARY KEY CLUSTERED ([LinkId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Links] ADD CONSTRAINT [ac_Stores_ac_Links_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_Manufacturers]

Tables [dbo].[ac_Manufacturers]
.\SQL2005 > AC707 > Tables > dbo.ac_Manufacturers
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Manufacturers_PK: ManufacturerId | ManufacturerId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Manufacturers_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(255) | 510 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Manufacturers_PK: ManufacturerId | ac_Manufacturers_PK | ManufacturerId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Manufacturers_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Manufacturers]
(
[ManufacturerId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Manufacturers] ADD CONSTRAINT [ac_Manufacturers_PK] PRIMARY KEY CLUSTERED ([ManufacturerId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Manufacturers] ADD CONSTRAINT [ac_Stores_ac_Manufacturers_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Products]


[dbo].[ac_OptionChoices]

Tables [dbo].[ac_OptionChoices]
.\SQL2005 > AC707 > Tables > dbo.ac_OptionChoices
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:49 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_AttributeOptions_PK: OptionChoiceId | OptionChoiceId | int | 4 | No | 1 - 1 |
Foreign Keys ac_ProductAttributes_ac_AttributeOptions_FK1: [dbo].[ac_Options].OptionId | OptionId | int | 4 | No |  |
 | Name | nvarchar(100) | 200 | No |  |
 | ThumbnailUrl | varchar(255) | 255 | Yes |  |
 | ImageUrl | varchar(255) | 255 | Yes |  |
 | PriceModifier | decimal(10,2) | 9 | Yes |  |
 | CogsModifier | decimal(10,2) | 9 | Yes |  |
 | WeightModifier | decimal(10,2) | 9 | Yes |  |
 | SkuModifier | nvarchar(20) | 40 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_AttributeOptions_PK: OptionChoiceId | ac_AttributeOptions_PK | OptionChoiceId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ProductAttributes_ac_AttributeOptions_FK1 | Cascade | OptionId->[dbo].[ac_Options].[OptionId]
SQL Script
CREATE TABLE [dbo].[ac_OptionChoices]
(
[OptionChoiceId] [int] NOT NULL IDENTITY(1, 1),
[OptionId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ThumbnailUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ImageUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PriceModifier] [decimal] (10, 2) NULL,
[CogsModifier] [decimal] (10, 2) NULL,
[WeightModifier] [decimal] (10, 2) NULL,
[SkuModifier] [nvarchar] (20) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Option__Order__73852659] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OptionChoices] ADD CONSTRAINT [ac_AttributeOptions_PK] PRIMARY KEY CLUSTERED ([OptionChoiceId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OptionChoices] ADD CONSTRAINT [ac_ProductAttributes_ac_AttributeOptions_FK1] FOREIGN KEY ([OptionId]) REFERENCES [dbo].[ac_Options] ([OptionId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Options]
  • dbo


[dbo].[ac_Options]

Tables [dbo].[ac_Options]
.\SQL2005 > AC707 > Tables > dbo.ac_Options
  • Properties
  • Columns
  • Indexes
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ProductAttributes_PK: OptionId | OptionId | int | 4 | No | 1 - 1
 | Name | nvarchar(100) | 200 | No |
 | HeaderText | nvarchar(100) | 200 | Yes |
 | ShowThumbnails | bit | 1 | No |
 | ThumbnailColumns | tinyint | 1 | No |
 | ThumbnailWidth | smallint | 2 | No |
 | ThumbnailHeight | smallint | 2 | No |
 | CreatedDate | datetime | 8 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductAttributes_PK: OptionId | ac_ProductAttributes_PK | OptionId | Yes
SQL Script
CREATE TABLE [dbo].[ac_Options]
(
[OptionId] [int] NOT NULL IDENTITY(1, 1),
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[HeaderText] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShowThumbnails] [bit] NOT NULL,
[ThumbnailColumns] [tinyint] NOT NULL,
[ThumbnailWidth] [smallint] NOT NULL,
[ThumbnailHeight] [smallint] NOT NULL,
[CreatedDate] [datetime] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Options] ADD CONSTRAINT [ac_ProductAttributes_PK] PRIMARY KEY CLUSTERED ([OptionId]) ON [PRIMARY]
GO
Uses
  • dbo
Used By
  • [dbo].[ac_OptionChoices]
  • [dbo].[ac_ProductOptions]


[dbo].[ac_OrderCoupons]

Tables [dbo].[ac_OrderCoupons]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderCoupons
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Orders_ac_OrderCoupons_FK1: [dbo].[ac_Orders].OrderId | OrderId | int | 4 | No
 | CouponCode | nvarchar(50) | 100 | No
Indexes Indexes
Name | Columns | Unique
ac_OrderCoupons_PK | CouponCode, OrderId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Orders_ac_OrderCoupons_FK1 | Cascade | OrderId->[dbo].[ac_Orders].[OrderId]
SQL Script
CREATE TABLE [dbo].[ac_OrderCoupons]
(
[OrderId] [int] NOT NULL,
[CouponCode] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderCoupons] ADD CONSTRAINT [ac_OrderCoupons_PK] PRIMARY KEY CLUSTERED ([CouponCode], [OrderId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderCoupons] ADD CONSTRAINT [ac_Orders_ac_OrderCoupons_FK1] FOREIGN KEY ([OrderId]) REFERENCES [dbo].[ac_Orders] ([OrderId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Orders]
  • dbo


[dbo].[ac_OrderItemDigitalGoods]

Tables [dbo].[ac_OrderItemDigitalGoods]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderItemDigitalGoods
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_OrderItemDigitalGoods_PK: OrderItemDigitalGoodId | OrderItemDigitalGoodId | int | 4 | No | 1 - 1
Foreign Keys ac_OrderItems_ac_OrderItemDigitalGoods_FK1: [dbo].[ac_OrderItems].OrderItemId | OrderItemId | int | 4 | No |
Foreign Keys ac_OrderItemDigitalGoods_ac_DigitalGoods_FK1: [dbo].[ac_DigitalGoods].DigitalGoodId | DigitalGoodId | int | 4 | Yes |
 | Name | nvarchar(100) | 200 | Yes |
 | ActivationDate | datetime | 8 | Yes |
 | DownloadDate | datetime | 8 | Yes |
 | SerialKeyData | nvarchar(max) | max | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_OrderItemDigitalGoods_PK: OrderItemDigitalGoodId | ac_OrderItemDigitalGoods_PK | OrderItemDigitalGoodId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_OrderItemDigitalGoods_ac_DigitalGoods_FK1 | SetNull | DigitalGoodId->[dbo].[ac_DigitalGoods].[DigitalGoodId]
ac_OrderItems_ac_OrderItemDigitalGoods_FK1 | Cascade | OrderItemId->[dbo].[ac_OrderItems].[OrderItemId]
SQL Script
CREATE TABLE [dbo].[ac_OrderItemDigitalGoods]
(
[OrderItemDigitalGoodId] [int] NOT NULL IDENTITY(1, 1),
[OrderItemId] [int] NOT NULL,
[DigitalGoodId] [int] NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ActivationDate] [datetime] NULL,
[DownloadDate] [datetime] NULL,
[SerialKeyData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderItemDigitalGoods] ADD CONSTRAINT [ac_OrderItemDigitalGoods_PK] PRIMARY KEY CLUSTERED ([OrderItemDigitalGoodId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderItemDigitalGoods] ADD CONSTRAINT [ac_OrderItemDigitalGoods_ac_DigitalGoods_FK1] FOREIGN KEY ([DigitalGoodId]) REFERENCES [dbo].[ac_DigitalGoods] ([DigitalGoodId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_OrderItemDigitalGoods] ADD CONSTRAINT [ac_OrderItems_ac_OrderItemDigitalGoods_FK1] FOREIGN KEY ([OrderItemId]) REFERENCES [dbo].[ac_OrderItems] ([OrderItemId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_DigitalGoods]
  • [dbo].[ac_OrderItems]
  • dbo
Used By
  • [dbo].[ac_Downloads]


[dbo].[ac_OrderItemInputs]

Tables [dbo].[ac_OrderItemInputs]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderItemInputs
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_OrderItemInputs_PK: OrderItemInputId | OrderItemInputId | int | 4 | No | 1 - 1
Foreign Keys ac_OrderItems_ac_OrderItemInputs_FK1: [dbo].[ac_OrderItems].OrderItemId | OrderItemId | int | 4 | No |
 | IsMerchantField | bit | 1 | No |
 | Name | nvarchar(100) | 200 | No |
 | InputValue | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_OrderItemInputs_PK: OrderItemInputId | ac_OrderItemInputs_PK | OrderItemInputId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_OrderItems_ac_OrderItemInputs_FK1 | Cascade | OrderItemId->[dbo].[ac_OrderItems].[OrderItemId]
SQL Script
CREATE TABLE [dbo].[ac_OrderItemInputs]
(
[OrderItemInputId] [int] NOT NULL IDENTITY(1, 1),
[OrderItemId] [int] NOT NULL,
[IsMerchantField] [bit] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[InputValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderItemInputs] ADD CONSTRAINT [ac_OrderItemInputs_PK] PRIMARY KEY CLUSTERED ([OrderItemInputId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderItemInputs] ADD CONSTRAINT [ac_OrderItems_ac_OrderItemInputs_FK1] FOREIGN KEY ([OrderItemId]) REFERENCES [dbo].[ac_OrderItems] ([OrderItemId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_OrderItems]
  • dbo


[dbo].[ac_OrderItems]

Tables [dbo].[ac_OrderItems]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderItems
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_OrderItems_PK: OrderItemId | OrderItemId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Orders_ac_OrderItems_FK1: [dbo].[ac_Orders].OrderId | OrderId | int | 4 | No |  |
 | ParentItemId | int | 4 | Yes |  |
 | OrderItemTypeId | smallint | 2 | No |  |
 | ShippableId | tinyint | 1 | No |  |
Foreign Keys ac_OrderShipments_ac_OrderItems_FK1: [dbo].[ac_OrderShipments].OrderShipmentId | OrderShipmentId | int | 4 | Yes |  |
Foreign Keys ac_Products_ac_OrderItems_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | Yes |  |
 | Name | nvarchar(255) | 510 | No |  |
 | OptionList | varchar(255) | 255 | Yes |  |
 | VariantName | nvarchar(255) | 510 | Yes |  |
 | Sku | nvarchar(100) | 200 | Yes |  |
 | Price | decimal(12,4) | 9 | No |  |
 | Weight | decimal(12,4) | 9 | No |  |
 | CostOfGoods | decimal(12,4) | 9 | No |  |
 | Quantity | smallint | 2 | No |  |
 | LineMessage | nvarchar(255) | 510 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
 | GiftMessage | nvarchar(255) | 510 | Yes |  |
Foreign Keys ac_TaxCodes_ac_OrderItems_FK1: [dbo].[ac_TaxCodes].TaxCodeId | TaxCodeId | int | 4 | Yes |  |
Foreign Keys ac_WrapStyles_ac_OrderItems_FK1: [dbo].[ac_WrapStyles].WrapStyleId | WrapStyleId | int | 4 | Yes |  |
Foreign Keys ac_WishlistItems_ac_OrderItems_FK1: [dbo].[ac_WishlistItems].WishlistItemId | WishlistItemId | int | 4 | Yes |  |
 | InventoryStatusId | smallint | 2 | No |  |
 | TaxRate | decimal(12,4) | 9 | No |  |
 | TaxAmount | decimal(12,4) | 9 | No |  |
 | KitList | varchar(255) | 255 | Yes |  |
 | CustomFields | nvarchar(max) | max | Yes |  |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_OrderItems_PK: OrderItemId | ac_OrderItems_PK | OrderItemId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Orders_ac_OrderItems_FK1 | Cascade | OrderId->[dbo].[ac_Orders].[OrderId]
ac_OrderShipments_ac_OrderItems_FK1 |  | OrderShipmentId->[dbo].[ac_OrderShipments].[OrderShipmentId]
ac_Products_ac_OrderItems_FK1 | SetNull | ProductId->[dbo].[ac_Products].[ProductId]
ac_TaxCodes_ac_OrderItems_FK1 | SetNull | TaxCodeId->[dbo].[ac_TaxCodes].[TaxCodeId]
ac_WishlistItems_ac_OrderItems_FK1 | SetNull | WishlistItemId->[dbo].[ac_WishlistItems].[WishlistItemId]
ac_WrapStyles_ac_OrderItems_FK1 | SetNull | WrapStyleId->[dbo].[ac_WrapStyles].[WrapStyleId]
SQL Script
CREATE TABLE [dbo].[ac_OrderItems]
(
[OrderItemId] [int] NOT NULL IDENTITY(1, 1),
[OrderId] [int] NOT NULL,
[ParentItemId] [int] NULL,
[OrderItemTypeId] [smallint] NOT NULL,
[ShippableId] [tinyint] NOT NULL,
[OrderShipmentId] [int] NULL,
[ProductId] [int] NULL,
[Name] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[OptionList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[VariantName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Sku] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Price] [decimal] (12, 4) NOT NULL,
[Weight] [decimal] (12, 4) NOT NULL,
[CostOfGoods] [decimal] (12, 4) NOT NULL,
[Quantity] [smallint] NOT NULL,
[LineMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_OrderI__Order__208CD6FA] DEFAULT ((0)),
[GiftMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[TaxCodeId] [int] NULL,
[WrapStyleId] [int] NULL,
[WishlistItemId] [int] NULL,
[InventoryStatusId] [smallint] NOT NULL,
[TaxRate] [decimal] (12, 4) NOT NULL,
[TaxAmount] [decimal] (12, 4) NOT NULL,
[KitList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CustomFields] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderItems] ADD CONSTRAINT [ac_OrderItems_PK] PRIMARY KEY CLUSTERED ([OrderItemId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderItems] ADD CONSTRAINT [ac_Orders_ac_OrderItems_FK1] FOREIGN KEY ([OrderId]) REFERENCES [dbo].[ac_Orders] ([OrderId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_OrderItems] ADD CONSTRAINT [ac_OrderShipments_ac_OrderItems_FK1] FOREIGN KEY ([OrderShipmentId]) REFERENCES [dbo].[ac_OrderShipments] ([OrderShipmentId])
GO
ALTER TABLE [dbo].[ac_OrderItems] ADD CONSTRAINT [ac_Products_ac_OrderItems_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_OrderItems] ADD CONSTRAINT [ac_TaxCodes_ac_OrderItems_FK1] FOREIGN KEY ([TaxCodeId]) REFERENCES [dbo].[ac_TaxCodes] ([TaxCodeId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_OrderItems] ADD CONSTRAINT [ac_WishlistItems_ac_OrderItems_FK1] FOREIGN KEY ([WishlistItemId]) REFERENCES [dbo].[ac_WishlistItems] ([WishlistItemId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_OrderItems] ADD CONSTRAINT [ac_WrapStyles_ac_OrderItems_FK1] FOREIGN KEY ([WrapStyleId]) REFERENCES [dbo].[ac_WrapStyles] ([WrapStyleId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Orders]
  • [dbo].[ac_OrderShipments]
  • [dbo].[ac_Products]
  • [dbo].[ac_TaxCodes]
  • [dbo].[ac_WishlistItems]
  • [dbo].[ac_WrapStyles]
  • dbo
Used By
  • [dbo].[ac_GiftCertificates]
  • [dbo].[ac_OrderItemDigitalGoods]
  • [dbo].[ac_OrderItemInputs]
  • [dbo].[ac_Subscriptions]


[dbo].[ac_OrderNotes]

Tables [dbo].[ac_OrderNotes]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderNotes
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_OrderNotes_PK: OrderNoteId | OrderNoteId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Orders_ac_OrderNotes_FK1: [dbo].[ac_Orders].OrderId | OrderId | int | 4 | No |  |
Foreign Keys ac_Users_ac_OrderNotes_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | Yes |  |
 | CreatedDate | datetime | 8 | No |  |
 | Comment | nvarchar(max) | max | No |  |
 | IsRead | bit | 1 | No |  | ((1))
 | NoteTypeId | tinyint | 1 | No |  |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_OrderNotes_PK: OrderNoteId | ac_OrderNotes_PK | OrderNoteId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Orders_ac_OrderNotes_FK1 | Cascade | OrderId->[dbo].[ac_Orders].[OrderId]
ac_Users_ac_OrderNotes_FK1 | SetNull | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_OrderNotes]
(
[OrderNoteId] [int] NOT NULL IDENTITY(1, 1),
[OrderId] [int] NOT NULL,
[UserId] [int] NULL,
[CreatedDate] [datetime] NOT NULL,
[Comment] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[IsRead] [bit] NOT NULL CONSTRAINT [DF__ac_OrderN__IsRea__1DB06A4F] DEFAULT ((1)),
[NoteTypeId] [tinyint] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderNotes] ADD CONSTRAINT [ac_OrderNotes_PK] PRIMARY KEY CLUSTERED ([OrderNoteId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderNotes] ADD CONSTRAINT [ac_Orders_ac_OrderNotes_FK1] FOREIGN KEY ([OrderId]) REFERENCES [dbo].[ac_Orders] ([OrderId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_OrderNotes] ADD CONSTRAINT [ac_Users_ac_OrderNotes_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Orders]
  • [dbo].[ac_Users]
  • dbo


[dbo].[ac_Orders]

Tables [dbo].[ac_Orders]
.\SQL2005 > AC707 > Tables > dbo.ac_Orders
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Orders_PK: OrderId | OrderId | int | 4 | No | 1 - 1
 | OrderNumber | int | 4 | No |
 | OrderDate | datetime | 8 | No |
Foreign Keys ac_Stores_ac_Orders_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
Foreign Keys ac_Users_ac_Orders_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | Yes |
Foreign Keys ac_Affiliates_ac_Orders_FK1: [dbo].[ac_Affiliates].AffiliateId | AffiliateId | int | 4 | Yes |
 | BillToFirstName | nvarchar(30) | 60 | Yes |
 | BillToLastName | nvarchar(50) | 100 | Yes |
 | BillToCompany | nvarchar(50) | 100 | Yes |
 | BillToAddress1 | nvarchar(255) | 510 | Yes |
 | BillToAddress2 | nvarchar(255) | 510 | Yes |
 | BillToCity | nvarchar(50) | 100 | Yes |
 | BillToProvince | nvarchar(50) | 100 | Yes |
 | BillToPostalCode | nvarchar(15) | 30 | Yes |
 | BillToCountryCode | nchar(2) | 4 | Yes |
 | BillToPhone | nvarchar(50) | 100 | Yes |
 | BillToFax | nvarchar(50) | 100 | Yes |
 | BillToEmail | nvarchar(255) | 510 | Yes |
 | ProductSubtotal | decimal(12,4) | 9 | No |
 | TotalCharges | decimal(12,4) | 9 | No |
 | TotalPayments | decimal(12,4) | 9 | No |
Foreign Keys ac_OrderStatuses_ac_Orders_FK1: [dbo].[ac_OrderStatuses].OrderStatusId | OrderStatusId | int | 4 | No |
 | Exported | bit | 1 | No |
 | RemoteIP | varchar(39) | 39 | Yes |
 | Referrer | nvarchar(255) | 510 | Yes |
 | GoogleOrderNumber | nvarchar(50) | 100 | Yes |
 | PaymentStatusId | tinyint | 1 | No |
 | ShipmentStatusId | tinyint | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Orders_PK: OrderId | ac_Orders_PK | OrderId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Affiliates_ac_Orders_FK1 | SetNull | AffiliateId->[dbo].[ac_Affiliates].[AffiliateId]
ac_OrderStatuses_ac_Orders_FK1 |  | OrderStatusId->[dbo].[ac_OrderStatuses].[OrderStatusId]
ac_Stores_ac_Orders_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
ac_Users_ac_Orders_FK1 | SetNull | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_Orders]
(
[OrderId] [int] NOT NULL IDENTITY(1, 1),
[OrderNumber] [int] NOT NULL,
[OrderDate] [datetime] NOT NULL,
[StoreId] [int] NOT NULL,
[UserId] [int] NULL,
[AffiliateId] [int] NULL,
[BillToFirstName] [nvarchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToLastName] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToCompany] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToAddress1] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToAddress2] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToCity] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToProvince] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToPostalCode] [nvarchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToCountryCode] [nchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToPhone] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToFax] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[BillToEmail] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ProductSubtotal] [decimal] (12, 4) NOT NULL,
[TotalCharges] [decimal] (12, 4) NOT NULL,
[TotalPayments] [decimal] (12, 4) NOT NULL,
[OrderStatusId] [int] NOT NULL,
[Exported] [bit] NOT NULL,
[RemoteIP] [varchar] (39) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Referrer] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[GoogleOrderNumber] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PaymentStatusId] [tinyint] NOT NULL,
[ShipmentStatusId] [tinyint] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Orders] ADD CONSTRAINT [ac_Orders_PK] PRIMARY KEY CLUSTERED ([OrderId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Orders] ADD CONSTRAINT [ac_Affiliates_ac_Orders_FK1] FOREIGN KEY ([AffiliateId]) REFERENCES [dbo].[ac_Affiliates] ([AffiliateId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Orders] ADD CONSTRAINT [ac_OrderStatuses_ac_Orders_FK1] FOREIGN KEY ([OrderStatusId]) REFERENCES [dbo].[ac_OrderStatuses] ([OrderStatusId])
GO
ALTER TABLE [dbo].[ac_Orders] ADD CONSTRAINT [ac_Stores_ac_Orders_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
ALTER TABLE [dbo].[ac_Orders] ADD CONSTRAINT [ac_Users_ac_Orders_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Affiliates]
  • [dbo].[ac_OrderStatuses]
  • [dbo].[ac_Stores]
  • [dbo].[ac_Users]
  • dbo
Used By
  • [dbo].[ac_GiftCertificateTransactions]
  • [dbo].[ac_OrderCoupons]
  • [dbo].[ac_OrderItems]
  • [dbo].[ac_OrderNotes]
  • [dbo].[ac_OrderShipments]
  • [dbo].[ac_Payments]


[dbo].[ac_OrderShipments]

Tables [dbo].[ac_OrderShipments]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderShipments
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_OrderShipments_PK: OrderShipmentId | OrderShipmentId | int | 4 | No | 1 - 1
Foreign Keys ac_Orders_ac_Shipments_FK1: [dbo].[ac_Orders].OrderId | OrderId | int | 4 | No |
Foreign Keys ac_Warehouses_ac_Shipments_FK1: [dbo].[ac_Warehouses].WarehouseId | WarehouseId | int | 4 | Yes |
 | ShipToFirstName | nvarchar(30) | 60 | Yes |
 | ShipToLastName | nvarchar(50) | 100 | Yes |
 | ShipToCompany | nvarchar(50) | 100 | Yes |
 | ShipToAddress1 | nvarchar(255) | 510 | Yes |
 | ShipToAddress2 | nvarchar(255) | 510 | Yes |
 | ShipToCity | nvarchar(50) | 100 | Yes |
 | ShipToProvince | nvarchar(50) | 100 | Yes |
 | ShipToPostalCode | nvarchar(15) | 30 | Yes |
 | ShipToCountryCode | nchar(2) | 4 | Yes |
 | ShipToPhone | nvarchar(50) | 100 | Yes |
 | ShipToFax | nvarchar(50) | 100 | Yes |
 | ShipToEmail | nvarchar(255) | 510 | Yes |
 | ShipToResidence | bit | 1 | Yes |
Foreign Keys ac_ShipMethods_ac_OrderShipments_FK1: [dbo].[ac_ShipMethods].ShipMethodId | ShipMethodId | int | 4 | Yes |
 | ShipMethodName | nvarchar(255) | 510 | Yes |
 | ShipMessage | nvarchar(255) | 510 | Yes |
 | ShipDate | datetime | 8 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_OrderShipments_PK: OrderShipmentId | ac_OrderShipments_PK | OrderShipmentId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Orders_ac_Shipments_FK1 | Cascade | OrderId->[dbo].[ac_Orders].[OrderId]
ac_ShipMethods_ac_OrderShipments_FK1 | SetNull | ShipMethodId->[dbo].[ac_ShipMethods].[ShipMethodId]
ac_Warehouses_ac_Shipments_FK1 | SetNull | WarehouseId->[dbo].[ac_Warehouses].[WarehouseId]
SQL Script
CREATE TABLE [dbo].[ac_OrderShipments]
(
[OrderShipmentId] [int] NOT NULL IDENTITY(1, 1),
[OrderId] [int] NOT NULL,
[WarehouseId] [int] NULL,
[ShipToFirstName] [nvarchar] (30) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToLastName] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToCompany] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToAddress1] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToAddress2] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToCity] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToProvince] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToPostalCode] [nvarchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToCountryCode] [nchar] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToPhone] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToFax] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToEmail] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipToResidence] [bit] NULL,
[ShipMethodId] [int] NULL,
[ShipMethodName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ShipDate] [datetime] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderShipments] ADD CONSTRAINT [ac_OrderShipments_PK] PRIMARY KEY CLUSTERED ([OrderShipmentId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderShipments] ADD CONSTRAINT [ac_Orders_ac_Shipments_FK1] FOREIGN KEY ([OrderId]) REFERENCES [dbo].[ac_Orders] ([OrderId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_OrderShipments] ADD CONSTRAINT [ac_ShipMethods_ac_OrderShipments_FK1] FOREIGN KEY ([ShipMethodId]) REFERENCES [dbo].[ac_ShipMethods] ([ShipMethodId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_OrderShipments] ADD CONSTRAINT [ac_Warehouses_ac_Shipments_FK1] FOREIGN KEY ([WarehouseId]) REFERENCES [dbo].[ac_Warehouses] ([WarehouseId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Orders]
  • [dbo].[ac_ShipMethods]
  • [dbo].[ac_Warehouses]
  • dbo
Used By
  • [dbo].[ac_OrderItems]
  • [dbo].[ac_TrackingNumbers]


[dbo].[ac_OrderStatusActions]

Tables [dbo].[ac_OrderStatusActions]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderStatusActions
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_OrderStatuses_ac_OrderStatusActions_FK1: [dbo].[ac_OrderStatuses].OrderStatusId | OrderStatusId | int | 4 | No
 | OrderActionId | smallint | 2 | No
Indexes Indexes
Name | Columns | Unique
ac_OrderStatusActions_PK | OrderActionId, OrderStatusId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_OrderStatuses_ac_OrderStatusActions_FK1 | Cascade | OrderStatusId->[dbo].[ac_OrderStatuses].[OrderStatusId]
SQL Script
CREATE TABLE [dbo].[ac_OrderStatusActions]
(
[OrderStatusId] [int] NOT NULL,
[OrderActionId] [smallint] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatusActions] ADD CONSTRAINT [ac_OrderStatusActions_PK] PRIMARY KEY CLUSTERED ([OrderActionId], [OrderStatusId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatusActions] ADD CONSTRAINT [ac_OrderStatuses_ac_OrderStatusActions_FK1] FOREIGN KEY ([OrderStatusId]) REFERENCES [dbo].[ac_OrderStatuses] ([OrderStatusId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_OrderStatuses]
  • dbo


[dbo].[ac_OrderStatusEmails]

Tables [dbo].[ac_OrderStatusEmails]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderStatusEmails
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_OrderStatuses_ac_OrderStatusEmails_FK1: [dbo].[ac_OrderStatuses].OrderStatusId | OrderStatusId | int | 4 | No
Foreign Keys ac_Emails_ac_OrderStatusEmails_FK1: [dbo].[ac_EmailTemplates].EmailTemplateId | EmailTemplateId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_OrderStatusEmails_PK | EmailTemplateId, OrderStatusId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Emails_ac_OrderStatusEmails_FK1 | EmailTemplateId->[dbo].[ac_EmailTemplates].[EmailTemplateId]
ac_OrderStatuses_ac_OrderStatusEmails_FK1 | OrderStatusId->[dbo].[ac_OrderStatuses].[OrderStatusId]
SQL Script
CREATE TABLE [dbo].[ac_OrderStatusEmails]
(
[OrderStatusId] [int] NOT NULL,
[EmailTemplateId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatusEmails] ADD CONSTRAINT [ac_OrderStatusEmails_PK] PRIMARY KEY CLUSTERED ([EmailTemplateId], [OrderStatusId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatusEmails] ADD CONSTRAINT [ac_Emails_ac_OrderStatusEmails_FK1] FOREIGN KEY ([EmailTemplateId]) REFERENCES [dbo].[ac_EmailTemplates] ([EmailTemplateId])
GO
ALTER TABLE [dbo].[ac_OrderStatusEmails] ADD CONSTRAINT [ac_OrderStatuses_ac_OrderStatusEmails_FK1] FOREIGN KEY ([OrderStatusId]) REFERENCES [dbo].[ac_OrderStatuses] ([OrderStatusId])
GO
Uses
  • [dbo].[ac_EmailTemplates]
  • [dbo].[ac_OrderStatuses]
  • dbo


[dbo].[ac_OrderStatuses]

Tables [dbo].[ac_OrderStatuses]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderStatuses
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_OrderStatuses_PK: OrderStatusId | OrderStatusId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Stores_ac_OrderStatuses_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |  |
 | Name | nvarchar(100) | 200 | No |  |
 | DisplayName | nvarchar(100) | 200 | Yes |  |
 | InventoryActionId | smallint | 2 | No |  |
 | IsActive | bit | 1 | No |  |
 | IsValid | bit | 1 | No |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_OrderStatuses_PK: OrderStatusId | ac_OrderStatuses_PK | OrderStatusId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_OrderStatuses_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_OrderStatuses]
(
[OrderStatusId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[DisplayName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[InventoryActionId] [smallint] NOT NULL,
[IsActive] [bit] NOT NULL,
[IsValid] [bit] NOT NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_OrderS__Order__1332DBDC] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatuses] ADD CONSTRAINT [ac_OrderStatuses_PK] PRIMARY KEY CLUSTERED ([OrderStatusId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatuses] ADD CONSTRAINT [ac_Stores_ac_OrderStatuses_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Orders]
  • [dbo].[ac_OrderStatusActions]
  • [dbo].[ac_OrderStatusEmails]
  • [dbo].[ac_OrderStatusTriggers]


[dbo].[ac_OrderStatusTriggers]

Tables [dbo].[ac_OrderStatusTriggers]
.\SQL2005 > AC707 > Tables > dbo.ac_OrderStatusTriggers
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Cluster Primary Key ac_OrderStatusTriggers_PK: StoreEventId | StoreEventId | int | 4 | No
Foreign Keys ac_OrderStatuses_ac_OrderStatusTriggers_FK1: [dbo].[ac_OrderStatuses].OrderStatusId | OrderStatusId | int | 4 | No
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_OrderStatusTriggers_PK: StoreEventId | ac_OrderStatusTriggers_PK | StoreEventId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_OrderStatuses_ac_OrderStatusTriggers_FK1 | Cascade | OrderStatusId->[dbo].[ac_OrderStatuses].[OrderStatusId]
SQL Script
CREATE TABLE [dbo].[ac_OrderStatusTriggers]
(
[StoreEventId] [int] NOT NULL,
[OrderStatusId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatusTriggers] ADD CONSTRAINT [ac_OrderStatusTriggers_PK] PRIMARY KEY CLUSTERED ([StoreEventId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_OrderStatusTriggers] ADD CONSTRAINT [ac_OrderStatuses_ac_OrderStatusTriggers_FK1] FOREIGN KEY ([OrderStatusId]) REFERENCES [dbo].[ac_OrderStatuses] ([OrderStatusId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_OrderStatuses]
  • dbo


[dbo].[ac_PageViews]

Tables [dbo].[ac_PageViews]
.\SQL2005 > AC707 > Tables > dbo.ac_PageViews
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_PageViews_PK: PageViewId | PageViewId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_PageViews_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | ActivityDate | datetime | 8 | No |
 | RemoteIP | varchar(39) | 39 | No |
 | RequestMethod | nvarchar(4) | 8 | No |
Foreign Keys ac_Users_ac_PageViews_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No |
 | UriStem | nvarchar(255) | 510 | No |
 | UriQuery | nvarchar(255) | 510 | Yes |
 | TimeTaken | int | 4 | No |
 | UserAgent | nvarchar(255) | 510 | Yes |
 | Referrer | nvarchar(255) | 510 | Yes |
 | CatalogNodeId | int | 4 | Yes |
 | CatalogNodeTypeId | smallint | 2 | Yes |
 | Browser | nvarchar(150) | 300 | No |
 | BrowserName | nvarchar(100) | 200 | No |
 | BrowserPlatform | nvarchar(40) | 80 | No |
 | BrowserVersion | nvarchar(40) | 80 | No |
 | AffiliateId | int | 4 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_PageViews_PK: PageViewId | ac_PageViews_PK | PageViewId | Yes
Foreign Keys Foreign Keys
Name | No Check | Columns
ac_Stores_ac_PageViews_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
ac_Users_ac_PageViews_FK1 | Yes | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_PageViews]
(
[PageViewId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[ActivityDate] [datetime] NOT NULL,
[RemoteIP] [varchar] (39) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[RequestMethod] [nvarchar] (4) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[UserId] [int] NOT NULL,
[UriStem] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[UriQuery] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[TimeTaken] [int] NOT NULL,
[UserAgent] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Referrer] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CatalogNodeId] [int] NULL,
[CatalogNodeTypeId] [smallint] NULL,
[Browser] [nvarchar] (150) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[BrowserName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[BrowserPlatform] [nvarchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[BrowserVersion] [nvarchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[AffiliateId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PageViews] ADD CONSTRAINT [ac_PageViews_PK] PRIMARY KEY CLUSTERED ([PageViewId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PageViews] ADD CONSTRAINT [ac_Stores_ac_PageViews_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
ALTER TABLE [dbo].[ac_PageViews] WITH NOCHECK ADD CONSTRAINT [ac_Users_ac_PageViews_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId])
GO
ALTER TABLE [dbo].[ac_PageViews] NOCHECK CONSTRAINT [ac_Users_ac_PageViews_FK1]
GO
Uses
  • [dbo].[ac_Stores]
  • [dbo].[ac_Users]
  • dbo


[dbo].[ac_PaymentGateways]

Tables [dbo].[ac_PaymentGateways]
.\SQL2005 > AC707 > Tables > dbo.ac_PaymentGateways
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_PaymentGatways_PK: PaymentGatewayId | PaymentGatewayId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_PaymentGateways_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | ClassId | varchar(255) | 255 | No |
 | ConfigData | nvarchar(max) | max | Yes |
 | ReCrypt | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_PaymentGatways_PK: PaymentGatewayId | ac_PaymentGatways_PK | PaymentGatewayId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_PaymentGateways_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_PaymentGateways]
(
[PaymentGatewayId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ClassId] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ConfigData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ReCrypt] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PaymentGateways] ADD CONSTRAINT [ac_PaymentGatways_PK] PRIMARY KEY CLUSTERED ([PaymentGatewayId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PaymentGateways] ADD CONSTRAINT [ac_Stores_ac_PaymentGateways_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_PaymentMethods]
  • [dbo].[ac_Transactions]


[dbo].[ac_PaymentMethodGroups]

Tables [dbo].[ac_PaymentMethodGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_PaymentMethodGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_PaymentMethods_ac_PaymentMethodsGroups_FK1: [dbo].[ac_PaymentMethods].PaymentMethodId | PaymentMethodId | int | 4 | No
Foreign Keys ac_Groups_ac_PaymentMethodGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_PaymentMethodGroups_PK | PaymentMethodId, GroupId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_PaymentMethodGroups_FK1 | Cascade | GroupId->[dbo].[ac_Groups].[GroupId]
ac_PaymentMethods_ac_PaymentMethodsGroups_FK1 | Cascade | PaymentMethodId->[dbo].[ac_PaymentMethods].[PaymentMethodId]
SQL Script
CREATE TABLE [dbo].[ac_PaymentMethodGroups]
(
[PaymentMethodId] [int] NOT NULL,
[GroupId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PaymentMethodGroups] ADD CONSTRAINT [ac_PaymentMethodGroups_PK] PRIMARY KEY CLUSTERED ([PaymentMethodId], [GroupId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PaymentMethodGroups] ADD CONSTRAINT [ac_Groups_ac_PaymentMethodGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_PaymentMethodGroups] ADD CONSTRAINT [ac_PaymentMethods_ac_PaymentMethodsGroups_FK1] FOREIGN KEY ([PaymentMethodId]) REFERENCES [dbo].[ac_PaymentMethods] ([PaymentMethodId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_PaymentMethods]
  • dbo


[dbo].[ac_PaymentMethods]

Tables [dbo].[ac_PaymentMethods]
.\SQL2005 > AC707 > Tables > dbo.ac_PaymentMethods
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_PaymentMethods_PK: PaymentMethodId | PaymentMethodId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Stores_ac_PaymentMethods_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |  |
 | Name | nvarchar(100) | 200 | No |  |
 | PaymentInstrumentId | smallint | 2 | No |  |
Foreign Keys ac_PaymentGateways_ac_PaymentMethods_FK1: [dbo].[ac_PaymentGateways].PaymentGatewayId | PaymentGatewayId | int | 4 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_PaymentMethods_PK: PaymentMethodId | ac_PaymentMethods_PK | PaymentMethodId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_PaymentGateways_ac_PaymentMethods_FK1 | SetNull | PaymentGatewayId->[dbo].[ac_PaymentGateways].[PaymentGatewayId]
ac_Stores_ac_PaymentMethods_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_PaymentMethods]
(
[PaymentMethodId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[PaymentInstrumentId] [smallint] NOT NULL,
[PaymentGatewayId] [int] NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Paymen__Order__08B54D69] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PaymentMethods] ADD CONSTRAINT [ac_PaymentMethods_PK] PRIMARY KEY CLUSTERED ([PaymentMethodId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PaymentMethods] ADD CONSTRAINT [ac_PaymentGateways_ac_PaymentMethods_FK1] FOREIGN KEY ([PaymentGatewayId]) REFERENCES [dbo].[ac_PaymentGateways] ([PaymentGatewayId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_PaymentMethods] ADD CONSTRAINT [ac_Stores_ac_PaymentMethods_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_PaymentGateways]
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_PaymentMethodGroups]
  • [dbo].[ac_Payments]


[dbo].[ac_Payments]

Tables [dbo].[ac_Payments]
.\SQL2005 > AC707 > Tables > dbo.ac_Payments
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Payments_PK: PaymentId | PaymentId | int | 4 | No | 1 - 1
Foreign Keys ac_Orders_ac_Payments_FK1: [dbo].[ac_Orders].OrderId | OrderId | int | 4 | No |
Foreign Keys ac_Subscriptions_ac_Payments_FK1: [dbo].[ac_Subscriptions].SubscriptionId | SubscriptionId | int | 4 | Yes |
Foreign Keys ac_PaymentMethods_ac_Payments_FK1: [dbo].[ac_PaymentMethods].PaymentMethodId | PaymentMethodId | int | 4 | Yes |
 | PaymentMethodName | nvarchar(100) | 200 | Yes |
 | ReferenceNumber | nvarchar(50) | 100 | Yes |
 | Amount | decimal(12,4) | 9 | No |
 | CurrencyCode | nvarchar(3) | 6 | No |
 | PaymentDate | datetime | 8 | No |
 | PaymentStatusId | smallint | 2 | No |
 | PaymentStatusReason | nvarchar(255) | 510 | Yes |
 | CompletedDate | datetime | 8 | Yes |
 | EncryptedAccountData | nvarchar(max) | max | Yes |
 | ReCrypt | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Payments_PK: PaymentId | ac_Payments_PK | PaymentId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Orders_ac_Payments_FK1 | Cascade | OrderId->[dbo].[ac_Orders].[OrderId]
ac_PaymentMethods_ac_Payments_FK1 | SetNull | PaymentMethodId->[dbo].[ac_PaymentMethods].[PaymentMethodId]
ac_Subscriptions_ac_Payments_FK1 | SetNull | SubscriptionId->[dbo].[ac_Subscriptions].[SubscriptionId]
SQL Script
CREATE TABLE [dbo].[ac_Payments]
(
[PaymentId] [int] NOT NULL IDENTITY(1, 1),
[OrderId] [int] NOT NULL,
[SubscriptionId] [int] NULL,
[PaymentMethodId] [int] NULL,
[PaymentMethodName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ReferenceNumber] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Amount] [decimal] (12, 4) NOT NULL,
[CurrencyCode] [nvarchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[PaymentDate] [datetime] NOT NULL,
[PaymentStatusId] [smallint] NOT NULL,
[PaymentStatusReason] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CompletedDate] [datetime] NULL,
[EncryptedAccountData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ReCrypt] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Payments] ADD CONSTRAINT [ac_Payments_PK] PRIMARY KEY CLUSTERED ([PaymentId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Payments] ADD CONSTRAINT [ac_Orders_ac_Payments_FK1] FOREIGN KEY ([OrderId]) REFERENCES [dbo].[ac_Orders] ([OrderId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_Payments] ADD CONSTRAINT [ac_PaymentMethods_ac_Payments_FK1] FOREIGN KEY ([PaymentMethodId]) REFERENCES [dbo].[ac_PaymentMethods] ([PaymentMethodId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Payments] ADD CONSTRAINT [ac_Subscriptions_ac_Payments_FK1] FOREIGN KEY ([SubscriptionId]) REFERENCES [dbo].[ac_Subscriptions] ([SubscriptionId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Orders]
  • [dbo].[ac_PaymentMethods]
  • [dbo].[ac_Subscriptions]
  • dbo
Used By
  • [dbo].[ac_Transactions]


[dbo].[ac_PersonalizationPaths]

Tables [dbo].[ac_PersonalizationPaths]
.\SQL2005 > AC707 > Tables > dbo.ac_PersonalizationPaths
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_PersonalizationPaths_PK: PersonalizationPathId | PersonalizationPathId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Paths_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Path | nvarchar(255) | 510 | No |
 | LoweredPath | nvarchar(255) | 510 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_PersonalizationPaths_PK: PersonalizationPathId | ac_PersonalizationPaths_PK | PersonalizationPathId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Paths_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_PersonalizationPaths]
(
[PersonalizationPathId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Path] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LoweredPath] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PersonalizationPaths] ADD CONSTRAINT [ac_PersonalizationPaths_PK] PRIMARY KEY CLUSTERED ([PersonalizationPathId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_PersonalizationPaths] ADD CONSTRAINT [ac_Stores_ac_Paths_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_SharedPersonalization]
  • [dbo].[ac_UserPersonalization]


[dbo].[ac_ProductAssets]

Tables [dbo].[ac_ProductAssets]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductAssets
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_ProductAssets_PK: ProductAssetId | ProductAssetId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Products_ac_ProductAssets_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |  |
 | AssetUrl | nvarchar(255) | 510 | No |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductAssets_PK: ProductAssetId | ac_ProductAssets_PK | ProductAssetId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_ProductAssets_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductAssets]
(
[ProductAssetId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[AssetUrl] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Produc__Order__02084FDA] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductAssets] ADD CONSTRAINT [ac_ProductAssets_PK] PRIMARY KEY CLUSTERED ([ProductAssetId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductAssets] ADD CONSTRAINT [ac_Products_ac_ProductAssets_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductCustomFields]

Tables [dbo].[ac_ProductCustomFields]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductCustomFields
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ProductCustomFields_PK: ProductFieldId | ProductFieldId | int | 4 | No | 1 - 1
Foreign Keys ac_Products_ac_ProductCustomFields_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
 | IsUserDefined | bit | 1 | No |
 | IsVisible | bit | 1 | No |
 | FieldName | nvarchar(100) | 200 | No |
 | FieldValue | nvarchar(max) | max | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductCustomFields_PK: ProductFieldId | ac_ProductCustomFields_PK | ProductFieldId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_ProductCustomFields_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductCustomFields]
(
[ProductFieldId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[IsUserDefined] [bit] NOT NULL,
[IsVisible] [bit] NOT NULL,
[FieldName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[FieldValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductCustomFields] ADD CONSTRAINT [ac_ProductCustomFields_PK] PRIMARY KEY CLUSTERED ([ProductFieldId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductCustomFields] ADD CONSTRAINT [ac_Products_ac_ProductCustomFields_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductDigitalGoods]

Tables [dbo].[ac_ProductDigitalGoods]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductDigitalGoods
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ProductDigitalGoods_PK: ProductDigitalGoodId | ProductDigitalGoodId | int | 4 | No | 1 - 1
Foreign Keys ac_Products_ac_DigitalGoods_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
 | OptionList | varchar(255) | 255 | Yes |
Foreign Keys ac_DigitalGoods_ac_ProductDigitalGoods_FK1: [dbo].[ac_DigitalGoods].DigitalGoodId | DigitalGoodId | int | 4 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductDigitalGoods_PK: ProductDigitalGoodId | ac_ProductDigitalGoods_PK | ProductDigitalGoodId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_DigitalGoods_ac_ProductDigitalGoods_FK1 | Cascade | DigitalGoodId->[dbo].[ac_DigitalGoods].[DigitalGoodId]
ac_Products_ac_DigitalGoods_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductDigitalGoods]
(
[ProductDigitalGoodId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[OptionList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DigitalGoodId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductDigitalGoods] ADD CONSTRAINT [ac_ProductDigitalGoods_PK] PRIMARY KEY CLUSTERED ([ProductDigitalGoodId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductDigitalGoods] ADD CONSTRAINT [ac_DigitalGoods_ac_ProductDigitalGoods_FK1] FOREIGN KEY ([DigitalGoodId]) REFERENCES [dbo].[ac_DigitalGoods] ([DigitalGoodId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ProductDigitalGoods] ADD CONSTRAINT [ac_Products_ac_DigitalGoods_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_DigitalGoods]
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductImages]

Tables [dbo].[ac_ProductImages]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductImages
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_ProductImages_PK: ProductImageId | ProductImageId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Products_ac_ProductImages_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |  |
 | ImageUrl | varchar(255) | 255 | No |  |
 | ImageAltText | nvarchar(100) | 200 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductImages_PK: ProductImageId | ac_ProductImages_PK | ProductImageId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_ProductImages_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductImages]
(
[ProductImageId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[ImageUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ImageAltText] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Produc__Order__7B5B524B] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductImages] ADD CONSTRAINT [ac_ProductImages_PK] PRIMARY KEY CLUSTERED ([ProductImageId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductImages] ADD CONSTRAINT [ac_Products_ac_ProductImages_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductKitComponents]

Tables [dbo].[ac_ProductKitComponents]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductKitComponents
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Default
Foreign Keys ac_Products_ac_ProductKitComponents_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
Foreign Keys ac_KitComponents_ac_ProductKitComponents_FK1: [dbo].[ac_KitComponents].KitComponentId | KitComponentId | int | 4 | No |
 | OrderBy | smallint | 2 | No | ((0))
Indexes Indexes
Name | Columns | Unique
ac_ProductKitComponents_PK | ProductId, KitComponentId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_KitComponents_ac_ProductKitComponents_FK1 | Cascade | KitComponentId->[dbo].[ac_KitComponents].[KitComponentId]
ac_Products_ac_ProductKitComponents_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductKitComponents]
(
[ProductId] [int] NOT NULL,
[KitComponentId] [int] NOT NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Produc__Order__787EE5A0] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductKitComponents] ADD CONSTRAINT [ac_ProductKitComponents_PK] PRIMARY KEY CLUSTERED ([ProductId], [KitComponentId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductKitComponents] ADD CONSTRAINT [ac_KitComponents_ac_ProductKitComponents_FK1] FOREIGN KEY ([KitComponentId]) REFERENCES [dbo].[ac_KitComponents] ([KitComponentId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ProductKitComponents] ADD CONSTRAINT [ac_Products_ac_ProductKitComponents_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_KitComponents]
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductOptions]

Tables [dbo].[ac_ProductOptions]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductOptions
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Products_ac_ProductOptions_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
Foreign Keys ac_Options_ac_ProductOptions_FK1: [dbo].[ac_Options].OptionId | OptionId | int | 4 | No
 | OrderBy | smallint | 2 | No
Indexes Indexes
Name | Columns | Unique
ac_ProductOptions_PK | ProductId, OptionId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Options_ac_ProductOptions_FK1 | Cascade | OptionId->[dbo].[ac_Options].[OptionId]
ac_Products_ac_ProductOptions_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductOptions]
(
[ProductId] [int] NOT NULL,
[OptionId] [int] NOT NULL,
[OrderBy] [smallint] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductOptions] ADD CONSTRAINT [ac_ProductOptions_PK] PRIMARY KEY CLUSTERED ([ProductId], [OptionId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductOptions] ADD CONSTRAINT [ac_Options_ac_ProductOptions_FK1] FOREIGN KEY ([OptionId]) REFERENCES [dbo].[ac_Options] ([OptionId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ProductOptions] ADD CONSTRAINT [ac_Products_ac_ProductOptions_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Options]
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductProductTemplates]

Tables [dbo].[ac_ProductProductTemplates]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductProductTemplates
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Products_ac_ProductProductTemplates_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
Foreign Keys ac_ProductTemplates_ac_ProductProductTemplates_FK1: [dbo].[ac_ProductTemplates].ProductTemplateId | ProductTemplateId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_ProductProductTemplates_PK | ProductId, ProductTemplateId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_ProductProductTemplates_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
ac_ProductTemplates_ac_ProductProductTemplates_FK1 | Cascade | ProductTemplateId->[dbo].[ac_ProductTemplates].[ProductTemplateId]
SQL Script
CREATE TABLE [dbo].[ac_ProductProductTemplates]
(
[ProductId] [int] NOT NULL,
[ProductTemplateId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductProductTemplates] ADD CONSTRAINT [ac_ProductProductTemplates_PK] PRIMARY KEY CLUSTERED ([ProductId], [ProductTemplateId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductProductTemplates] ADD CONSTRAINT [ac_Products_ac_ProductProductTemplates_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ProductProductTemplates] ADD CONSTRAINT [ac_ProductTemplates_ac_ProductProductTemplates_FK1] FOREIGN KEY ([ProductTemplateId]) REFERENCES [dbo].[ac_ProductTemplates] ([ProductTemplateId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • [dbo].[ac_ProductTemplates]
  • dbo


[dbo].[ac_ProductReviews]

Tables [dbo].[ac_ProductReviews]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductReviews
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ProductReviews_PK: ProductReviewId | ProductReviewId | int | 4 | No | 1 - 1
Foreign Keys ac_Products_ac_ProductReviews_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
Foreign Keys ac_ReviewerProfiles_ac_ProductReviews_FK1: [dbo].[ac_ReviewerProfiles].ReviewerProfileId | ReviewerProfileId | int | 4 | No |
 | ReviewDate | datetime | 8 | No |
 | Rating | tinyint | 1 | No |
 | ReviewTitle | nvarchar(100) | 200 | No |
 | ReviewBody | nvarchar(max) | max | No |
 | IsApproved | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductReviews_PK: ProductReviewId | ac_ProductReviews_PK | ProductReviewId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_ProductReviews_FK1 |  | ProductId->[dbo].[ac_Products].[ProductId]
ac_ReviewerProfiles_ac_ProductReviews_FK1 | Cascade | ReviewerProfileId->[dbo].[ac_ReviewerProfiles].[ReviewerProfileId]
SQL Script
CREATE TABLE [dbo].[ac_ProductReviews]
(
[ProductReviewId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[ReviewerProfileId] [int] NOT NULL,
[ReviewDate] [datetime] NOT NULL,
[Rating] [tinyint] NOT NULL,
[ReviewTitle] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ReviewBody] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[IsApproved] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductReviews] ADD CONSTRAINT [ac_ProductReviews_PK] PRIMARY KEY CLUSTERED ([ProductReviewId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductReviews] ADD CONSTRAINT [ac_Products_ac_ProductReviews_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId])
GO
ALTER TABLE [dbo].[ac_ProductReviews] ADD CONSTRAINT [ac_ReviewerProfiles_ac_ProductReviews_FK1] FOREIGN KEY ([ReviewerProfileId]) REFERENCES [dbo].[ac_ReviewerProfiles] ([ReviewerProfileId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • [dbo].[ac_ReviewerProfiles]
  • dbo


[dbo].[ac_Products]

Tables [dbo].[ac_Products]
.\SQL2005 > AC707 > Tables > dbo.ac_Products
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_Products_PK: ProductId | ProductId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Stores_ac_Products_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |  |
 | Name | nvarchar(255) | 510 | No |  |
 | Price | decimal(12,4) | 9 | No |  |
 | CostOfGoods | decimal(12,4) | 9 | No |  |
 | MSRP | decimal(12,4) | 9 | No |  |
 | Weight | decimal(12,4) | 9 | No |  |
 | Length | decimal(12,4) | 9 | No |  |
 | Width | decimal(12,4) | 9 | No |  |
 | Height | decimal(12,4) | 9 | No |  |
Foreign Keys ac_Manufacturers_ac_Products_FK1: [dbo].[ac_Manufacturers].ManufacturerId | ManufacturerId | int | 4 | Yes |  |
 | Sku | nvarchar(40) | 80 | Yes |  |
 | ModelNumber | nvarchar(40) | 80 | Yes |  |
 | DisplayPage | varchar(100) | 100 | Yes |  |
Foreign Keys ac_TaxCodes_ac_Products_FK1: [dbo].[ac_TaxCodes].TaxCodeId | TaxCodeId | int | 4 | Yes |  |
 | ShippableId | tinyint | 1 | No |  | ((0))
Foreign Keys ac_Warehouses_ac_Products_FK1: [dbo].[ac_Warehouses].WarehouseId | WarehouseId | int | 4 | Yes |  |
 | InventoryModeId | tinyint | 1 | No |  |
 | InStock | int | 4 | No |  |
 | InStockWarningLevel | int | 4 | No |  |
 | ThumbnailUrl | varchar(255) | 255 | Yes |  |
 | ThumbnailAltText | nvarchar(255) | 510 | Yes |  |
 | ImageUrl | varchar(255) | 255 | Yes |  |
 | ImageAltText | nvarchar(255) | 510 | Yes |  |
 | Summary | nvarchar(max) | max | Yes |  |
 | Description | nvarchar(max) | max | Yes |  |
 | ExtendedDescription | nvarchar(max) | max | Yes |  |
Foreign Keys ac_Vendors_ac_Products_FK1: [dbo].[ac_Vendors].VendorId | VendorId | int | 4 | Yes |  |
 | CreatedDate | datetime | 8 | No |  |
 | LastModifiedDate | datetime | 8 | No |  |
 | IsFeatured | bit | 1 | No |  |
 | IsProhibited | bit | 1 | No |  |
 | AllowReviews | bit | 1 | No |  |
 | AllowBackorder | bit | 1 | No |  |
Foreign Keys ac_WrapGroups_ac_Products_FK1: [dbo].[ac_WrapGroups].WrapGroupId | WrapGroupId | int | 4 | Yes |  |
 | ExcludeFromFeed | bit | 1 | No |  |
 | HtmlHead | nvarchar(max) | max | Yes |  |
 | DisablePurchase | bit | 1 | No |  |
 | MinQuantity | smallint | 2 | No |  |
 | MaxQuantity | smallint | 2 | No |  |
 | VisibilityId | tinyint | 1 | No |  |
 | Theme | varchar(100) | 100 | Yes |  |
 | IconUrl | varchar(255) | 255 | Yes |  |
 | IconAltText | nvarchar(255) | 510 | Yes |  |
 | IsGiftCertificate | bit | 1 | No |  |
 | UseVariablePrice | bit | 1 | No |  |
 | MinimumPrice | decimal(10,2) | 9 | Yes |  |
 | MaximumPrice | decimal(10,2) | 9 | Yes |  |
 | SearchKeywords | nvarchar(max) | max | Yes |  |
 | HidePrice | bit | 1 | No |  |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Products_PK: ProductId | ac_Products_PK | ProductId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Manufacturers_ac_Products_FK1 | SetNull | ManufacturerId->[dbo].[ac_Manufacturers].[ManufacturerId]
ac_Stores_ac_Products_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
ac_TaxCodes_ac_Products_FK1 | SetNull | TaxCodeId->[dbo].[ac_TaxCodes].[TaxCodeId]
ac_Vendors_ac_Products_FK1 |  | VendorId->[dbo].[ac_Vendors].[VendorId]
ac_Warehouses_ac_Products_FK1 |  | WarehouseId->[dbo].[ac_Warehouses].[WarehouseId]
ac_WrapGroups_ac_Products_FK1 | SetNull | WrapGroupId->[dbo].[ac_WrapGroups].[WrapGroupId]
SQL Script
CREATE TABLE [dbo].[ac_Products]
(
[ProductId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Price] [decimal] (12, 4) NOT NULL,
[CostOfGoods] [decimal] (12, 4) NOT NULL,
[MSRP] [decimal] (12, 4) NOT NULL,
[Weight] [decimal] (12, 4) NOT NULL,
[Length] [decimal] (12, 4) NOT NULL,
[Width] [decimal] (12, 4) NOT NULL,
[Height] [decimal] (12, 4) NOT NULL,
[ManufacturerId] [int] NULL,
[Sku] [nvarchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ModelNumber] [nvarchar] (40) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DisplayPage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[TaxCodeId] [int] NULL,
[ShippableId] [tinyint] NOT NULL CONSTRAINT [DF__ac_Produc__Shipp__73BA3083] DEFAULT ((0)),
[WarehouseId] [int] NULL,
[InventoryModeId] [tinyint] NOT NULL,
[InStock] [int] NOT NULL,
[InStockWarningLevel] [int] NOT NULL,
[ThumbnailUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ThumbnailAltText] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ImageUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ImageAltText] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Summary] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Description] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ExtendedDescription] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[VendorId] [int] NULL,
[CreatedDate] [datetime] NOT NULL,
[LastModifiedDate] [datetime] NOT NULL,
[IsFeatured] [bit] NOT NULL,
[IsProhibited] [bit] NOT NULL,
[AllowReviews] [bit] NOT NULL,
[AllowBackorder] [bit] NOT NULL,
[WrapGroupId] [int] NULL,
[ExcludeFromFeed] [bit] NOT NULL,
[HtmlHead] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DisablePurchase] [bit] NOT NULL,
[MinQuantity] [smallint] NOT NULL,
[MaxQuantity] [smallint] NOT NULL,
[VisibilityId] [tinyint] NOT NULL,
[Theme] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IconUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IconAltText] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IsGiftCertificate] [bit] NOT NULL,
[UseVariablePrice] [bit] NOT NULL,
[MinimumPrice] [decimal] (10, 2) NULL,
[MaximumPrice] [decimal] (10, 2) NULL,
[SearchKeywords] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[HidePrice] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Products] ADD CONSTRAINT [ac_Products_PK] PRIMARY KEY CLUSTERED ([ProductId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Products] ADD CONSTRAINT [ac_Manufacturers_ac_Products_FK1] FOREIGN KEY ([ManufacturerId]) REFERENCES [dbo].[ac_Manufacturers] ([ManufacturerId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Products] ADD CONSTRAINT [ac_Stores_ac_Products_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
ALTER TABLE [dbo].[ac_Products] ADD CONSTRAINT [ac_TaxCodes_ac_Products_FK1] FOREIGN KEY ([TaxCodeId]) REFERENCES [dbo].[ac_TaxCodes] ([TaxCodeId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Products] ADD CONSTRAINT [ac_Vendors_ac_Products_FK1] FOREIGN KEY ([VendorId]) REFERENCES [dbo].[ac_Vendors] ([VendorId])
GO
ALTER TABLE [dbo].[ac_Products] ADD CONSTRAINT [ac_Warehouses_ac_Products_FK1] FOREIGN KEY ([WarehouseId]) REFERENCES [dbo].[ac_Warehouses] ([WarehouseId])
GO
ALTER TABLE [dbo].[ac_Products] ADD CONSTRAINT [ac_WrapGroups_ac_Products_FK1] FOREIGN KEY ([WrapGroupId]) REFERENCES [dbo].[ac_WrapGroups] ([WrapGroupId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Manufacturers]
  • [dbo].[ac_Stores]
  • [dbo].[ac_TaxCodes]
  • [dbo].[ac_Vendors]
  • [dbo].[ac_Warehouses]
  • [dbo].[ac_WrapGroups]
  • dbo
Used By
  • [dbo].[ac_BasketItems]
  • [dbo].[ac_CouponProducts]
  • [dbo].[ac_Kits]
  • [dbo].[ac_OrderItems]
  • [dbo].[ac_ProductAssets]
  • [dbo].[ac_ProductCustomFields]
  • [dbo].[ac_ProductDigitalGoods]
  • [dbo].[ac_ProductImages]
  • [dbo].[ac_ProductKitComponents]
  • [dbo].[ac_ProductOptions]
  • [dbo].[ac_ProductProductTemplates]
  • [dbo].[ac_ProductReviews]
  • [dbo].[ac_ProductTemplateFields]
  • [dbo].[ac_ProductVariants]
  • [dbo].[ac_ProductVolumeDiscounts]
  • [dbo].[ac_RelatedProducts]
  • [dbo].[ac_RelatedProducts]
  • [dbo].[ac_Specials]
  • [dbo].[ac_SubscriptionPlans]
  • [dbo].[ac_UpsellProducts]
  • [dbo].[ac_WishlistItems]


[dbo].[ac_ProductTemplateFields]

Tables [dbo].[ac_ProductTemplateFields]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductTemplateFields
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ProductTemplateFields_PK: ProductTemplateFieldId | ProductTemplateFieldId | int | 4 | No | 1 - 1
Foreign Keys ac_Products_ac_ProductTemplateFields_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
Foreign Keys ac_InputFields_ac_ProductTemplateFields_FK1: [dbo].[ac_InputFields].InputFieldId | InputFieldId | int | 4 | No |
 | InputValue | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductTemplateFields_PK: ProductTemplateFieldId | ac_ProductTemplateFields_PK | ProductTemplateFieldId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_InputFields_ac_ProductTemplateFields_FK1 | Cascade | InputFieldId->[dbo].[ac_InputFields].[InputFieldId]
ac_Products_ac_ProductTemplateFields_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductTemplateFields]
(
[ProductTemplateFieldId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[InputFieldId] [int] NOT NULL,
[InputValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductTemplateFields] ADD CONSTRAINT [ac_ProductTemplateFields_PK] PRIMARY KEY CLUSTERED ([ProductTemplateFieldId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductTemplateFields] ADD CONSTRAINT [ac_InputFields_ac_ProductTemplateFields_FK1] FOREIGN KEY ([InputFieldId]) REFERENCES [dbo].[ac_InputFields] ([InputFieldId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ProductTemplateFields] ADD CONSTRAINT [ac_Products_ac_ProductTemplateFields_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_InputFields]
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductTemplates]

Tables [dbo].[ac_ProductTemplates]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductTemplates
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ProductTemplates_PK: ProductTemplateId | ProductTemplateId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_ProductTemplates_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductTemplates_PK: ProductTemplateId | ac_ProductTemplates_PK | ProductTemplateId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_ProductTemplates_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_ProductTemplates]
(
[ProductTemplateId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductTemplates] ADD CONSTRAINT [ac_ProductTemplates_PK] PRIMARY KEY CLUSTERED ([ProductTemplateId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductTemplates] ADD CONSTRAINT [ac_Stores_ac_ProductTemplates_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_InputFields]
  • [dbo].[ac_ProductProductTemplates]


[dbo].[ac_ProductVariants]

Tables [dbo].[ac_ProductVariants]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductVariants
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ProductVariants_PK: ProductVariantId | ProductVariantId | int | 4 | No | 1 - 1
Foreign Keys ac_Products_ac_ProductVariations_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
 | Option1 | int | 4 | No |
 | Option2 | int | 4 | No |
 | Option3 | int | 4 | No |
 | Option4 | int | 4 | No |
 | Option5 | int | 4 | No |
 | Option6 | int | 4 | No |
 | Option7 | int | 4 | No |
 | Option8 | int | 4 | No |
 | VariantName | nvarchar(255) | 510 | Yes |
 | Sku | nvarchar(100) | 200 | Yes |
 | Price | decimal(12,4) | 9 | Yes |
 | PriceModeId | tinyint | 1 | No |
 | Weight | decimal(12,4) | 9 | Yes |
 | WeightModeId | tinyint | 1 | No |
 | CostOfGoods | decimal(12,4) | 9 | Yes |
 | InStock | int | 4 | No |
 | InStockWarningLevel | int | 4 | No |
 | Available | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ProductVariants_PK: ProductVariantId | ac_ProductVariants_PK | ProductVariantId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Products_ac_ProductVariations_FK1 | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductVariants]
(
[ProductVariantId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[Option1] [int] NOT NULL,
[Option2] [int] NOT NULL,
[Option3] [int] NOT NULL,
[Option4] [int] NOT NULL,
[Option5] [int] NOT NULL,
[Option6] [int] NOT NULL,
[Option7] [int] NOT NULL,
[Option8] [int] NOT NULL,
[VariantName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Sku] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Price] [decimal] (12, 4) NULL,
[PriceModeId] [tinyint] NOT NULL,
[Weight] [decimal] (12, 4) NULL,
[WeightModeId] [tinyint] NOT NULL,
[CostOfGoods] [decimal] (12, 4) NULL,
[InStock] [int] NOT NULL,
[InStockWarningLevel] [int] NOT NULL,
[Available] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductVariants] ADD CONSTRAINT [ac_ProductVariants_PK] PRIMARY KEY CLUSTERED ([ProductVariantId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductVariants] ADD CONSTRAINT [ac_Products_ac_ProductVariations_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId])
GO
Uses
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ProductVolumeDiscounts]

Tables [dbo].[ac_ProductVolumeDiscounts]
.\SQL2005 > AC707 > Tables > dbo.ac_ProductVolumeDiscounts
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Products_ac_ProductDiscountAssn_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
Foreign Keys ac_Discounts_ac_ProductDiscountAssn_FK1: [dbo].[ac_VolumeDiscounts].VolumeDiscountId | VolumeDiscountId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_ProductVolumeDiscounts_PK | ProductId, VolumeDiscountId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Discounts_ac_ProductDiscountAssn_FK1 | Cascade | VolumeDiscountId->[dbo].[ac_VolumeDiscounts].[VolumeDiscountId]
ac_Products_ac_ProductDiscountAssn_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_ProductVolumeDiscounts]
(
[ProductId] [int] NOT NULL,
[VolumeDiscountId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductVolumeDiscounts] ADD CONSTRAINT [ac_ProductVolumeDiscounts_PK] PRIMARY KEY CLUSTERED ([ProductId], [VolumeDiscountId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ProductVolumeDiscounts] ADD CONSTRAINT [ac_Discounts_ac_ProductDiscountAssn_FK1] FOREIGN KEY ([VolumeDiscountId]) REFERENCES [dbo].[ac_VolumeDiscounts] ([VolumeDiscountId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ProductVolumeDiscounts] ADD CONSTRAINT [ac_Products_ac_ProductDiscountAssn_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • [dbo].[ac_VolumeDiscounts]
  • dbo


[dbo].[ac_Profiles]

Tables [dbo].[ac_Profiles]
.\SQL2005 > AC707 > Tables > dbo.ac_Profiles
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Cluster Primary Key ac_Profiles_PK: UserId Foreign Keys ac_Users_ac_Profiles_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No
 | PropertyNames | nvarchar(max) | max | No
 | PropertyValuesString | nvarchar(max) | max | No
 | PropertyValuesBinary | image | max | No
 | LastUpdatedDate | datetime | 8 | Yes
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Profiles_PK: UserId | ac_Profiles_PK | UserId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Users_ac_Profiles_FK1 | Cascade | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_Profiles]
(
[UserId] [int] NOT NULL,
[PropertyNames] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[PropertyValuesString] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[PropertyValuesBinary] [image] NOT NULL,
[LastUpdatedDate] [datetime] NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Profiles] ADD CONSTRAINT [ac_Profiles_PK] PRIMARY KEY CLUSTERED ([UserId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Profiles] ADD CONSTRAINT [ac_Users_ac_Profiles_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Users]
  • dbo


[dbo].[ac_Provinces]

Tables [dbo].[ac_Provinces]
.\SQL2005 > AC707 > Tables > dbo.ac_Provinces
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Provinces_PK: ProvinceId | ProvinceId | int | 4 | No | 1 - 1
Foreign Keys ac_Countries_ac_Provinces_FK1: [dbo].[ac_Countries].CountryCode | CountryCode | char(2) | 2 | No |
 | Name | nvarchar(50) | 100 | No |
 | LoweredName | nvarchar(50) | 100 | No |
 | ProvinceCode | nvarchar(10) | 20 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Provinces_PK: ProvinceId | ac_Provinces_PK | ProvinceId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Countries_ac_Provinces_FK1 | Cascade | CountryCode->[dbo].[ac_Countries].[CountryCode]
SQL Script
CREATE TABLE [dbo].[ac_Provinces]
(
[ProvinceId] [int] NOT NULL IDENTITY(1, 1),
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Name] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LoweredName] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ProvinceCode] [nvarchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Provinces] ADD CONSTRAINT [ac_Provinces_PK] PRIMARY KEY CLUSTERED ([ProvinceId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Provinces] ADD CONSTRAINT [ac_Countries_ac_Provinces_FK1] FOREIGN KEY ([CountryCode]) REFERENCES [dbo].[ac_Countries] ([CountryCode]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Countries]
  • dbo
Used By
  • [dbo].[ac_ShipZoneProvinces]


[dbo].[ac_Readmes]

Tables [dbo].[ac_Readmes]
.\SQL2005 > AC707 > Tables > dbo.ac_Readmes
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Readmes_PK: ReadmeId | ReadmeId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Readmes_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | DisplayName | nvarchar(100) | 200 | No |
 | ReadmeText | nvarchar(max) | max | No |
 | IsHTML | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Readmes_PK: ReadmeId | ac_Readmes_PK | ReadmeId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Readmes_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Readmes]
(
[ReadmeId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[DisplayName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ReadmeText] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[IsHTML] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Readmes] ADD CONSTRAINT [ac_Readmes_PK] PRIMARY KEY CLUSTERED ([ReadmeId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Readmes] ADD CONSTRAINT [ac_Stores_ac_Readmes_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_DigitalGoods]


[dbo].[ac_Redirects]

Tables [dbo].[ac_Redirects]
.\SQL2005 > AC707 > Tables > dbo.ac_Redirects
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Heap | Yes
Row Count (~) | 0
Created | 2:33:49 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Primary Key ac_Redirects_PK: RedirectId | RedirectId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Stores_ac_Redirects_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |  |
 | SourceUrl | nvarchar(255) | 510 | No |  |
Indexes ac_Redirects_IX1: LoweredSourceUrl | LoweredSourceUrl | nvarchar(255) | 510 | No |  |
 | TargetUrl | nvarchar(255) | 510 | No |  |
 | UseRegEx | bit | 1 | No |  |
 | CreatedDate | datetime | 8 | No |  |
 | LastVisitedDate | datetime | 8 | Yes |  |
 | VisitCount | int | 4 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Primary Key ac_Redirects_PK: RedirectId | ac_Redirects_PK | RedirectId | Yes
 | ac_Redirects_IX1 | LoweredSourceUrl | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Redirects_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Redirects]
(
[RedirectId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[SourceUrl] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LoweredSourceUrl] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[TargetUrl] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[UseRegEx] [bit] NOT NULL,
[CreatedDate] [datetime] NOT NULL,
[LastVisitedDate] [datetime] NULL,
[VisitCount] [int] NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_Redire__Order__7D0E9093] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Redirects] ADD CONSTRAINT [ac_Redirects_PK] PRIMARY KEY NONCLUSTERED ([RedirectId]) ON [PRIMARY]
GO
CREATE UNIQUE NONCLUSTERED INDEX [ac_Redirects_IX1] ON [dbo].[ac_Redirects] ([LoweredSourceUrl]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Redirects] ADD CONSTRAINT [ac_Stores_ac_Redirects_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_RelatedProducts]

Tables [dbo].[ac_RelatedProducts]
.\SQL2005 > AC707 > Tables > dbo.ac_RelatedProducts
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Products_ac_RelatedProducts_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
 | OrderBy | smallint | 2 | No
Foreign Keys ac_Products_ac_RelatedProducts_FK2: [dbo].[ac_Products].ChildProductId | ChildProductId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_RelatedProducts_PK | ProductId, ChildProductId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Products_ac_RelatedProducts_FK1 | ProductId->[dbo].[ac_Products].[ProductId]
ac_Products_ac_RelatedProducts_FK2 | ChildProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_RelatedProducts]
(
[ProductId] [int] NOT NULL,
[OrderBy] [smallint] NOT NULL,
[ChildProductId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_RelatedProducts] ADD CONSTRAINT [ac_RelatedProducts_PK] PRIMARY KEY CLUSTERED ([ProductId], [ChildProductId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_RelatedProducts] ADD CONSTRAINT [ac_Products_ac_RelatedProducts_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId])
GO
ALTER TABLE [dbo].[ac_RelatedProducts] ADD CONSTRAINT [ac_Products_ac_RelatedProducts_FK2] FOREIGN KEY ([ChildProductId]) REFERENCES [dbo].[ac_Products] ([ProductId])
GO
Uses
  • [dbo].[ac_Products]
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_ReviewerProfiles]

Tables [dbo].[ac_ReviewerProfiles]
.\SQL2005 > AC707 > Tables > dbo.ac_ReviewerProfiles
  • Properties
  • Columns
  • Indexes
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ReviewerProfiles_PK: ReviewerProfileId | ReviewerProfileId | int | 4 | No | 1 - 1
 | Email | nvarchar(255) | 510 | No |
 | DisplayName | nvarchar(100) | 200 | No |
 | Location | nvarchar(50) | 100 | Yes |
 | EmailVerified | bit | 1 | No |
 | EmailVerificationCode | uniqueidentifier | 16 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ReviewerProfiles_PK: ReviewerProfileId | ac_ReviewerProfiles_PK | ReviewerProfileId | Yes
SQL Script
CREATE TABLE [dbo].[ac_ReviewerProfiles]
(
[ReviewerProfileId] [int] NOT NULL IDENTITY(1, 1),
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[DisplayName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Location] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[EmailVerified] [bit] NOT NULL,
[EmailVerificationCode] [uniqueidentifier] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ReviewerProfiles] ADD CONSTRAINT [ac_ReviewerProfiles_PK] PRIMARY KEY CLUSTERED ([ReviewerProfileId]) ON [PRIMARY]
GO
Uses
  • dbo
Used By
  • [dbo].[ac_ProductReviews]


[dbo].[ac_Roles]

Tables [dbo].[ac_Roles]
.\SQL2005 > AC707 > Tables > dbo.ac_Roles
  • Properties
  • Columns
  • Indexes
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Roles_PK: RoleId | RoleId | int | 4 | No | 1 - 1
 | Name | nvarchar(100) | 200 | No |
 | LoweredName | nvarchar(100) | 200 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Roles_PK: RoleId | ac_Roles_PK | RoleId | Yes
SQL Script
CREATE TABLE [dbo].[ac_Roles]
(
[RoleId] [int] NOT NULL IDENTITY(1, 1),
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LoweredName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Roles] ADD CONSTRAINT [ac_Roles_PK] PRIMARY KEY CLUSTERED ([RoleId]) ON [PRIMARY]
GO
Uses
  • dbo
Used By
  • [dbo].[ac_GroupRoles]


[dbo].[ac_SerialKeys]

Tables [dbo].[ac_SerialKeys]
.\SQL2005 > AC707 > Tables > dbo.ac_SerialKeys
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_LicenseKeys_PK: SerialKeyId | SerialKeyId | int | 4 | No | 1 - 1
Foreign Keys ac_DigitalGoods_ac_SerialKeys_FK1: [dbo].[ac_DigitalGoods].DigitalGoodId | DigitalGoodId | int | 4 | No |
 | SerialKeyData | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_LicenseKeys_PK: SerialKeyId | ac_LicenseKeys_PK | SerialKeyId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_DigitalGoods_ac_SerialKeys_FK1 | Cascade | DigitalGoodId->[dbo].[ac_DigitalGoods].[DigitalGoodId]
SQL Script
CREATE TABLE [dbo].[ac_SerialKeys]
(
[SerialKeyId] [int] NOT NULL IDENTITY(1, 1),
[DigitalGoodId] [int] NOT NULL,
[SerialKeyData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SerialKeys] ADD CONSTRAINT [ac_LicenseKeys_PK] PRIMARY KEY CLUSTERED ([SerialKeyId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SerialKeys] ADD CONSTRAINT [ac_DigitalGoods_ac_SerialKeys_FK1] FOREIGN KEY ([DigitalGoodId]) REFERENCES [dbo].[ac_DigitalGoods] ([DigitalGoodId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_DigitalGoods]
  • dbo


[dbo].[ac_SharedPersonalization]

Tables [dbo].[ac_SharedPersonalization]
.\SQL2005 > AC707 > Tables > dbo.ac_SharedPersonalization
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Cluster Primary Key ac_SharedPersonalization_PK: PersonalizationPathId Foreign Keys ac_Paths_ac_SharedPersonalization_FK1: [dbo].[ac_PersonalizationPaths].PersonalizationPathId | PersonalizationPathId | int | 4 | No
 | PageSettings | image | max | Yes
 | Theme | varchar(100) | 100 | Yes
 | MasterPageFile | varchar(100) | 100 | Yes
 | LastUpdatedDate | datetime | 8 | No
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_SharedPersonalization_PK: PersonalizationPathId | ac_SharedPersonalization_PK | PersonalizationPathId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Paths_ac_SharedPersonalization_FK1 | Cascade | PersonalizationPathId->[dbo].[ac_PersonalizationPaths].[PersonalizationPathId]
SQL Script
CREATE TABLE [dbo].[ac_SharedPersonalization]
(
[PersonalizationPathId] [int] NOT NULL,
[PageSettings] [image] NULL,
[Theme] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[MasterPageFile] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[LastUpdatedDate] [datetime] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SharedPersonalization] ADD CONSTRAINT [ac_SharedPersonalization_PK] PRIMARY KEY CLUSTERED ([PersonalizationPathId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SharedPersonalization] ADD CONSTRAINT [ac_Paths_ac_SharedPersonalization_FK1] FOREIGN KEY ([PersonalizationPathId]) REFERENCES [dbo].[ac_PersonalizationPaths] ([PersonalizationPathId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_PersonalizationPaths]
  • dbo


[dbo].[ac_ShipGateways]

Tables [dbo].[ac_ShipGateways]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipGateways
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ShipGateways_PK: ShipGatewayId | ShipGatewayId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_ShipGateways_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | ClassId | varchar(255) | 255 | No |
 | ConfigData | nvarchar(max) | max | Yes |
 | ReCrypt | bit | 1 | No |
 | Enabled | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ShipGateways_PK: ShipGatewayId | ac_ShipGateways_PK | ShipGatewayId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_ShipGateways_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_ShipGateways]
(
[ShipGatewayId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ClassId] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ConfigData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ReCrypt] [bit] NOT NULL,
[Enabled] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipGateways] ADD CONSTRAINT [ac_ShipGateways_PK] PRIMARY KEY CLUSTERED ([ShipGatewayId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipGateways] ADD CONSTRAINT [ac_Stores_ac_ShipGateways_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_ShipMethods]
  • [dbo].[ac_TrackingNumbers]


[dbo].[ac_ShipMethodGroups]

Tables [dbo].[ac_ShipMethodGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipMethodGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_ShipMethods_ac_ShipMethodGroups_FK1: [dbo].[ac_ShipMethods].ShipMethodId | ShipMethodId | int | 4 | No
Foreign Keys ac_Groups_ac_ShipMethodGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_ShipMethodGroups_PK | GroupId, ShipMethodId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Groups_ac_ShipMethodGroups_FK1 | GroupId->[dbo].[ac_Groups].[GroupId]
ac_ShipMethods_ac_ShipMethodGroups_FK1 | ShipMethodId->[dbo].[ac_ShipMethods].[ShipMethodId]
SQL Script
CREATE TABLE [dbo].[ac_ShipMethodGroups]
(
[ShipMethodId] [int] NOT NULL,
[GroupId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethodGroups] ADD CONSTRAINT [ac_ShipMethodGroups_PK] PRIMARY KEY CLUSTERED ([GroupId], [ShipMethodId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethodGroups] ADD CONSTRAINT [ac_Groups_ac_ShipMethodGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId])
GO
ALTER TABLE [dbo].[ac_ShipMethodGroups] ADD CONSTRAINT [ac_ShipMethods_ac_ShipMethodGroups_FK1] FOREIGN KEY ([ShipMethodId]) REFERENCES [dbo].[ac_ShipMethods] ([ShipMethodId])
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_ShipMethods]
  • dbo


[dbo].[ac_ShipMethods]

Tables [dbo].[ac_ShipMethods]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipMethods
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_ShipMethods_PK: ShipMethodId | ShipMethodId | int | 4 | No | 1 - 1 |
Foreign Keys ac_Stores_ac_ShipMethods_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |  |
 | ShipMethodTypeId | smallint | 2 | No |  |
 | Name | nvarchar(255) | 510 | No |  |
 | Surcharge | decimal(12,4) | 9 | No |  |
Foreign Keys ac_ShipGateways_ac_ShipMethods_FK1: [dbo].[ac_ShipGateways].ShipGatewayId | ShipGatewayId | int | 4 | Yes |  |
 | ServiceCode | nvarchar(255) | 510 | Yes |  |
 | MinPurchase | decimal(12,4) | 9 | No |  |
 | SurchargeIsVisible | bit | 1 | No |  |
 | SurchargeIsPercent | bit | 1 | Yes |  |
Foreign Keys ac_TaxCodes_ac_ShipMethods_FK1: [dbo].[ac_TaxCodes].TaxCodeId | TaxCodeId | int | 4 | Yes |  |
 | SurchargeTaxCodeId | int | 4 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ShipMethods_PK: ShipMethodId | ac_ShipMethods_PK | ShipMethodId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ShipGateways_ac_ShipMethods_FK1 | Cascade | ShipGatewayId->[dbo].[ac_ShipGateways].[ShipGatewayId]
ac_Stores_ac_ShipMethods_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
ac_TaxCodes_ac_ShipMethods_FK1 | SetNull | TaxCodeId->[dbo].[ac_TaxCodes].[TaxCodeId]
SQL Script
CREATE TABLE [dbo].[ac_ShipMethods]
(
[ShipMethodId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[ShipMethodTypeId] [smallint] NOT NULL,
[Name] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Surcharge] [decimal] (12, 4) NOT NULL,
[ShipGatewayId] [int] NULL,
[ServiceCode] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[MinPurchase] [decimal] (12, 4) NOT NULL,
[SurchargeIsVisible] [bit] NOT NULL,
[SurchargeIsPercent] [bit] NULL,
[TaxCodeId] [int] NULL,
[SurchargeTaxCodeId] [int] NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_ShipMe__Order__59FA5E80] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethods] ADD CONSTRAINT [ac_ShipMethods_PK] PRIMARY KEY CLUSTERED ([ShipMethodId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethods] ADD CONSTRAINT [ac_ShipGateways_ac_ShipMethods_FK1] FOREIGN KEY ([ShipGatewayId]) REFERENCES [dbo].[ac_ShipGateways] ([ShipGatewayId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ShipMethods] ADD CONSTRAINT [ac_Stores_ac_ShipMethods_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
ALTER TABLE [dbo].[ac_ShipMethods] ADD CONSTRAINT [ac_TaxCodes_ac_ShipMethods_FK1] FOREIGN KEY ([TaxCodeId]) REFERENCES [dbo].[ac_TaxCodes] ([TaxCodeId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_ShipGateways]
  • [dbo].[ac_Stores]
  • [dbo].[ac_TaxCodes]
  • dbo
Used By
  • [dbo].[ac_BasketShipments]
  • [dbo].[ac_CouponShipMethods]
  • [dbo].[ac_OrderShipments]
  • [dbo].[ac_ShipMethodGroups]
  • [dbo].[ac_ShipMethodShipZones]
  • [dbo].[ac_ShipMethodWarehouses]
  • [dbo].[ac_ShipRateMatrix]


[dbo].[ac_ShipMethodShipZones]

Tables [dbo].[ac_ShipMethodShipZones]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipMethodShipZones
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_ShipMethods_ac_ShipMethodShipZones_FK1: [dbo].[ac_ShipMethods].ShipMethodId | ShipMethodId | int | 4 | No
Foreign Keys ac_ShipZones_ac_ShipMethodShipZones_FK1: [dbo].[ac_ShipZones].ShipZoneId | ShipZoneId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_ShipMethodShipZones_PK | ShipMethodId, ShipZoneId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ShipMethods_ac_ShipMethodShipZones_FK1 | Cascade | ShipMethodId->[dbo].[ac_ShipMethods].[ShipMethodId]
ac_ShipZones_ac_ShipMethodShipZones_FK1 |  | ShipZoneId->[dbo].[ac_ShipZones].[ShipZoneId]
SQL Script
CREATE TABLE [dbo].[ac_ShipMethodShipZones]
(
[ShipMethodId] [int] NOT NULL,
[ShipZoneId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethodShipZones] ADD CONSTRAINT [ac_ShipMethodShipZones_PK] PRIMARY KEY CLUSTERED ([ShipMethodId], [ShipZoneId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethodShipZones] ADD CONSTRAINT [ac_ShipMethods_ac_ShipMethodShipZones_FK1] FOREIGN KEY ([ShipMethodId]) REFERENCES [dbo].[ac_ShipMethods] ([ShipMethodId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ShipMethodShipZones] ADD CONSTRAINT [ac_ShipZones_ac_ShipMethodShipZones_FK1] FOREIGN KEY ([ShipZoneId]) REFERENCES [dbo].[ac_ShipZones] ([ShipZoneId])
GO
Uses
  • [dbo].[ac_ShipMethods]
  • [dbo].[ac_ShipZones]
  • dbo


[dbo].[ac_ShipMethodWarehouses]

Tables [dbo].[ac_ShipMethodWarehouses]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipMethodWarehouses
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_ShipMethods_ac_ShipMethodWarehouses_FK1: [dbo].[ac_ShipMethods].ShipMethodId | ShipMethodId | int | 4 | No
Foreign Keys ac_Warehouses_ac_ShipMethodWarehouses_FK1: [dbo].[ac_Warehouses].WarehouseId | WarehouseId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_ShipMethodWarehouses_PK | ShipMethodId, WarehouseId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ShipMethods_ac_ShipMethodWarehouses_FK1 | Cascade | ShipMethodId->[dbo].[ac_ShipMethods].[ShipMethodId]
ac_Warehouses_ac_ShipMethodWarehouses_FK1 | Cascade | WarehouseId->[dbo].[ac_Warehouses].[WarehouseId]
SQL Script
CREATE TABLE [dbo].[ac_ShipMethodWarehouses]
(
[ShipMethodId] [int] NOT NULL,
[WarehouseId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethodWarehouses] ADD CONSTRAINT [ac_ShipMethodWarehouses_PK] PRIMARY KEY CLUSTERED ([ShipMethodId], [WarehouseId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipMethodWarehouses] ADD CONSTRAINT [ac_ShipMethods_ac_ShipMethodWarehouses_FK1] FOREIGN KEY ([ShipMethodId]) REFERENCES [dbo].[ac_ShipMethods] ([ShipMethodId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ShipMethodWarehouses] ADD CONSTRAINT [ac_Warehouses_ac_ShipMethodWarehouses_FK1] FOREIGN KEY ([WarehouseId]) REFERENCES [dbo].[ac_Warehouses] ([WarehouseId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_ShipMethods]
  • [dbo].[ac_Warehouses]
  • dbo


[dbo].[ac_ShipRateMatrix]

Tables [dbo].[ac_ShipRateMatrix]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipRateMatrix
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_ShipRateMatrix_PK: ShipRateMatrixId | ShipRateMatrixId | int | 4 | No | 1 - 1 |
Foreign Keys ac_ShipMethods_ac_ShipMatrix_FK1: [dbo].[ac_ShipMethods].ShipMethodId | ShipMethodId | int | 4 | No |  |
 | RangeStart | decimal(12,4) | 9 | Yes |  |
 | RangeEnd | decimal(12,4) | 9 | Yes |  |
 | Rate | decimal(12,4) | 9 | No |  |
 | IsPercent | bit | 1 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ShipRateMatrix_PK: ShipRateMatrixId | ac_ShipRateMatrix_PK | ShipRateMatrixId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ShipMethods_ac_ShipMatrix_FK1 | Cascade | ShipMethodId->[dbo].[ac_ShipMethods].[ShipMethodId]
SQL Script
CREATE TABLE [dbo].[ac_ShipRateMatrix]
(
[ShipRateMatrixId] [int] NOT NULL IDENTITY(1, 1),
[ShipMethodId] [int] NOT NULL,
[RangeStart] [decimal] (12, 4) NULL,
[RangeEnd] [decimal] (12, 4) NULL,
[Rate] [decimal] (12, 4) NOT NULL,
[IsPercent] [bit] NOT NULL CONSTRAINT [DF__ac_ShipRa__IsPer__534D60F1] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipRateMatrix] ADD CONSTRAINT [ac_ShipRateMatrix_PK] PRIMARY KEY CLUSTERED ([ShipRateMatrixId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipRateMatrix] ADD CONSTRAINT [ac_ShipMethods_ac_ShipMatrix_FK1] FOREIGN KEY ([ShipMethodId]) REFERENCES [dbo].[ac_ShipMethods] ([ShipMethodId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_ShipMethods]
  • dbo


[dbo].[ac_ShipZoneCountries]

Tables [dbo].[ac_ShipZoneCountries]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipZoneCountries
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_ShipZones_ac_ShipZoneCountries_FK1: [dbo].[ac_ShipZones].ShipZoneId | ShipZoneId | int | 4 | No
Foreign Keys ac_Countries_ac_ShipZoneCountries_FK1: [dbo].[ac_Countries].CountryCode | CountryCode | char(2) | 2 | No
Indexes Indexes
Name | Columns | Unique
ac_ShipZoneCountries_PK | ShipZoneId, CountryCode | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Countries_ac_ShipZoneCountries_FK1 | Cascade | CountryCode->[dbo].[ac_Countries].[CountryCode]
ac_ShipZones_ac_ShipZoneCountries_FK1 | Cascade | ShipZoneId->[dbo].[ac_ShipZones].[ShipZoneId]
SQL Script
CREATE TABLE [dbo].[ac_ShipZoneCountries]
(
[ShipZoneId] [int] NOT NULL,
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipZoneCountries] ADD CONSTRAINT [ac_ShipZoneCountries_PK] PRIMARY KEY CLUSTERED ([ShipZoneId], [CountryCode]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipZoneCountries] ADD CONSTRAINT [ac_Countries_ac_ShipZoneCountries_FK1] FOREIGN KEY ([CountryCode]) REFERENCES [dbo].[ac_Countries] ([CountryCode]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ShipZoneCountries] ADD CONSTRAINT [ac_ShipZones_ac_ShipZoneCountries_FK1] FOREIGN KEY ([ShipZoneId]) REFERENCES [dbo].[ac_ShipZones] ([ShipZoneId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Countries]
  • [dbo].[ac_ShipZones]
  • dbo


[dbo].[ac_ShipZoneProvinces]

Tables [dbo].[ac_ShipZoneProvinces]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipZoneProvinces
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_ShipZones_ac_ShipZoneProvinces_FK1: [dbo].[ac_ShipZones].ShipZoneId | ShipZoneId | int | 4 | No
Foreign Keys ac_Provinces_ac_ShipZoneProvinces_FK1: [dbo].[ac_Provinces].ProvinceId | ProvinceId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_ShipZoneProvinces_PK | ProvinceId, ShipZoneId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Provinces_ac_ShipZoneProvinces_FK1 | Cascade | ProvinceId->[dbo].[ac_Provinces].[ProvinceId]
ac_ShipZones_ac_ShipZoneProvinces_FK1 | Cascade | ShipZoneId->[dbo].[ac_ShipZones].[ShipZoneId]
SQL Script
CREATE TABLE [dbo].[ac_ShipZoneProvinces]
(
[ShipZoneId] [int] NOT NULL,
[ProvinceId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipZoneProvinces] ADD CONSTRAINT [ac_ShipZoneProvinces_PK] PRIMARY KEY CLUSTERED ([ProvinceId], [ShipZoneId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipZoneProvinces] ADD CONSTRAINT [ac_Provinces_ac_ShipZoneProvinces_FK1] FOREIGN KEY ([ProvinceId]) REFERENCES [dbo].[ac_Provinces] ([ProvinceId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_ShipZoneProvinces] ADD CONSTRAINT [ac_ShipZones_ac_ShipZoneProvinces_FK1] FOREIGN KEY ([ShipZoneId]) REFERENCES [dbo].[ac_ShipZones] ([ShipZoneId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Provinces]
  • [dbo].[ac_ShipZones]
  • dbo


[dbo].[ac_ShipZones]

Tables [dbo].[ac_ShipZones]
.\SQL2005 > AC707 > Tables > dbo.ac_ShipZones
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_ShipZones_PK: ShipZoneId | ShipZoneId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_ShipZones_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(255) | 510 | No |
 | CountryRuleId | tinyint | 1 | No |
 | ProvinceRuleId | tinyint | 1 | No |
Indexes ac_ShipZones_IX1: PostalCodeFilter | PostalCodeFilter | nvarchar(255) | 510 | Yes |
 | ExcludePostalCodeFilter | nvarchar(255) | 510 | Yes |
 | UsePCPM | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_ShipZones_PK: ShipZoneId | ac_ShipZones_PK | ShipZoneId | Yes
 | ac_ShipZones_IX1 | PostalCodeFilter |
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_ShipZones_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_ShipZones]
(
[ShipZoneId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[CountryRuleId] [tinyint] NOT NULL,
[ProvinceRuleId] [tinyint] NOT NULL,
[PostalCodeFilter] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ExcludePostalCodeFilter] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[UsePCPM] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipZones] ADD CONSTRAINT [ac_ShipZones_PK] PRIMARY KEY CLUSTERED ([ShipZoneId]) ON [PRIMARY]
GO
CREATE NONCLUSTERED INDEX [ac_ShipZones_IX1] ON [dbo].[ac_ShipZones] ([PostalCodeFilter]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_ShipZones] ADD CONSTRAINT [ac_Stores_ac_ShipZones_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_ShipMethodShipZones]
  • [dbo].[ac_ShipZoneCountries]
  • [dbo].[ac_ShipZoneProvinces]
  • [dbo].[ac_TaxRuleShipZones]


[dbo].[ac_SpecialGroups]

Tables [dbo].[ac_SpecialGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_SpecialGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Specials_ac_SpecialGroups_FK1: [dbo].[ac_Specials].SpecialId | SpecialId | int | 4 | No
Foreign Keys ac_Groups_ac_SpecialGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_SpecialGroups_PK | SpecialId, GroupId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_SpecialGroups_FK1 | Cascade | GroupId->[dbo].[ac_Groups].[GroupId]
ac_Specials_ac_SpecialGroups_FK1 | Cascade | SpecialId->[dbo].[ac_Specials].[SpecialId]
SQL Script
CREATE TABLE [dbo].[ac_SpecialGroups]
(
[SpecialId] [int] NOT NULL,
[GroupId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SpecialGroups] ADD CONSTRAINT [ac_SpecialGroups_PK] PRIMARY KEY CLUSTERED ([SpecialId], [GroupId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SpecialGroups] ADD CONSTRAINT [ac_Groups_ac_SpecialGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_SpecialGroups] ADD CONSTRAINT [ac_Specials_ac_SpecialGroups_FK1] FOREIGN KEY ([SpecialId]) REFERENCES [dbo].[ac_Specials] ([SpecialId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_Specials]
  • dbo


[dbo].[ac_Specials]

Tables [dbo].[ac_Specials]
.\SQL2005 > AC707 > Tables > dbo.ac_Specials
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Specials_PK: SpecialId | SpecialId | int | 4 | No | 1 - 1
Foreign Keys ac_Products_ac_Specials_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
 | Price | decimal(12,4) | 9 | No |
 | StartDate | datetime | 8 | Yes |
 | EndDate | datetime | 8 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Specials_PK: SpecialId | ac_Specials_PK | SpecialId | Yes
Foreign Keys Foreign Keys
Name | No Check | Columns
ac_Products_ac_Specials_FK1 | Yes | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_Specials]
(
[SpecialId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[Price] [decimal] (12, 4) NOT NULL,
[StartDate] [datetime] NULL,
[EndDate] [datetime] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Specials] ADD CONSTRAINT [ac_Specials_PK] PRIMARY KEY CLUSTERED ([SpecialId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Specials] WITH NOCHECK ADD CONSTRAINT [ac_Products_ac_Specials_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId])
GO
ALTER TABLE [dbo].[ac_Specials] NOCHECK CONSTRAINT [ac_Products_ac_Specials_FK1]
GO
Uses
  • [dbo].[ac_Products]
  • dbo
Used By
  • [dbo].[ac_SpecialGroups]


[dbo].[ac_Stores]

Tables [dbo].[ac_Stores]
.\SQL2005 > AC707 > Tables > dbo.ac_Stores
  • Properties
  • Columns
  • Indexes
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_Stores_PK: StoreId | StoreId | int | 4 | No | 1 - 1 |
 | Name | nvarchar(100) | 200 | No |  |
 | ApplicationName | nvarchar(255) | 510 | No |  |
 | LoweredApplicationName | nvarchar(255) | 510 | No |  |
 | LicenseKey | varchar(max) | max | Yes |  |
 | DefaultWarehouseId | int | 4 | Yes |  |
 | NextOrderId | int | 4 | No |  | ((1))
 | OrderIdIncrement | smallint | 2 | No |  | ((1))
 | WeightUnitId | smallint | 2 | No |  |
 | MeasurementUnitId | smallint | 2 | No |  |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Stores_PK: StoreId | ac_Stores_PK | StoreId | Yes
SQL Script
CREATE TABLE [dbo].[ac_Stores]
(
[StoreId] [int] NOT NULL IDENTITY(1, 1),
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ApplicationName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LoweredApplicationName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LicenseKey] [varchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DefaultWarehouseId] [int] NULL,
[NextOrderId] [int] NOT NULL CONSTRAINT [DF__ac_Stores__NextO__45F365D3] DEFAULT ((1)),
[OrderIdIncrement] [smallint] NOT NULL CONSTRAINT [DF__ac_Stores__Order__46E78A0C] DEFAULT ((1)),
[WeightUnitId] [smallint] NOT NULL,
[MeasurementUnitId] [smallint] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Stores] ADD CONSTRAINT [ac_Stores_PK] PRIMARY KEY CLUSTERED ([StoreId]) ON [PRIMARY]
GO
Uses
  • dbo
Used By
  • [dbo].[ac_Affiliates]
  • [dbo].[ac_AuditEvents]
  • [dbo].[ac_BannedIPs]
  • [dbo].[ac_Categories]
  • [dbo].[ac_Countries]
  • [dbo].[ac_Coupons]
  • [dbo].[ac_Currencies]
  • [dbo].[ac_CustomFields]
  • [dbo].[ac_CustomUrls]
  • [dbo].[ac_DigitalGoods]
  • [dbo].[ac_EmailLists]
  • [dbo].[ac_EmailTemplates]
  • [dbo].[ac_ErrorMessages]
  • [dbo].[ac_GiftCertificates]
  • [dbo].[ac_Groups]
  • [dbo].[ac_KitComponents]
  • [dbo].[ac_LicenseAgreements]
  • [dbo].[ac_Links]
  • [dbo].[ac_Manufacturers]
  • [dbo].[ac_Orders]
  • [dbo].[ac_OrderStatuses]
  • [dbo].[ac_PageViews]
  • [dbo].[ac_PaymentGateways]
  • [dbo].[ac_PaymentMethods]
  • [dbo].[ac_PersonalizationPaths]
  • [dbo].[ac_Products]
  • [dbo].[ac_ProductTemplates]
  • [dbo].[ac_Readmes]
  • [dbo].[ac_Redirects]
  • [dbo].[ac_ShipGateways]
  • [dbo].[ac_ShipMethods]
  • [dbo].[ac_ShipZones]
  • [dbo].[ac_StoreSettings]
  • [dbo].[ac_TaxCodes]
  • [dbo].[ac_TaxGateways]
  • [dbo].[ac_TaxRules]
  • [dbo].[ac_Users]
  • [dbo].[ac_Vendors]
  • [dbo].[ac_VolumeDiscounts]
  • [dbo].[ac_Warehouses]
  • [dbo].[ac_Webpages]
  • [dbo].[ac_WrapGroups]


[dbo].[ac_StoreSettings]

Tables [dbo].[ac_StoreSettings]
.\SQL2005 > AC707 > Tables > dbo.ac_StoreSettings
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_StoreSettings_PK: StoreSettingId | StoreSettingId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_StoreSettings_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | FieldName | nvarchar(255) | 510 | No |
 | FieldValue | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_StoreSettings_PK: StoreSettingId | ac_StoreSettings_PK | StoreSettingId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Stores_ac_StoreSettings_FK1 | Cascade | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_StoreSettings]
(
[StoreSettingId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[FieldName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[FieldValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_StoreSettings] ADD CONSTRAINT [ac_StoreSettings_PK] PRIMARY KEY CLUSTERED ([StoreSettingId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_StoreSettings] ADD CONSTRAINT [ac_Stores_ac_StoreSettings_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_SubscriptionPlans]

Tables [dbo].[ac_SubscriptionPlans]
.\SQL2005 > AC707 > Tables > dbo.ac_SubscriptionPlans
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Cluster Primary Key ac_SubscriptionPlans_PK: ProductId Foreign Keys ac_Products_ac_SubscriptionPlans_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
 | Name | nvarchar(100) | 200 | No
 | NumberOfPayments | smallint | 2 | No
 | PaymentFrequency | smallint | 2 | No
 | PaymentFrequencyUnitId | tinyint | 1 | No
 | RecurringCharge | decimal(9,2) | 5 | No
 | RecurringChargeSpecified | bit | 1 | No
Foreign Keys ac_Groups_ac_SubscriptionPlans_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | Yes
Foreign Keys ac_TaxCodes_ac_SubscriptionPlans_FK1: [dbo].[ac_TaxCodes].TaxCodeId | TaxCodeId | int | 4 | Yes
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_SubscriptionPlans_PK: ProductId | ac_SubscriptionPlans_PK | ProductId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_SubscriptionPlans_FK1 | SetNull | GroupId->[dbo].[ac_Groups].[GroupId]
ac_Products_ac_SubscriptionPlans_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
ac_TaxCodes_ac_SubscriptionPlans_FK1 | SetNull | TaxCodeId->[dbo].[ac_TaxCodes].[TaxCodeId]
SQL Script
CREATE TABLE [dbo].[ac_SubscriptionPlans]
(
[ProductId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[NumberOfPayments] [smallint] NOT NULL,
[PaymentFrequency] [smallint] NOT NULL,
[PaymentFrequencyUnitId] [tinyint] NOT NULL,
[RecurringCharge] [decimal] (9, 2) NOT NULL,
[RecurringChargeSpecified] [bit] NOT NULL,
[GroupId] [int] NULL,
[TaxCodeId] [int] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SubscriptionPlans] ADD CONSTRAINT [ac_SubscriptionPlans_PK] PRIMARY KEY CLUSTERED ([ProductId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_SubscriptionPlans] ADD CONSTRAINT [ac_Groups_ac_SubscriptionPlans_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_SubscriptionPlans] ADD CONSTRAINT [ac_Products_ac_SubscriptionPlans_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_SubscriptionPlans] ADD CONSTRAINT [ac_TaxCodes_ac_SubscriptionPlans_FK1] FOREIGN KEY ([TaxCodeId]) REFERENCES [dbo].[ac_TaxCodes] ([TaxCodeId]) ON DELETE SET NULL
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_Products]
  • [dbo].[ac_TaxCodes]
  • dbo
Used By
  • [dbo].[ac_Subscriptions]


[dbo].[ac_Subscriptions]

Tables [dbo].[ac_Subscriptions]
.\SQL2005 > AC707 > Tables > dbo.ac_Subscriptions
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Subscriptions_PK: SubscriptionId | SubscriptionId | int | 4 | No | 1 - 1
Foreign Keys ac_SubscriptionPlans_ac_Subscriptions_FK1: [dbo].[ac_SubscriptionPlans].ProductId | ProductId | int | 4 | No |
Foreign Keys ac_Users_ac_Subscriptions_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No |
Foreign Keys ac_OrderItems_ac_Subscriptions_FK1: [dbo].[ac_OrderItems].OrderItemId | OrderItemId | int | 4 | Yes |
Foreign Keys ac_Transactions_ac_Subscriptions_FK1: [dbo].[ac_Transactions].TransactionId | TransactionId | int | 4 | Yes |
 | IsActive | bit | 1 | No |
 | ExpirationDate | datetime | 8 | Yes |
 | GroupId | int | 4 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Subscriptions_PK: SubscriptionId | ac_Subscriptions_PK | SubscriptionId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_OrderItems_ac_Subscriptions_FK1 | SetNull | OrderItemId->[dbo].[ac_OrderItems].[OrderItemId]
ac_SubscriptionPlans_ac_Subscriptions_FK1 | Cascade | ProductId->[dbo].[ac_SubscriptionPlans].[ProductId]
ac_Transactions_ac_Subscriptions_FK1 |  | TransactionId->[dbo].[ac_Transactions].[TransactionId]
ac_Users_ac_Subscriptions_FK1 | Cascade | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_Subscriptions]
(
[SubscriptionId] [int] NOT NULL IDENTITY(1, 1),
[ProductId] [int] NOT NULL,
[UserId] [int] NOT NULL,
[OrderItemId] [int] NULL,
[TransactionId] [int] NULL,
[IsActive] [bit] NOT NULL,
[ExpirationDate] [datetime] NULL,
[GroupId] [int] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Subscriptions] ADD CONSTRAINT [ac_Subscriptions_PK] PRIMARY KEY CLUSTERED ([SubscriptionId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Subscriptions] ADD CONSTRAINT [ac_OrderItems_ac_Subscriptions_FK1] FOREIGN KEY ([OrderItemId]) REFERENCES [dbo].[ac_OrderItems] ([OrderItemId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Subscriptions] ADD CONSTRAINT [ac_SubscriptionPlans_ac_Subscriptions_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_SubscriptionPlans] ([ProductId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_Subscriptions] ADD CONSTRAINT [ac_Transactions_ac_Subscriptions_FK1] FOREIGN KEY ([TransactionId]) REFERENCES [dbo].[ac_Transactions] ([TransactionId])
GO
ALTER TABLE [dbo].[ac_Subscriptions] ADD CONSTRAINT [ac_Users_ac_Subscriptions_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_OrderItems]
  • [dbo].[ac_SubscriptionPlans]
  • [dbo].[ac_Transactions]
  • [dbo].[ac_Users]
  • dbo
Used By
  • [dbo].[ac_Payments]
  • [dbo].[ac_UserGroups]
  • [dbo].[acsp_MergeUserGroupMembers]


[dbo].[ac_TaxCodes]

Tables [dbo].[ac_TaxCodes]
.\SQL2005 > AC707 > Tables > dbo.ac_TaxCodes
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_TaxCodes_PK: TaxCodeId | TaxCodeId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_TaxCodes_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_TaxCodes_PK: TaxCodeId | ac_TaxCodes_PK | TaxCodeId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_TaxCodes_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_TaxCodes]
(
[TaxCodeId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxCodes] ADD CONSTRAINT [ac_TaxCodes_PK] PRIMARY KEY CLUSTERED ([TaxCodeId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxCodes] ADD CONSTRAINT [ac_Stores_ac_TaxCodes_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_BasketItems]
  • [dbo].[ac_OrderItems]
  • [dbo].[ac_Products]
  • [dbo].[ac_ShipMethods]
  • [dbo].[ac_SubscriptionPlans]
  • [dbo].[ac_TaxRuleTaxCodes]
  • [dbo].[ac_WrapStyles]


[dbo].[ac_TaxGateways]

Tables [dbo].[ac_TaxGateways]
.\SQL2005 > AC707 > Tables > dbo.ac_TaxGateways
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_TaxGateways_PK: TaxGatewayId | TaxGatewayId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_TaxGateways_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | ClassId | varchar(255) | 255 | No |
 | ConfigData | nvarchar(max) | max | Yes |
 | ReCrypt | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_TaxGateways_PK: TaxGatewayId | ac_TaxGateways_PK | TaxGatewayId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_TaxGateways_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_TaxGateways]
(
[TaxGatewayId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ClassId] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[ConfigData] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ReCrypt] [bit] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxGateways] ADD CONSTRAINT [ac_TaxGateways_PK] PRIMARY KEY CLUSTERED ([TaxGatewayId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxGateways] ADD CONSTRAINT [ac_Stores_ac_TaxGateways_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_TaxRuleGroups]

Tables [dbo].[ac_TaxRuleGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_TaxRuleGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_TaxRules_ac_TaxRuleGroups_FK1: [dbo].[ac_TaxRules].TaxRuleId | TaxRuleId | int | 4 | No
Foreign Keys ac_Groups_ac_TaxRuleGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_TaxRuleGroups_PK | GroupId, TaxRuleId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_TaxRuleGroups_FK1 | Cascade | GroupId->[dbo].[ac_Groups].[GroupId]
ac_TaxRules_ac_TaxRuleGroups_FK1 | Cascade | TaxRuleId->[dbo].[ac_TaxRules].[TaxRuleId]
SQL Script
CREATE TABLE [dbo].[ac_TaxRuleGroups]
(
[TaxRuleId] [int] NOT NULL,
[GroupId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRuleGroups] ADD CONSTRAINT [ac_TaxRuleGroups_PK] PRIMARY KEY CLUSTERED ([GroupId], [TaxRuleId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRuleGroups] ADD CONSTRAINT [ac_Groups_ac_TaxRuleGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_TaxRuleGroups] ADD CONSTRAINT [ac_TaxRules_ac_TaxRuleGroups_FK1] FOREIGN KEY ([TaxRuleId]) REFERENCES [dbo].[ac_TaxRules] ([TaxRuleId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_TaxRules]
  • dbo


[dbo].[ac_TaxRules]

Tables [dbo].[ac_TaxRules]
.\SQL2005 > AC707 > Tables > dbo.ac_TaxRules
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_TaxRules_PK: TaxRuleId | TaxRuleId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_TaxRules_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | TaxRate | decimal(9,4) | 5 | No |
 | UseBillingAddress | bit | 1 | No |
 | GroupRuleId | tinyint | 1 | No |
 | TaxCodeId | int | 4 | Yes |
 | Priority | smallint | 2 | No |
 | RoundingRuleId | tinyint | 1 | No |
 | UsePerItemTax | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_TaxRules_PK: TaxRuleId | ac_TaxRules_PK | TaxRuleId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_TaxRules_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_TaxRules]
(
[TaxRuleId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[TaxRate] [decimal] (9, 4) NOT NULL,
[UseBillingAddress] [bit] NOT NULL,
[GroupRuleId] [tinyint] NOT NULL,
[TaxCodeId] [int] NULL,
[Priority] [smallint] NOT NULL,
[RoundingRuleId] [tinyint] NOT NULL,
[UsePerItemTax] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRules] ADD CONSTRAINT [ac_TaxRules_PK] PRIMARY KEY CLUSTERED ([TaxRuleId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRules] ADD CONSTRAINT [ac_Stores_ac_TaxRules_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_TaxRuleGroups]
  • [dbo].[ac_TaxRuleShipZones]
  • [dbo].[ac_TaxRuleTaxCodes]


[dbo].[ac_TaxRuleShipZones]

Tables [dbo].[ac_TaxRuleShipZones]
.\SQL2005 > AC707 > Tables > dbo.ac_TaxRuleShipZones
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_TaxRules_ac_TaxRuleShipZones_FK1: [dbo].[ac_TaxRules].TaxRuleId | TaxRuleId | int | 4 | No
Foreign Keys ac_ShipZones_ac_TaxRuleShipZones_FK1: [dbo].[ac_ShipZones].ShipZoneId | ShipZoneId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_TaxRuleShipZones_PK | TaxRuleId, ShipZoneId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ShipZones_ac_TaxRuleShipZones_FK1 | Cascade | ShipZoneId->[dbo].[ac_ShipZones].[ShipZoneId]
ac_TaxRules_ac_TaxRuleShipZones_FK1 | Cascade | TaxRuleId->[dbo].[ac_TaxRules].[TaxRuleId]
SQL Script
CREATE TABLE [dbo].[ac_TaxRuleShipZones]
(
[TaxRuleId] [int] NOT NULL,
[ShipZoneId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRuleShipZones] ADD CONSTRAINT [ac_TaxRuleShipZones_PK] PRIMARY KEY CLUSTERED ([TaxRuleId], [ShipZoneId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRuleShipZones] ADD CONSTRAINT [ac_ShipZones_ac_TaxRuleShipZones_FK1] FOREIGN KEY ([ShipZoneId]) REFERENCES [dbo].[ac_ShipZones] ([ShipZoneId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_TaxRuleShipZones] ADD CONSTRAINT [ac_TaxRules_ac_TaxRuleShipZones_FK1] FOREIGN KEY ([TaxRuleId]) REFERENCES [dbo].[ac_TaxRules] ([TaxRuleId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_ShipZones]
  • [dbo].[ac_TaxRules]
  • dbo


[dbo].[ac_TaxRuleTaxCodes]

Tables [dbo].[ac_TaxRuleTaxCodes]
.\SQL2005 > AC707 > Tables > dbo.ac_TaxRuleTaxCodes
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_TaxRules_ac_TaxRuleTaxCodeAssn_FK1: [dbo].[ac_TaxRules].TaxRuleId | TaxRuleId | int | 4 | No
Foreign Keys ac_TaxCodes_ac_TaxRuleTaxCodeAssn_FK1: [dbo].[ac_TaxCodes].TaxCodeId | TaxCodeId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_TaxRuleTaxCodes_PK | TaxRuleId, TaxCodeId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_TaxCodes_ac_TaxRuleTaxCodeAssn_FK1 | Cascade | TaxCodeId->[dbo].[ac_TaxCodes].[TaxCodeId]
ac_TaxRules_ac_TaxRuleTaxCodeAssn_FK1 | Cascade | TaxRuleId->[dbo].[ac_TaxRules].[TaxRuleId]
SQL Script
CREATE TABLE [dbo].[ac_TaxRuleTaxCodes]
(
[TaxRuleId] [int] NOT NULL,
[TaxCodeId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRuleTaxCodes] ADD CONSTRAINT [ac_TaxRuleTaxCodes_PK] PRIMARY KEY CLUSTERED ([TaxRuleId], [TaxCodeId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TaxRuleTaxCodes] ADD CONSTRAINT [ac_TaxCodes_ac_TaxRuleTaxCodeAssn_FK1] FOREIGN KEY ([TaxCodeId]) REFERENCES [dbo].[ac_TaxCodes] ([TaxCodeId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_TaxRuleTaxCodes] ADD CONSTRAINT [ac_TaxRules_ac_TaxRuleTaxCodeAssn_FK1] FOREIGN KEY ([TaxRuleId]) REFERENCES [dbo].[ac_TaxRules] ([TaxRuleId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_TaxCodes]
  • [dbo].[ac_TaxRules]
  • dbo


[dbo].[ac_TrackingNumbers]

Tables [dbo].[ac_TrackingNumbers]
.\SQL2005 > AC707 > Tables > dbo.ac_TrackingNumbers
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_TrackingNumbers_PK: TrackingNumberId | TrackingNumberId | int | 4 | No | 1 - 1
Foreign Keys ac_Shipments_ac_Tracking_FK1: [dbo].[ac_OrderShipments].OrderShipmentId | OrderShipmentId | int | 4 | No |
Foreign Keys ac_ShipGateways_ac_Tracking_FK1: [dbo].[ac_ShipGateways].ShipGatewayId | ShipGatewayId | int | 4 | Yes |
 | TrackingNumberData | nvarchar(100) | 200 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_TrackingNumbers_PK: TrackingNumberId | ac_TrackingNumbers_PK | TrackingNumberId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_ShipGateways_ac_Tracking_FK1 | SetNull | ShipGatewayId->[dbo].[ac_ShipGateways].[ShipGatewayId]
ac_Shipments_ac_Tracking_FK1 | Cascade | OrderShipmentId->[dbo].[ac_OrderShipments].[OrderShipmentId]
SQL Script
CREATE TABLE [dbo].[ac_TrackingNumbers]
(
[TrackingNumberId] [int] NOT NULL IDENTITY(1, 1),
[OrderShipmentId] [int] NOT NULL,
[ShipGatewayId] [int] NULL,
[TrackingNumberData] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TrackingNumbers] ADD CONSTRAINT [ac_TrackingNumbers_PK] PRIMARY KEY CLUSTERED ([TrackingNumberId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_TrackingNumbers] ADD CONSTRAINT [ac_ShipGateways_ac_Tracking_FK1] FOREIGN KEY ([ShipGatewayId]) REFERENCES [dbo].[ac_ShipGateways] ([ShipGatewayId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_TrackingNumbers] ADD CONSTRAINT [ac_Shipments_ac_Tracking_FK1] FOREIGN KEY ([OrderShipmentId]) REFERENCES [dbo].[ac_OrderShipments] ([OrderShipmentId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_OrderShipments]
  • [dbo].[ac_ShipGateways]
  • dbo


[dbo].[ac_Transactions]

Tables [dbo].[ac_Transactions]
.\SQL2005 > AC707 > Tables > dbo.ac_Transactions
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Transactions_PK: TransactionId | TransactionId | int | 4 | No | 1 - 1
 | TransactionTypeId | smallint | 2 | No |
Foreign Keys ac_Payments_ac_Transactions_FK1: [dbo].[ac_Payments].PaymentId | PaymentId | int | 4 | No |
Foreign Keys ac_PaymentGateways_ac_Transactions_FK1: [dbo].[ac_PaymentGateways].PaymentGatewayId | PaymentGatewayId | int | 4 | Yes |
 | ProviderTransactionId | nvarchar(50) | 100 | Yes |
 | TransactionDate | datetime | 8 | No |
 | Amount | decimal(12,4) | 9 | No |
 | TransactionStatusId | smallint | 2 | No |
 | ResponseCode | nvarchar(50) | 100 | Yes |
 | ResponseMessage | nvarchar(255) | 510 | Yes |
 | AuthorizationCode | nvarchar(255) | 510 | Yes |
 | AVSResultCode | char(1) | 1 | Yes |
 | CVVResultCode | char(1) | 1 | Yes |
 | CAVResultCode | char(1) | 1 | Yes |
 | RemoteIP | varchar(39) | 39 | Yes |
 | Referrer | nvarchar(255) | 510 | Yes |
 | AdditionalData | nvarchar(255) | 510 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Transactions_PK: TransactionId | ac_Transactions_PK | TransactionId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_PaymentGateways_ac_Transactions_FK1 | SetNull | PaymentGatewayId->[dbo].[ac_PaymentGateways].[PaymentGatewayId]
ac_Payments_ac_Transactions_FK1 | Cascade | PaymentId->[dbo].[ac_Payments].[PaymentId]
SQL Script
CREATE TABLE [dbo].[ac_Transactions]
(
[TransactionId] [int] NOT NULL IDENTITY(1, 1),
[TransactionTypeId] [smallint] NOT NULL,
[PaymentId] [int] NOT NULL,
[PaymentGatewayId] [int] NULL,
[ProviderTransactionId] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[TransactionDate] [datetime] NOT NULL,
[Amount] [decimal] (12, 4) NOT NULL,
[TransactionStatusId] [smallint] NOT NULL,
[ResponseCode] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ResponseMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[AuthorizationCode] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[AVSResultCode] [char] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CVVResultCode] [char] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CAVResultCode] [char] (1) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[RemoteIP] [varchar] (39) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Referrer] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[AdditionalData] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Transactions] ADD CONSTRAINT [ac_Transactions_PK] PRIMARY KEY CLUSTERED ([TransactionId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Transactions] ADD CONSTRAINT [ac_PaymentGateways_ac_Transactions_FK1] FOREIGN KEY ([PaymentGatewayId]) REFERENCES [dbo].[ac_PaymentGateways] ([PaymentGatewayId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Transactions] ADD CONSTRAINT [ac_Payments_ac_Transactions_FK1] FOREIGN KEY ([PaymentId]) REFERENCES [dbo].[ac_Payments] ([PaymentId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_PaymentGateways]
  • [dbo].[ac_Payments]
  • dbo
Used By
  • [dbo].[ac_Subscriptions]


[dbo].[ac_UpsellProducts]

Tables [dbo].[ac_UpsellProducts]
.\SQL2005 > AC707 > Tables > dbo.ac_UpsellProducts
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:49 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Products_ac_UpsellProducts_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No
 | ChildProductId | int | 4 | No
 | OrderBy | smallint | 2 | No
Indexes Indexes
Name | Columns | Unique
ac_UpsellProducts_PK | ProductId, ChildProductId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_UpsellProducts_FK1 | Cascade | ProductId->[dbo].[ac_Products].[ProductId]
SQL Script
CREATE TABLE [dbo].[ac_UpsellProducts]
(
[ProductId] [int] NOT NULL,
[ChildProductId] [int] NOT NULL,
[OrderBy] [smallint] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UpsellProducts] ADD CONSTRAINT [ac_UpsellProducts_PK] PRIMARY KEY CLUSTERED ([ProductId], [ChildProductId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UpsellProducts] ADD CONSTRAINT [ac_Products_ac_UpsellProducts_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • dbo


[dbo].[ac_UpsOrigin]

Tables [dbo].[ac_UpsOrigin]
.\SQL2005 > AC707 > Tables > dbo.ac_UpsOrigin
  • Properties
  • Columns
  • Indexes
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:48 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Cluster Primary Key ac_UpsOrigin_PK: CountryCode | CountryCode | char(2) | 2 | No
 | CountryName | nvarchar(100) | 200 | Yes
 | CurrencyName | nvarchar(50) | 100 | Yes
 | CurrencyCode | nvarchar(3) | 6 | Yes
 | EuroAllowed | smallint | 2 | Yes
 | MIVDollar | decimal(12,4) | 9 | Yes
 | MIVEuro | decimal(12,4) | 9 | Yes
 | UOM | smallint | 2 | Yes
 | MaxWeight | decimal(12,4) | 9 | Yes
 | MaxMetricWeight | decimal(12,4) | 9 | Yes
 | EUMember | smallint | 2 | Yes
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_UpsOrigin_PK: CountryCode | ac_UpsOrigin_PK | CountryCode | Yes
SQL Script
CREATE TABLE [dbo].[ac_UpsOrigin]
(
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[CountryName] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CurrencyName] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CurrencyCode] [nvarchar] (3) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[EuroAllowed] [smallint] NULL,
[MIVDollar] [decimal] (12, 4) NULL,
[MIVEuro] [decimal] (12, 4) NULL,
[UOM] [smallint] NULL,
[MaxWeight] [decimal] (12, 4) NULL,
[MaxMetricWeight] [decimal] (12, 4) NULL,
[EUMember] [smallint] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UpsOrigin] ADD CONSTRAINT [ac_UpsOrigin_PK] PRIMARY KEY CLUSTERED ([CountryCode]) ON [PRIMARY]
GO
Uses
  • dbo


[dbo].[ac_UserGroups]

Tables [dbo].[ac_UserGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_UserGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Users_ac_UserGroups_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No
Foreign Keys ac_Groups_ac_UserGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Foreign Keys ac_Subscriptions_ac_UserGroups_FK1: [dbo].[ac_Subscriptions].SubscriptionId | SubscriptionId | int | 4 | Yes
Indexes Indexes
Name | Columns | Unique
ac_UserGroups_PK | GroupId, UserId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_UserGroups_FK1 | Cascade | GroupId->[dbo].[ac_Groups].[GroupId]
ac_Subscriptions_ac_UserGroups_FK1 |  | SubscriptionId->[dbo].[ac_Subscriptions].[SubscriptionId]
ac_Users_ac_UserGroups_FK1 | Cascade | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_UserGroups]
(
[UserId] [int] NOT NULL,
[GroupId] [int] NOT NULL,
[SubscriptionId] [int] NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserGroups] ADD CONSTRAINT [ac_UserGroups_PK] PRIMARY KEY CLUSTERED ([GroupId], [UserId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserGroups] ADD CONSTRAINT [ac_Groups_ac_UserGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_UserGroups] ADD CONSTRAINT [ac_Subscriptions_ac_UserGroups_FK1] FOREIGN KEY ([SubscriptionId]) REFERENCES [dbo].[ac_Subscriptions] ([SubscriptionId])
GO
ALTER TABLE [dbo].[ac_UserGroups] ADD CONSTRAINT [ac_Users_ac_UserGroups_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_Subscriptions]
  • [dbo].[ac_Users]
  • dbo
Used By
  • [dbo].[acsp_MergeUserGroupMembers]


[dbo].[ac_UserPasswords]

Tables [dbo].[ac_UserPasswords]
.\SQL2005 > AC707 > Tables > dbo.ac_UserPasswords
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Users_ac_UserPasswords_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No
 | PasswordNumber | tinyint | 1 | No
 | Password | nvarchar(255) | 510 | No
 | PasswordFormat | nvarchar(10) | 20 | Yes
 | CreateDate | datetime | 8 | No
 | ForceExpiration | bit | 1 | No
Indexes Indexes
Name | Columns | Unique
ac_UserPasswords_PK | UserId, PasswordNumber | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Users_ac_UserPasswords_FK1 | Cascade | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_UserPasswords]
(
[UserId] [int] NOT NULL,
[PasswordNumber] [tinyint] NOT NULL,
[Password] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[PasswordFormat] [nvarchar] (10) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CreateDate] [datetime] NOT NULL,
[ForceExpiration] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserPasswords] ADD CONSTRAINT [ac_UserPasswords_PK] PRIMARY KEY CLUSTERED ([UserId], [PasswordNumber]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserPasswords] ADD CONSTRAINT [ac_Users_ac_UserPasswords_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Users]
  • dbo


[dbo].[ac_UserPersonalization]

Tables [dbo].[ac_UserPersonalization]
.\SQL2005 > AC707 > Tables > dbo.ac_UserPersonalization
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Paths_ac_UserPersonalization_FK1: [dbo].[ac_PersonalizationPaths].PersonalizationPathId | PersonalizationPathId | int | 4 | No
Foreign Keys ac_Users_ac_UserPersonalization_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No
 | PageSettings | image | max | Yes
 | Theme | varchar(100) | 100 | Yes
 | MasterPageFile | varchar(100) | 100 | Yes
 | LastUpdatedDate | datetime | 8 | No
Indexes Indexes
Name | Columns | Unique
ac_UserPersonalization_PK | UserId, PersonalizationPathId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Paths_ac_UserPersonalization_FK1 | Cascade | PersonalizationPathId->[dbo].[ac_PersonalizationPaths].[PersonalizationPathId]
ac_Users_ac_UserPersonalization_FK1 | Cascade | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_UserPersonalization]
(
[PersonalizationPathId] [int] NOT NULL,
[UserId] [int] NOT NULL,
[PageSettings] [image] NULL,
[Theme] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[MasterPageFile] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[LastUpdatedDate] [datetime] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserPersonalization] ADD CONSTRAINT [ac_UserPersonalization_PK] PRIMARY KEY CLUSTERED ([UserId], [PersonalizationPathId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserPersonalization] ADD CONSTRAINT [ac_Paths_ac_UserPersonalization_FK1] FOREIGN KEY ([PersonalizationPathId]) REFERENCES [dbo].[ac_PersonalizationPaths] ([PersonalizationPathId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_UserPersonalization] ADD CONSTRAINT [ac_Users_ac_UserPersonalization_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_PersonalizationPaths]
  • [dbo].[ac_Users]
  • dbo


[dbo].[ac_Users]

Tables [dbo].[ac_Users]
.\SQL2005 > AC707 > Tables > dbo.ac_Users
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Users_PK: UserId | UserId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Users_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | UserName | nvarchar(255) | 510 | No |
 | LoweredUserName | nvarchar(255) | 510 | No |
 | Email | nvarchar(255) | 510 | Yes |
 | LoweredEmail | nvarchar(255) | 510 | Yes |
Foreign Keys ac_Affiliates_ac_Users_FK1: [dbo].[ac_Affiliates].AffiliateId | AffiliateId | int | 4 | Yes |
 | AffiliateReferralDate | datetime | 8 | Yes |
 | PrimaryAddressId | int | 4 | Yes |
 | PrimaryWishlistId | int | 4 | Yes |
 | PayPalId | nvarchar(50) | 100 | Yes |
 | PasswordQuestion | nvarchar(255) | 510 | Yes |
 | PasswordAnswer | nvarchar(255) | 510 | Yes |
 | IsApproved | bit | 1 | No |
 | IsAnonymous | bit | 1 | No |
 | IsLockedOut | bit | 1 | No |
 | CreateDate | datetime | 8 | No |
 | LastActivityDate | datetime | 8 | Yes |
 | LastLoginDate | datetime | 8 | Yes |
 | LastPasswordChangedDate | datetime | 8 | Yes |
 | LastLockoutDate | datetime | 8 | Yes |
 | FailedPasswordAttemptCount | int | 4 | No |
 | FailedPasswordAttemptWindowStart | datetime | 8 | Yes |
 | FailedPasswordAnswerAttemptCount | int | 4 | No |
 | FailedPasswordAnswerAttemptWindowStart | datetime | 8 | Yes |
 | Comment | nvarchar(max) | max | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Users_PK: UserId | ac_Users_PK | UserId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Affiliates_ac_Users_FK1 | SetNull | AffiliateId->[dbo].[ac_Affiliates].[AffiliateId]
ac_Stores_ac_Users_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Users]
(
[UserId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[UserName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[LoweredUserName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[LoweredEmail] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[AffiliateId] [int] NULL,
[AffiliateReferralDate] [datetime] NULL,
[PrimaryAddressId] [int] NULL,
[PrimaryWishlistId] [int] NULL,
[PayPalId] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PasswordQuestion] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PasswordAnswer] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[IsApproved] [bit] NOT NULL,
[IsAnonymous] [bit] NOT NULL,
[IsLockedOut] [bit] NOT NULL,
[CreateDate] [datetime] NOT NULL,
[LastActivityDate] [datetime] NULL,
[LastLoginDate] [datetime] NULL,
[LastPasswordChangedDate] [datetime] NULL,
[LastLockoutDate] [datetime] NULL,
[FailedPasswordAttemptCount] [int] NOT NULL,
[FailedPasswordAttemptWindowStart] [datetime] NULL,
[FailedPasswordAnswerAttemptCount] [int] NOT NULL,
[FailedPasswordAnswerAttemptWindowStart] [datetime] NULL,
[Comment] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Users] ADD CONSTRAINT [ac_Users_PK] PRIMARY KEY CLUSTERED ([UserId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Users] ADD CONSTRAINT [ac_Affiliates_ac_Users_FK1] FOREIGN KEY ([AffiliateId]) REFERENCES [dbo].[ac_Affiliates] ([AffiliateId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Users] ADD CONSTRAINT [ac_Stores_ac_Users_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Affiliates]
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Addresses]
  • [dbo].[ac_AuditEvents]
  • [dbo].[ac_Baskets]
  • [dbo].[ac_OrderNotes]
  • [dbo].[ac_Orders]
  • [dbo].[ac_PageViews]
  • [dbo].[ac_Profiles]
  • [dbo].[ac_Subscriptions]
  • [dbo].[ac_UserGroups]
  • [dbo].[ac_UserPasswords]
  • [dbo].[ac_UserPersonalization]
  • [dbo].[ac_UserSettings]
  • [dbo].[ac_Wishlists]


[dbo].[ac_UserSettings]

Tables [dbo].[ac_UserSettings]
.\SQL2005 > AC707 > Tables > dbo.ac_UserSettings
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_UserSettings_PK: UserSettingId | UserSettingId | int | 4 | No | 1 - 1
Foreign Keys ac_Users_ac_UserSettings_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No |
 | FieldName | nvarchar(255) | 510 | No |
 | FieldValue | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_UserSettings_PK: UserSettingId | ac_UserSettings_PK | UserSettingId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Users_ac_UserSettings_FK1 | Cascade | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_UserSettings]
(
[UserSettingId] [int] NOT NULL IDENTITY(1, 1),
[UserId] [int] NOT NULL,
[FieldName] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[FieldValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserSettings] ADD CONSTRAINT [ac_UserSettings_PK] PRIMARY KEY CLUSTERED ([UserSettingId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_UserSettings] ADD CONSTRAINT [ac_Users_ac_UserSettings_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Users]
  • dbo


[dbo].[ac_VendorGroups]

Tables [dbo].[ac_VendorGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_VendorGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_Vendors_ac_VendorGroups_FK1: [dbo].[ac_Vendors].VendorId | VendorId | int | 4 | No
Foreign Keys ac_Groups_ac_VendorGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_VendorGroups_PK | GroupId, VendorId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Groups_ac_VendorGroups_FK1 | GroupId->[dbo].[ac_Groups].[GroupId]
ac_Vendors_ac_VendorGroups_FK1 | VendorId->[dbo].[ac_Vendors].[VendorId]
SQL Script
CREATE TABLE [dbo].[ac_VendorGroups]
(
[VendorId] [int] NOT NULL,
[GroupId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VendorGroups] ADD CONSTRAINT [ac_VendorGroups_PK] PRIMARY KEY CLUSTERED ([GroupId], [VendorId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VendorGroups] ADD CONSTRAINT [ac_Groups_ac_VendorGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId])
GO
ALTER TABLE [dbo].[ac_VendorGroups] ADD CONSTRAINT [ac_Vendors_ac_VendorGroups_FK1] FOREIGN KEY ([VendorId]) REFERENCES [dbo].[ac_Vendors] ([VendorId])
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_Vendors]
  • dbo


[dbo].[ac_Vendors]

Tables [dbo].[ac_Vendors]
.\SQL2005 > AC707 > Tables > dbo.ac_Vendors
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Vendors_PK: VendorId | VendorId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Vendors_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | Email | nvarchar(255) | 510 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Vendors_PK: VendorId | ac_Vendors_PK | VendorId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Vendors_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Vendors]
(
[VendorId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Vendors] ADD CONSTRAINT [ac_Vendors_PK] PRIMARY KEY CLUSTERED ([VendorId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Vendors] ADD CONSTRAINT [ac_Stores_ac_Vendors_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Products]
  • [dbo].[ac_VendorGroups]


[dbo].[ac_VolumeDiscountGroups]

Tables [dbo].[ac_VolumeDiscountGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_VolumeDiscountGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls
Foreign Keys ac_VolumeDiscounts_ac_VolumeDiscountGroups_FK1: [dbo].[ac_VolumeDiscounts].VolumeDiscountId | VolumeDiscountId | int | 4 | No
Foreign Keys ac_Groups_ac_VolumeDiscountGroups_FK1: [dbo].[ac_Groups].GroupId | GroupId | int | 4 | No
Indexes Indexes
Name | Columns | Unique
ac_VolumeDiscountGroups_PK | GroupId, VolumeDiscountId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Groups_ac_VolumeDiscountGroups_FK1 | Cascade | GroupId->[dbo].[ac_Groups].[GroupId]
ac_VolumeDiscounts_ac_VolumeDiscountGroups_FK1 | Cascade | VolumeDiscountId->[dbo].[ac_VolumeDiscounts].[VolumeDiscountId]
SQL Script
CREATE TABLE [dbo].[ac_VolumeDiscountGroups]
(
[VolumeDiscountId] [int] NOT NULL,
[GroupId] [int] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VolumeDiscountGroups] ADD CONSTRAINT [ac_VolumeDiscountGroups_PK] PRIMARY KEY CLUSTERED ([GroupId], [VolumeDiscountId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VolumeDiscountGroups] ADD CONSTRAINT [ac_Groups_ac_VolumeDiscountGroups_FK1] FOREIGN KEY ([GroupId]) REFERENCES [dbo].[ac_Groups] ([GroupId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_VolumeDiscountGroups] ADD CONSTRAINT [ac_VolumeDiscounts_ac_VolumeDiscountGroups_FK1] FOREIGN KEY ([VolumeDiscountId]) REFERENCES [dbo].[ac_VolumeDiscounts] ([VolumeDiscountId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Groups]
  • [dbo].[ac_VolumeDiscounts]
  • dbo


[dbo].[ac_VolumeDiscountLevels]

Tables [dbo].[ac_VolumeDiscountLevels]
.\SQL2005 > AC707 > Tables > dbo.ac_VolumeDiscountLevels
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_VolumeDiscountLevels_PK: VolumeDiscountLevelId | VolumeDiscountLevelId | int | 4 | No | 1 - 1
Foreign Keys ac_Discounts_ac_DiscountMatrix_FK1: [dbo].[ac_VolumeDiscounts].VolumeDiscountId | VolumeDiscountId | int | 4 | No |
 | MinValue | decimal(12,4) | 9 | No |
 | MaxValue | decimal(12,4) | 9 | No |
 | DiscountAmount | decimal(12,4) | 9 | No |
 | IsPercent | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_VolumeDiscountLevels_PK: VolumeDiscountLevelId | ac_VolumeDiscountLevels_PK | VolumeDiscountLevelId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Discounts_ac_DiscountMatrix_FK1 | Cascade | VolumeDiscountId->[dbo].[ac_VolumeDiscounts].[VolumeDiscountId]
SQL Script
CREATE TABLE [dbo].[ac_VolumeDiscountLevels]
(
[VolumeDiscountLevelId] [int] NOT NULL IDENTITY(1, 1),
[VolumeDiscountId] [int] NOT NULL,
[MinValue] [decimal] (12, 4) NOT NULL,
[MaxValue] [decimal] (12, 4) NOT NULL,
[DiscountAmount] [decimal] (12, 4) NOT NULL,
[IsPercent] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VolumeDiscountLevels] ADD CONSTRAINT [ac_VolumeDiscountLevels_PK] PRIMARY KEY CLUSTERED ([VolumeDiscountLevelId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VolumeDiscountLevels] ADD CONSTRAINT [ac_Discounts_ac_DiscountMatrix_FK1] FOREIGN KEY ([VolumeDiscountId]) REFERENCES [dbo].[ac_VolumeDiscounts] ([VolumeDiscountId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_VolumeDiscounts]
  • dbo


[dbo].[ac_VolumeDiscounts]

Tables [dbo].[ac_VolumeDiscounts]
.\SQL2005 > AC707 > Tables > dbo.ac_VolumeDiscounts
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_VolumeDiscounts_PK: VolumeDiscountId | VolumeDiscountId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Discounts_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | No |
 | IsValueBased | bit | 1 | No |
 | IsGlobal | bit | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_VolumeDiscounts_PK: VolumeDiscountId | ac_VolumeDiscounts_PK | VolumeDiscountId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Discounts_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_VolumeDiscounts]
(
[VolumeDiscountId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[IsValueBased] [bit] NOT NULL,
[IsGlobal] [bit] NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VolumeDiscounts] ADD CONSTRAINT [ac_VolumeDiscounts_PK] PRIMARY KEY CLUSTERED ([VolumeDiscountId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_VolumeDiscounts] ADD CONSTRAINT [ac_Stores_ac_Discounts_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_CategoryVolumeDiscounts]
  • [dbo].[ac_ProductVolumeDiscounts]
  • [dbo].[ac_VolumeDiscountGroups]
  • [dbo].[ac_VolumeDiscountLevels]


[dbo].[ac_Warehouses]

Tables [dbo].[ac_Warehouses]
.\SQL2005 > AC707 > Tables > dbo.ac_Warehouses
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Warehouses_PK: WarehouseId | WarehouseId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Warehouses_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(50) | 100 | No |
 | Address1 | nvarchar(255) | 510 | Yes |
 | Address2 | nvarchar(255) | 510 | Yes |
 | City | nvarchar(50) | 100 | Yes |
 | Province | nvarchar(50) | 100 | Yes |
 | PostalCode | nvarchar(15) | 30 | Yes |
Foreign Keys ac_Countries_ac_Warehouses_FK1: [dbo].[ac_Countries].CountryCode | CountryCode | char(2) | 2 | Yes |
 | Phone | nvarchar(50) | 100 | Yes |
 | Fax | nvarchar(50) | 100 | Yes |
 | Email | nvarchar(255) | 510 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Warehouses_PK: WarehouseId | ac_Warehouses_PK | WarehouseId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Countries_ac_Warehouses_FK1 | SetNull | CountryCode->[dbo].[ac_Countries].[CountryCode]
ac_Stores_ac_Warehouses_FK1 |  | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Warehouses]
(
[WarehouseId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[Address1] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Address2] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[City] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Province] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[PostalCode] [nvarchar] (15) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CountryCode] [char] (2) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Phone] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Fax] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Email] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Warehouses] ADD CONSTRAINT [ac_Warehouses_PK] PRIMARY KEY CLUSTERED ([WarehouseId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Warehouses] ADD CONSTRAINT [ac_Countries_ac_Warehouses_FK1] FOREIGN KEY ([CountryCode]) REFERENCES [dbo].[ac_Countries] ([CountryCode]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_Warehouses] ADD CONSTRAINT [ac_Stores_ac_Warehouses_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Countries]
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_BasketShipments]
  • [dbo].[ac_OrderShipments]
  • [dbo].[ac_Products]
  • [dbo].[ac_ShipMethodWarehouses]


[dbo].[ac_Webpages]

Tables [dbo].[ac_Webpages]
.\SQL2005 > AC707 > Tables > dbo.ac_Webpages
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Webpages_PK: WebpageId | WebpageId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_Webpages_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(100) | 200 | Yes |
 | Summary | nvarchar(max) | max | Yes |
 | Description | nvarchar(max) | max | Yes |
 | ThumbnailUrl | varchar(255) | 255 | Yes |
 | ThumbnailAltText | nvarchar(255) | 510 | Yes |
 | DisplayPage | varchar(100) | 100 | Yes |
 | Theme | varchar(100) | 100 | Yes |
 | HtmlHead | nvarchar(max) | max | Yes |
 | VisibilityId | tinyint | 1 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Webpages_PK: WebpageId | ac_Webpages_PK | WebpageId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_Webpages_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_Webpages]
(
[WebpageId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Summary] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Description] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ThumbnailUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ThumbnailAltText] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[DisplayPage] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Theme] [varchar] (100) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[HtmlHead] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[VisibilityId] [tinyint] NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Webpages] ADD CONSTRAINT [ac_Webpages_PK] PRIMARY KEY CLUSTERED ([WebpageId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Webpages] ADD CONSTRAINT [ac_Stores_ac_Webpages_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo


[dbo].[ac_WishlistItemInputs]

Tables [dbo].[ac_WishlistItemInputs]
.\SQL2005 > AC707 > Tables > dbo.ac_WishlistItemInputs
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_WishlistItemInputs_PK: WishlistItemInputId | WishlistItemInputId | int | 4 | No | 1 - 1
Foreign Keys ac_WishlistItems_ac_WishlistItemInputs_FK1: [dbo].[ac_WishlistItems].WishlistItemId | WishlistItemId | int | 4 | No |
Foreign Keys ac_InputFields_ac_WishlistItemInputs_FK1: [dbo].[ac_InputFields].InputFieldId | InputFieldId | int | 4 | No |
 | InputValue | nvarchar(max) | max | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_WishlistItemInputs_PK: WishlistItemInputId | ac_WishlistItemInputs_PK | WishlistItemInputId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_InputFields_ac_WishlistItemInputs_FK1 | Cascade | InputFieldId->[dbo].[ac_InputFields].[InputFieldId]
ac_WishlistItems_ac_WishlistItemInputs_FK1 | Cascade | WishlistItemId->[dbo].[ac_WishlistItems].[WishlistItemId]
SQL Script
CREATE TABLE [dbo].[ac_WishlistItemInputs]
(
[WishlistItemInputId] [int] NOT NULL IDENTITY(1, 1),
[WishlistItemId] [int] NOT NULL,
[InputFieldId] [int] NOT NULL,
[InputValue] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WishlistItemInputs] ADD CONSTRAINT [ac_WishlistItemInputs_PK] PRIMARY KEY CLUSTERED ([WishlistItemInputId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WishlistItemInputs] ADD CONSTRAINT [ac_InputFields_ac_WishlistItemInputs_FK1] FOREIGN KEY ([InputFieldId]) REFERENCES [dbo].[ac_InputFields] ([InputFieldId]) ON DELETE CASCADE
GO
ALTER TABLE [dbo].[ac_WishlistItemInputs] ADD CONSTRAINT [ac_WishlistItems_ac_WishlistItemInputs_FK1] FOREIGN KEY ([WishlistItemId]) REFERENCES [dbo].[ac_WishlistItems] ([WishlistItemId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_InputFields]
  • [dbo].[ac_WishlistItems]
  • dbo


[dbo].[ac_WishlistItems]

Tables [dbo].[ac_WishlistItems]
.\SQL2005 > AC707 > Tables > dbo.ac_WishlistItems
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_WishlistItems_PK: WishlistItemId | WishlistItemId | int | 4 | No | 1 - 1
Foreign Keys ac_Wishlists_ac_WishlistItems_FK1: [dbo].[ac_Wishlists].WishlistId | WishlistId | int | 4 | No |
Foreign Keys ac_Products_ac_WishlistItems_FK1: [dbo].[ac_Products].ProductId | ProductId | int | 4 | No |
 | OptionList | varchar(255) | 255 | Yes |
 | KitList | varchar(255) | 255 | Yes |
 | Price | decimal(12,4) | 9 | Yes |
 | LineMessage | nvarchar(255) | 510 | Yes |
 | CreatedDate | datetime | 8 | No |
 | LastModifiedDate | datetime | 8 | No |
 | Desired | smallint | 2 | No |
 | Received | smallint | 2 | No |
 | Priority | tinyint | 1 | No |
 | Comment | nvarchar(max) | max | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_WishlistItems_PK: WishlistItemId | ac_WishlistItems_PK | WishlistItemId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_Products_ac_WishlistItems_FK1 |  | ProductId->[dbo].[ac_Products].[ProductId]
ac_Wishlists_ac_WishlistItems_FK1 | Cascade | WishlistId->[dbo].[ac_Wishlists].[WishlistId]
SQL Script
CREATE TABLE [dbo].[ac_WishlistItems]
(
[WishlistItemId] [int] NOT NULL IDENTITY(1, 1),
[WishlistId] [int] NOT NULL,
[ProductId] [int] NOT NULL,
[OptionList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[KitList] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[Price] [decimal] (12, 4) NULL,
[LineMessage] [nvarchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[CreatedDate] [datetime] NOT NULL,
[LastModifiedDate] [datetime] NOT NULL,
[Desired] [smallint] NOT NULL,
[Received] [smallint] NOT NULL,
[Priority] [tinyint] NOT NULL,
[Comment] [nvarchar] (max) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY] TEXTIMAGE_ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WishlistItems] ADD CONSTRAINT [ac_WishlistItems_PK] PRIMARY KEY CLUSTERED ([WishlistItemId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WishlistItems] ADD CONSTRAINT [ac_Products_ac_WishlistItems_FK1] FOREIGN KEY ([ProductId]) REFERENCES [dbo].[ac_Products] ([ProductId])
GO
ALTER TABLE [dbo].[ac_WishlistItems] ADD CONSTRAINT [ac_Wishlists_ac_WishlistItems_FK1] FOREIGN KEY ([WishlistId]) REFERENCES [dbo].[ac_Wishlists] ([WishlistId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_Products]
  • [dbo].[ac_Wishlists]
  • dbo
Used By
  • [dbo].[ac_BasketItems]
  • [dbo].[ac_OrderItems]
  • [dbo].[ac_WishlistItemInputs]


[dbo].[ac_Wishlists]

Tables [dbo].[ac_Wishlists]
.\SQL2005 > AC707 > Tables > dbo.ac_Wishlists
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_Wishlists_PK: WishlistId | WishlistId | int | 4 | No | 1 - 1
Foreign Keys ac_Users_ac_Wishlists_FK1: [dbo].[ac_Users].UserId | UserId | int | 4 | No |
 | Name | nvarchar(50) | 100 | Yes |
 | ViewPassword | nvarchar(50) | 100 | Yes |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_Wishlists_PK: WishlistId | ac_Wishlists_PK | WishlistId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Users_ac_Wishlists_FK1 | UserId->[dbo].[ac_Users].[UserId]
SQL Script
CREATE TABLE [dbo].[ac_Wishlists]
(
[WishlistId] [int] NOT NULL IDENTITY(1, 1),
[UserId] [int] NOT NULL,
[Name] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ViewPassword] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Wishlists] ADD CONSTRAINT [ac_Wishlists_PK] PRIMARY KEY CLUSTERED ([WishlistId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_Wishlists] ADD CONSTRAINT [ac_Users_ac_Wishlists_FK1] FOREIGN KEY ([UserId]) REFERENCES [dbo].[ac_Users] ([UserId])
GO
Uses
  • [dbo].[ac_Users]
  • dbo
Used By
  • [dbo].[ac_WishlistItems]


[dbo].[ac_WrapGroups]

Tables [dbo].[ac_WrapGroups]
.\SQL2005 > AC707 > Tables > dbo.ac_WrapGroups
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity
Cluster Primary Key ac_WrapGroups_PK: WrapGroupId | WrapGroupId | int | 4 | No | 1 - 1
Foreign Keys ac_Stores_ac_WrapGroups_FK1: [dbo].[ac_Stores].StoreId | StoreId | int | 4 | No |
 | Name | nvarchar(50) | 100 | No |
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_WrapGroups_PK: WrapGroupId | ac_WrapGroups_PK | WrapGroupId | Yes
Foreign Keys Foreign Keys
Name | Columns
ac_Stores_ac_WrapGroups_FK1 | StoreId->[dbo].[ac_Stores].[StoreId]
SQL Script
CREATE TABLE [dbo].[ac_WrapGroups]
(
[WrapGroupId] [int] NOT NULL IDENTITY(1, 1),
[StoreId] [int] NOT NULL,
[Name] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WrapGroups] ADD CONSTRAINT [ac_WrapGroups_PK] PRIMARY KEY CLUSTERED ([WrapGroupId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WrapGroups] ADD CONSTRAINT [ac_Stores_ac_WrapGroups_FK1] FOREIGN KEY ([StoreId]) REFERENCES [dbo].[ac_Stores] ([StoreId])
GO
Uses
  • [dbo].[ac_Stores]
  • dbo
Used By
  • [dbo].[ac_Products]
  • [dbo].[ac_WrapStyles]


[dbo].[ac_WrapStyles]

Tables [dbo].[ac_WrapStyles]
.\SQL2005 > AC707 > Tables > dbo.ac_WrapStyles
  • Properties
  • Columns
  • Indexes
  • Foreign Keys
  • SQL Script
  • Uses
  • Used By
Properties
Property | Value
Collation | SQL_Latin1_General_CP1_CI_AS
Row Count (~) | 0
Created | 2:33:48 PM Friday, July 15, 2011
Last Modified | 2:33:49 PM Friday, July 15, 2011
Columns
 | Name | Data Type | Max Length (Bytes) | Allow Nulls | Identity | Default
Cluster Primary Key ac_WrapStyles_PK: WrapStyleId | WrapStyleId | int | 4 | No | 1 - 1 |
Foreign Keys ac_WrapGroups_ac_WrapStyles_FK1: [dbo].[ac_WrapGroups].WrapGroupId | WrapGroupId | int | 4 | No |  |
 | Name | nvarchar(50) | 100 | No |  |
Foreign Keys ac_TaxCodes_ac_WrapStyles_FK1: [dbo].[ac_TaxCodes].TaxCodeId | TaxCodeId | int | 4 | Yes |  |
 | Price | decimal(12,4) | 9 | No |  |
 | ThumbnailUrl | varchar(255) | 255 | Yes |  |
 | ImageUrl | varchar(255) | 255 | Yes |  |
 | OrderBy | smallint | 2 | No |  | ((0))
Indexes Indexes
 | Name | Columns | Unique
Cluster Primary Key ac_WrapStyles_PK: WrapStyleId | ac_WrapStyles_PK | WrapStyleId | Yes
Foreign Keys Foreign Keys
Name | Delete | Columns
ac_TaxCodes_ac_WrapStyles_FK1 | SetNull | TaxCodeId->[dbo].[ac_TaxCodes].[TaxCodeId]
ac_WrapGroups_ac_WrapStyles_FK1 | Cascade | WrapGroupId->[dbo].[ac_WrapGroups].[WrapGroupId]
SQL Script
CREATE TABLE [dbo].[ac_WrapStyles]
(
[WrapStyleId] [int] NOT NULL IDENTITY(1, 1),
[WrapGroupId] [int] NOT NULL,
[Name] [nvarchar] (50) COLLATE SQL_Latin1_General_CP1_CI_AS NOT NULL,
[TaxCodeId] [int] NULL,
[Price] [decimal] (12, 4) NOT NULL,
[ThumbnailUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[ImageUrl] [varchar] (255) COLLATE SQL_Latin1_General_CP1_CI_AS NULL,
[OrderBy] [smallint] NOT NULL CONSTRAINT [DF__ac_WrapSt__Order__173876EA] DEFAULT ((0))
) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WrapStyles] ADD CONSTRAINT [ac_WrapStyles_PK] PRIMARY KEY CLUSTERED ([WrapStyleId]) ON [PRIMARY]
GO
ALTER TABLE [dbo].[ac_WrapStyles] ADD CONSTRAINT [ac_TaxCodes_ac_WrapStyles_FK1] FOREIGN KEY ([TaxCodeId]) REFERENCES [dbo].[ac_TaxCodes] ([TaxCodeId]) ON DELETE SET NULL
GO
ALTER TABLE [dbo].[ac_WrapStyles] ADD CONSTRAINT [ac_WrapGroups_ac_WrapStyles_FK1] FOREIGN KEY ([WrapGroupId]) REFERENCES [dbo].[ac_WrapGroups] ([WrapGroupId]) ON DELETE CASCADE
GO
Uses
  • [dbo].[ac_TaxCodes]
  • [dbo].[ac_WrapGroups]
  • dbo
Used By
  • [dbo].[ac_BasketItems]
  • [dbo].[ac_OrderItems]


Stored Procedures

Stored Procedures Stored Procedures
.\SQL2005 > AC707 > Stored Procedures

Name
dbo.acsp_MergeUserGroupMembers


[dbo].[acsp_MergeUserGroupMembers]

Stored Procedures [dbo].[acsp_MergeUserGroupMembers]
.\SQL2005 > AC707 > Stored Procedures > dbo.acsp_MergeUserGroupMembers
  • Properties
  • Parameters
  • SQL Script
  • Uses
Properties
Property | Value
ANSI Nulls On | Yes
Quoted Identifier On | Yes
Parameters
Name | Data Type | Max Length (Bytes)
@sourceGroupId | int | 4
@targetGroupId | int | 4
SQL Script

/* Create procedure/function acsp_MergeUserGroupMembers. */
/* MERGES MEMBERS OF SOURCE GROUP TO TARGET GROUP */
create procedure [dbo].[acsp_MergeUserGroupMembers]
@sourceGroupId int,
@targetGroupId int
as
begin
/* BUILD TEMP TABLE FOR SOURCE GROUP */
SELECT UG.UserId, UG.GroupId, S.SubscriptionId, S.ExpirationDate
INTO #sourceGroup
FROM ac_UserGroups AS UG LEFT JOIN ac_Subscriptions AS S
ON UG.SubscriptionId = S.SubscriptionId
WHERE UG.GroupId = @sourceGroupId;

/* BUILD TEMP TABLE FOR TARGET GROUP */
SELECT UG.UserId, UG.GroupId, S.SubscriptionId, S.ExpirationDate
INTO #targetGroup
FROM ac_UserGroups AS UG LEFT JOIN ac_Subscriptions AS S
ON UG.SubscriptionId = S.SubscriptionId
WHERE UG.GroupId = @targetGroupId;

/* IF BOTH ASSIGNMENTS HAVE NULL EXPRIATIONS, FAVOR TARGET GROUP */
DELETE #sourceGroup
FROM #sourceGroup INNER JOIN #targetGroup ON #sourceGroup.UserId = #targetGroup.UserId
WHERE #sourceGroup.ExpirationDate IS NULL AND #targetGroup.ExpirationDate IS NULL;

/* IF SOURCE GROUP EXPIRES BEFORE TARGET GROUP, FAVOR TARGET GROUP */
DELETE #sourceGroup
FROM #sourceGroup INNER JOIN #targetGroup ON #sourceGroup.UserId = #targetGroup.UserId
WHERE #sourceGroup.ExpirationDate IS NOT NULL
AND (#targetGroup.ExpirationDate IS NULL OR #sourceGroup.ExpirationDate < #targetGroup.ExpirationDate);

/* IF SOURCE GROUP EXPIRES AFTER TARGET GROUP, FAVOR SOURCE GROUP */
DELETE #targetGroup
FROM #targetGroup INNER JOIN #sourceGroup ON #targetGroup.UserId = #sourceGroup.UserId
WHERE #targetGroup.ExpirationDate IS NOT NULL
AND (#sourceGroup.ExpirationDate IS NULL OR #targetGroup.ExpirationDate < #sourceGroup.ExpirationDate);

/* ANY RECORD NOT APPEARING IN SOURCEGROUP TEMP TABLE SHOULD BE REMOVED */
DELETE FROM ac_UserGroups
WHERE UserId NOT IN (SELECT UserId FROM #sourceGroup)
AND GroupID = @sourceGroupId;

/* ANY RECORD NOT APPEARING IN TARGETGROUP TEMP TABLE SHOULD BE REMOVED */
DELETE FROM ac_UserGroups
WHERE UserId NOT IN (SELECT UserId FROM #targetGroup)
AND GroupID = @targetGroupId;

/* RENUMBER ALL SOURCE GROUP RECORDS TO TO TARGET GROUP */
UPDATE ac_UserGroups
SET GroupId = @targetGroupId
WHERE GroupId = @sourceGroupId;

/* DROP TEMP TABLES */
DROP TABLE #sourceGroup;
DROP TABLE #targetGroup;
end

GO
Uses
  • [dbo].[ac_Subscriptions]
  • [dbo].[ac_UserGroups]
  • dbo